aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/ratbox-services/Makefile75
-rw-r--r--irc/ratbox-services/distinfo15
-rw-r--r--irc/ratbox-services/files/patch-Makefile.in17
-rw-r--r--irc/ratbox-services/files/patch-help_Makefile.in6
-rw-r--r--irc/ratbox-services/files/patch-tools_dbupgrade.pl23
-rw-r--r--irc/ratbox-services/files/patch-tools_generate-schema.pl17
-rw-r--r--irc/ratbox-services/files/pkg-install.in17
-rw-r--r--irc/ratbox-services/files/pkg-message.in46
-rw-r--r--irc/ratbox-services/pkg-descr6
-rw-r--r--irc/ratbox-services/pkg-plist304
10 files changed, 356 insertions, 170 deletions
diff --git a/irc/ratbox-services/Makefile b/irc/ratbox-services/Makefile
index ffab31978a2f..5564ab6f7497 100644
--- a/irc/ratbox-services/Makefile
+++ b/irc/ratbox-services/Makefile
@@ -5,15 +5,19 @@
# $FreeBSD$
PORTNAME= ratbox-services
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1.2
CATEGORIES= irc
MASTER_SITES= ftp://ftp.ircd-ratbox.org/pub/ircd-ratbox/${PORTNAME}/ \
ftp://ftp.demon.co.uk/pub/mirrors/ircd-ratbox/${PORTNAME}/ \
http://services.ircd-ratbox.org/download/ \
- ftp://ftp.parodius.com/pub/ircd-ratbox/${PORTNAME}/ \
- http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
+ ftp://ftp.parodius.com/pub/ircd-ratbox/${PORTNAME}/
EXTRACT_SUFX= .tgz
+PATCH_SITES= http://www.elasticmind.net/freebsd/ports/distfiles/ \
+ http://jsreedinc.com/freebsd/ports/patches/ \
+ http://www.atarininja.org/~wxs/distfiles/
+PATCHFILES= patch-autoconf_configure.in.gz patch-configure.gz patch-include_setup.h.in.gz
+
MAINTAINER= shaun@FreeBSD.org
COMMENT= A highly configurable services package for use with ircd-ratbox
@@ -22,20 +26,19 @@ USE_RC_SUBR= ratbox-services.sh
LOGDIR?= /var/log
RUNDIR?= /var/run
DBDIR?= /var/db/${PORTNAME}
+PERL?= ${LOCALBASE}/bin/perl
SUB_FILES= pkg-message pkg-install
-PLIST_SUB= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR}
-SUB_LIST= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR}
+PLIST_SUB= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR} PERL=${PERL}
+SUB_LIST= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR} DBDIR=${DBDIR} PERL=${PERL}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/ \
+CONFIGURE_ARGS+=--prefix=${PREFIX} \
+ --sysconfdir=${PREFIX}/etc/ \
--with-logdir=${LOGDIR} \
--with-rundir=${RUNDIR} \
- --with-helpdir=${DATADIR}/help \
- --with-sqlite=${LOCALBASE} \
+ --with-helpdir=${DATADIR}/help \
--without-sqlitebuild
-USE_SQLITE= 2
-
PORTDOCS= operguide.txt
#-- Options ------------------------------------------------------------
@@ -48,7 +51,10 @@ OPTIONS= NICKSERV "Enable nickname registration service" on \
JUPESERV "Enable jupe service" on \
OPERBOT "Enable operbot service" on \
GLOBALMSG "Enable global messaging service" on \
- BANSERV "Enable ban service" on
+ BANSERV "Enable ban service" on \
+ WATCHSERV "Enable command watching service" on \
+ SQLITE "Enable sqlite3 support (default)" on \
+ PGSQL "Enable pgsql backend support" off
#----------------------------------------------------------------------
@@ -90,6 +96,31 @@ CONFIGURE_ARGS+= --disable-global
CONFIGURE_ARGS+= --disable-banserv
.endif
+.if defined(WITHOUT_WATCHSERV)
+CONFIGURE_ARGS+= --disable-watchserv
+.endif
+
+.if !defined(WITH_SQLITE) && !defined(WITH_PGSQL)
+IGNORE= requires either an sqlite or pgsql backend
+.endif
+
+.if defined(WITH_SQLITE)
+USE_SQLITE= 3
+CONFIGURE_ARGS+= --enable-sqlite3=${LOCALBASE}
+.endif
+
+# This ratbox-services version has known problems when integrating
+# with MySQL and should be avoided until it is fixed in version 1.1.3
+#.if defined(WITH_MYSQL)
+#USE_MYSQL
+#CONFIGURE_ARGS+= --enable-mysql=${LOCALBASE}
+#.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL
+CONFIGURE_ARGS+= --enable-pgsql=${LOCALBASE}
+.endif
+
#-- User Configuration -------------------------------------------------
.if defined(NICKLEN)
@@ -100,6 +131,10 @@ CONFIGURE_ARGS+= --with-nicklen=${NICKLEN}
CONFIGURE_ARGS+= --with-topiclen=${TOPICLEN}
.endif
+.if defined(USERREGLEN)
+CONFIGURE_ARGS+= --with-userreglen=${USERREGLEN}
+.endif
+
#-----------------------------------------------------------------------
pre-configure:
@@ -107,6 +142,8 @@ pre-configure:
@${ECHO_MSG} "This port has additional options:"
@${ECHO_MSG} " NICKLEN [default 9, max 50] - Max nick length on server"
@${ECHO_MSG} " TOPICLEN [default 160, max 390] - Max topic length"
+ @${ECHO_MSG} " USERREGLEN [default 10] - Max registered username"
+ @${ECHO_MSG} " length on services"
@${ECHO_MSG} ""
@${ECHO_MSG} "THESE SHOULD BE CONSISTENT WITH YOUR IRCD-RATBOX SERVER/NETWORK!"
@${ECHO_MSG} ""
@@ -117,6 +154,9 @@ post-patch:
@${REINPLACE_CMD} -e "s#-O[02]##g" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s#%%DBDIR%%#${DBDIR}#g" ${WRKSRC}/include/config.h
+ @${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#g" \
+ ${WRKSRC}/tools/generate-schema.pl \
+ ${WRKSRC}/tools/dbupgrade.pl
pre-su-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -128,9 +168,18 @@ post-install:
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
${INSTALL_PROGRAM} ${WRKSRC}/src/ratbox-services ${PREFIX}/sbin/
- ${INSTALL_SCRIPT} ${WRKSRC}/tools/ircd-shortcut.pl ${PREFIX}/bin/ircd-shortcut
${INSTALL_DATA} ${WRKSRC}/doc/example.conf ${PREFIX}/etc/ratbox-services.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/doc/schema.txt ${DATADIR}/schema.sql
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}/tools/ && \
+ ${COPYTREE_SHARE} \* ${DATADIR} "! -name dbupgrade.pl.bak \
+ ! -name dbupgrade.pl.orig \
+ ! -name generate-schema.pl.bak \
+ ! -name generate-schema.pl.orig")
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL.mysql ${DOCSDIR}/INSTALL.mysql
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL.pgsql ${DOCSDIR}/INSTALL.pgsql
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL.sqlite ${DOCSDIR}/INSTALL.sqlite
+ ${INSTALL_DATA} ${WRKSRC}/UPGRADING ${DOCSDIR}/UPGRADING
+ ${INSTALL_DATA} ${WRKSRC}/DBMOVE ${DOCSDIR}/DBMOVE
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
diff --git a/irc/ratbox-services/distinfo b/irc/ratbox-services/distinfo
index 4cc7c73185ce..cad64d753c3a 100644
--- a/irc/ratbox-services/distinfo
+++ b/irc/ratbox-services/distinfo
@@ -1,3 +1,12 @@
-MD5 (ratbox-services-1.0.3.tgz) = acd4598d12b82c367f5a13110d784422
-SHA256 (ratbox-services-1.0.3.tgz) = 10e08ec21522499c8b3e6c1b37300a83f87e74b40a98ef19fcc40cd61127b510
-SIZE (ratbox-services-1.0.3.tgz) = 634213
+MD5 (ratbox-services-1.1.2.tgz) = 45fb80a0cddd98763bb27543172927bc
+SHA256 (ratbox-services-1.1.2.tgz) = cc4562474eda23ccee95185f6c634d91667643f2144abc6bbf0d0ddfe5838d20
+SIZE (ratbox-services-1.1.2.tgz) = 1015493
+MD5 (patch-autoconf_configure.in.gz) = c19461a35f7b593a79465bbeae06d216
+SHA256 (patch-autoconf_configure.in.gz) = 3df14d86ba7a8a3f490ca7be4baf09e6e749d01bfeedd9f05074a04fac61eb55
+SIZE (patch-autoconf_configure.in.gz) = 4797
+MD5 (patch-configure.gz) = 96f38c1c14856cf085bd1bb68774750c
+SHA256 (patch-configure.gz) = 4062f5feb29d2871e421eef50dd43fb2ecea1645db0fd42ae7d8e60e7ddcf2a5
+SIZE (patch-configure.gz) = 54528
+MD5 (patch-include_setup.h.in.gz) = 563a37ef659e607e7ca8015fa3356e8b
+SHA256 (patch-include_setup.h.in.gz) = cdd563ea75766f421c3cd86f53112c44d77d831fde3e5e5a44ea440b7ed1d67f
+SIZE (patch-include_setup.h.in.gz) = 1449
diff --git a/irc/ratbox-services/files/patch-Makefile.in b/irc/ratbox-services/files/patch-Makefile.in
index d5bbdf94849a..469754189a9f 100644
--- a/irc/ratbox-services/files/patch-Makefile.in
+++ b/irc/ratbox-services/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Wed May 18 00:33:18 2005
-+++ Makefile.in Sat Jan 28 22:58:12 2006
+--- ./Makefile.in.orig Mon Apr 10 19:53:23 2006
++++ ./Makefile.in Wed Sep 5 04:08:35 2007
@@ -6,7 +6,7 @@
LIBS=@LIBS@
LDFLAGS=@LDFLAGS@
@@ -9,7 +9,7 @@
prefix=@prefix@
exec_prefix=@prefix@
-@@ -36,17 +36,6 @@
+@@ -37,20 +37,6 @@
done
install: build
@@ -17,13 +17,16 @@
- $(INSTALL) -m 750 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sbindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sysconfdir)
+- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(logdir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(rundir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(helpdir)
+- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 tools/ircd-shortcut.pl $(DESTDIR)$(bindir)
+- $(INSTALL) -m 750 tools/dbupgrade.pl $(DESTDIR)$(bindir)
+- $(INSTALL) -m 640 tools/definetolength.pl $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 src/$(BIN) $(DESTDIR)$(sbindir)
- $(INSTALL) -m 640 doc/example.conf $(DESTDIR)$(sysconfdir)
-- $(INSTALL) -m 640 doc/schema.txt $(DESTDIR)$(sysconfdir)
- @for i in $(SUBDIRS); do \
- echo "install -> $$i"; \
- cd $$i; \
+ $(INSTALL) -m 640 include/setup.h $(DESTDIR)$(includedir)
+ $(INSTALL) -m 640 include/rserv.h $(DESTDIR)$(includedir)
+ $(INSTALL) -m 640 include/channel.h $(DESTDIR)$(includedir)
diff --git a/irc/ratbox-services/files/patch-help_Makefile.in b/irc/ratbox-services/files/patch-help_Makefile.in
index d49a8a82ba6f..2efa0b8b3068 100644
--- a/irc/ratbox-services/files/patch-help_Makefile.in
+++ b/irc/ratbox-services/files/patch-help_Makefile.in
@@ -1,7 +1,7 @@
---- help/Makefile.in.orig Wed Jun 15 15:21:39 2005
-+++ help/Makefile.in Sat Jan 28 23:15:11 2006
+--- ./help/Makefile.in.orig Fri Aug 24 12:32:24 2007
++++ ./help/Makefile.in Fri Aug 24 12:15:25 2007
@@ -10,10 +10,10 @@
- SUBDIRS=alis main operbot chanserv userserv jupeserv operserv nickserv global banserv
+ SUBDIRS=alis main operbot chanserv userserv jupeserv operserv nickserv global banserv watchserv
install:
- $(INSTALL) -m 750 -d $(DESTDIR)$(helpdir)
diff --git a/irc/ratbox-services/files/patch-tools_dbupgrade.pl b/irc/ratbox-services/files/patch-tools_dbupgrade.pl
new file mode 100644
index 000000000000..8ada4c52e9a4
--- /dev/null
+++ b/irc/ratbox-services/files/patch-tools_dbupgrade.pl
@@ -0,0 +1,23 @@
+--- ./tools/dbupgrade.pl.orig Fri Aug 24 13:01:39 2007
++++ ./tools/dbupgrade.pl Fri Aug 24 13:38:23 2007
+@@ -27,9 +27,9 @@
+ exit;
+ }
+
+-unless(-r "../include/setup.h")
++unless(-r "%%PREFIX%%/include/setup.h")
+ {
+- print("Unable to read ../include/setup.h, please run configure first\n");
++ print("Unable to read %%PREFIX%%/include/setup.h, please run configure first\n");
+ exit();
+ }
+
+@@ -71,7 +71,7 @@
+ }
+ else
+ {
+- %vals = &parse_includes("../include");
++ %vals = &parse_includes("%%PREFIX%%/include");
+ }
+
+ while(my ($key, $value) = each(%vals))
diff --git a/irc/ratbox-services/files/patch-tools_generate-schema.pl b/irc/ratbox-services/files/patch-tools_generate-schema.pl
new file mode 100644
index 000000000000..335d2b8ec5ad
--- /dev/null
+++ b/irc/ratbox-services/files/patch-tools_generate-schema.pl
@@ -0,0 +1,17 @@
+--- ./tools/generate-schema.pl.orig Fri Aug 24 12:45:51 2007
++++ ./tools/generate-schema.pl Fri Aug 24 12:49:13 2007
+@@ -15,11 +15,11 @@
+ my @schemas = ("base/schema-mysql.txt", "base/schema-pgsql.txt");
+ my @plain_schemas = ("base/schema-sqlite.txt");
+
+-my %vals = &parse_includes("../include");
++my %vals = &parse_includes("%%PREFIX%%/include");
+
+-unless(-r "../include/setup.h")
++unless(-r "%%PREFIX%%/include/setup.h")
+ {
+- print("Unable to read ../include/setup.h, please run configure first\n");
++ print("Unable to read %%PREFIX%%/include/setup.h, please run configure first\n");
+ exit();
+ }
+
diff --git a/irc/ratbox-services/files/pkg-install.in b/irc/ratbox-services/files/pkg-install.in
index 5aec496c1d8e..f7a260249d5f 100644
--- a/irc/ratbox-services/files/pkg-install.in
+++ b/irc/ratbox-services/files/pkg-install.in
@@ -100,25 +100,22 @@ touch $lf \
&& chown ircservices:ircservices $lf \
&& chmod 640 $lf
-mkdir -p %%DBDIR%%
-db="%%DBDIR%%/ratbox-services.db"
-
-if [ ! -f $db ]; then
- echo "Initialising services database..."
- %%LOCALBASE%%/bin/sqlite $db < %%DATADIR%%/schema.sql
-fi
+mkdir -p %%DBDIR%% \
+&& chown ircservices:ircservices %%DBDIR%% \
+&& chmod 750 %%DBDIR%%
# Secure permissions if we think this is a fresh install
if [ ! -f ${PKG_PREFIX}/ratbox-services.conf ]; then
- chown -R ircservices:ircservices %%DBDIR%%
chown ircservices:ircservices ${PKG_PREFIX}/etc/ratbox-services.conf.sample
- chmod 750 %%DBDIR%%
- chmod 640 $db
chmod 640 ${PKG_PREFIX}/etc/ratbox-services.conf.sample
fi
+cd %%DATADIR%% \
+&& %%PERL%% ./generate-schema.pl
+
+
#-----------------------------------------------------------------------
fi
#-----------------------------------------------------------------------
diff --git a/irc/ratbox-services/files/pkg-message.in b/irc/ratbox-services/files/pkg-message.in
index 197977db07e5..8fc6f848c92c 100644
--- a/irc/ratbox-services/files/pkg-message.in
+++ b/irc/ratbox-services/files/pkg-message.in
@@ -2,11 +2,51 @@
ratbox-services has been successfully installed.
You should now copy %%PREFIX%%/etc/ratbox-services.conf.sample to
-%%PREFIX%%/etc/ratbox-services.conf, and edit it as per the ratbox-services
-documentation. This file is required to start the server.
+%%PREFIX%%/etc/ratbox-services.conf, and edit it as per the
+ratbox-services documentation. This file is required to start services.
+
+You may also need to perform the following steps, if you have not
+already done so:
+
+Initialize Database:
+--------------------
+This must be done before the services server can start, even if you are
+converting from hybserv. Instructions for this are contained in:
+
+ %%DOCSDIR%%/INSTALL.<database_backend>
+
+The following directory has been created for the database to be stored
+in. For consistency, please use this location when generating your
+database instead of the directory specified in the help documentation:
+
+ %%DBDIR%%
+
+IRCD Server Config:
+-------------------
+On the ircd ratbox-services will connect to, add a connect{} block.
+This should have services's server name (name in serverinfo{} in
+ratbox-services.conf) and no autoconnect. 'send_password' and
+'accept_password' should be equal and 'flags=encrypted' should
+not be used.
+
+If you use the ratbox-services compatibility code in ircd-ratbox,
+all servers need service { name = "<ratbox-services's server name>"; };
Once you have added ratbox_services_enable="YES" to /etc/rc.conf, the
server can be started by running:
- %%PREFIX%%/etc/rc.d/ratbox-services.sh start
+ %%PREFIX%%/etc/rc.d/ratbox-services start
+
+Important UPGRADE Note:
+-----------------------
+Upgrading from the 1.0.x series to this current release will likely
+break everything. If upgrading between release versions you should
+read the UPDATING information:
+
+ %%DOCSDIR%%/UPDATING
+
+Common database update tools and scripts referenced in ratbox-services
+documentation can be found in:
+ %%DOCSDIR%%/
+
------------------------------------------------------------------------
diff --git a/irc/ratbox-services/pkg-descr b/irc/ratbox-services/pkg-descr
index b7c6157a3106..d6716f6b0c52 100644
--- a/irc/ratbox-services/pkg-descr
+++ b/irc/ratbox-services/pkg-descr
@@ -2,8 +2,9 @@ ratbox-services is a services package written mostly from scratch for
use with ircd-ratbox.
It is highly configurable, with nearly all options being set in a config
-that can be rehashed rather than set at compile time. It also uses the
-SQLite database backend, which works as a database interface to a normal
+that can be rehashed rather than set at compile time. As well supporting
+standard database backends like PostgreSQL, its default is to use
+the SQLite database backend, which works as a database interface to a normal
file, meaning no seperate database software must be running.
Features:
@@ -11,6 +12,7 @@ Features:
- Jupe service
- Global message service
- Oper services
+ - Watcher services
- Opered bot
- List service
diff --git a/irc/ratbox-services/pkg-plist b/irc/ratbox-services/pkg-plist
index f041d62cb8fc..95a54cd3a01a 100644
--- a/irc/ratbox-services/pkg-plist
+++ b/irc/ratbox-services/pkg-plist
@@ -1,160 +1,206 @@
-bin/ircd-shortcut
+%%DATADIR%%/ircd-shortcut.pl
+%%DATADIR%%/dbupgrade.pl
+%%DATADIR%%/definetolength.pl
+%%DATADIR%%/generate-schema.pl
+%%DATADIR%%/sqlitecheck.pl
+%%DATADIR%%/oldschema/1.0-mysql-schema.txt
+%%DATADIR%%/oldschema/1.0-pgsql-schema.txt
+%%DATADIR%%/oldschema/1.0-sqlite-schema.txt
+@dirrm %%DATADIR%%/oldschema
+%%DATADIR%%/base/schema-sqlite.txt
+%%DATADIR%%/base/schema-pgsql.txt
+%%DATADIR%%/base/schema-mysql.txt
+@dirrm %%DATADIR%%/base
+%%DOCSDIR%%/INSTALL.mysql
+%%DOCSDIR%%/INSTALL.pgsql
+%%DOCSDIR%%/INSTALL.sqlite
+%%DOCSDIR%%/UPGRADING
+%%DOCSDIR%%/DBMOVE
etc/ratbox-services.conf.sample
sbin/ratbox-services
-%%DATADIR%%/schema.sql
-%%DATADIR%%/help/alis/general
-%%DATADIR%%/help/alis/index
-%%DATADIR%%/help/alis/list
-%%DATADIR%%/help/main/u-boot
-%%DATADIR%%/help/main/u-connect
-%%DATADIR%%/help/main/u-die
-%%DATADIR%%/help/main/u-events
-%%DATADIR%%/help/main/u-flags
-%%DATADIR%%/help/main/u-quit
-%%DATADIR%%/help/main/u-rehash
+include/setup.h
+include/rserv.h
+include/channel.h
+include/client.h
+%%DATADIR%%/help/banserv/findxline
+%%DATADIR%%/help/banserv/xline
+%%DATADIR%%/help/banserv/resv
+%%DATADIR%%/help/banserv/u-findxline
+%%DATADIR%%/help/banserv/findresv
+%%DATADIR%%/help/banserv/u-resv
+%%DATADIR%%/help/banserv/u-xline
+%%DATADIR%%/help/banserv/index-admin
+%%DATADIR%%/help/banserv/u-findresv
+%%DATADIR%%/help/banserv/unresv
+%%DATADIR%%/help/banserv/unxline
+%%DATADIR%%/help/banserv/u-unresv
+%%DATADIR%%/help/banserv/u-unxline
+%%DATADIR%%/help/banserv/findkline
+%%DATADIR%%/help/banserv/kline
+%%DATADIR%%/help/banserv/u-findkline
+%%DATADIR%%/help/banserv/u-kline
+%%DATADIR%%/help/banserv/unkline
+%%DATADIR%%/help/banserv/u-unkline
+%%DATADIR%%/help/banserv/index
+%%DATADIR%%/help/banserv/sync
+%%DATADIR%%/help/banserv/general
+%%DATADIR%%/help/banserv/u-sync
+%%DATADIR%%/help/global/u-listwelcome
+%%DATADIR%%/help/global/delwelcome
+%%DATADIR%%/help/global/u-netmsg
+%%DATADIR%%/help/global/u-delwelcome
+%%DATADIR%%/help/global/addwelcome
+%%DATADIR%%/help/global/u-addwelcome
+%%DATADIR%%/help/global/listwelcome
+%%DATADIR%%/help/global/index
+%%DATADIR%%/help/global/index-admin
+%%DATADIR%%/help/global/general
+%%DATADIR%%/help/global/netmsg
+%%DATADIR%%/help/jupeserv/callunjupe
+%%DATADIR%%/help/jupeserv/calljupe
+%%DATADIR%%/help/jupeserv/pending
+%%DATADIR%%/help/jupeserv/jupe
+%%DATADIR%%/help/jupeserv/u-unjupe
+%%DATADIR%%/help/jupeserv/u-jupe
+%%DATADIR%%/help/jupeserv/unjupe
+%%DATADIR%%/help/jupeserv/index
+%%DATADIR%%/help/jupeserv/index-admin
+%%DATADIR%%/help/jupeserv/general
%%DATADIR%%/help/main/u-service
+%%DATADIR%%/help/main/u-chat
%%DATADIR%%/help/main/u-stats
+%%DATADIR%%/help/main/u-connect
%%DATADIR%%/help/main/u-status
-%%DATADIR%%/help/main/u-who
-%%DATADIR%%/help/operbot/general
-%%DATADIR%%/help/operbot/index
-%%DATADIR%%/help/operbot/index-admin
-%%DATADIR%%/help/operbot/invite
-%%DATADIR%%/help/operbot/objoin
-%%DATADIR%%/help/operbot/obpart
-%%DATADIR%%/help/operbot/op
-%%DATADIR%%/help/operbot/u-objoin
-%%DATADIR%%/help/operbot/u-obpart
-%%DATADIR%%/help/chanserv/addban
-%%DATADIR%%/help/chanserv/adduser
-%%DATADIR%%/help/chanserv/chandrop
-%%DATADIR%%/help/chanserv/chaninfo
-%%DATADIR%%/help/chanserv/chanlist
-%%DATADIR%%/help/chanserv/chanregister
-%%DATADIR%%/help/chanserv/chansuspend
+%%DATADIR%%/help/main/u-quit
+%%DATADIR%%/help/main/u-boot
+%%DATADIR%%/help/main/u-events
+%%DATADIR%%/help/main/u-rehash
+%%DATADIR%%/help/nickserv/u-nickdrop
+%%DATADIR%%/help/nickserv/release
+%%DATADIR%%/help/nickserv/drop
+%%DATADIR%%/help/nickserv/register
+%%DATADIR%%/help/nickserv/regain
+%%DATADIR%%/help/nickserv/index
+%%DATADIR%%/help/nickserv/nickdrop
+%%DATADIR%%/help/nickserv/info
+%%DATADIR%%/help/nickserv/set
+%%DATADIR%%/help/nickserv/index-admin
+%%DATADIR%%/help/nickserv/general
+%%DATADIR%%/help/operserv/u-takeover
+%%DATADIR%%/help/operserv/dbsync
+%%DATADIR%%/help/operserv/takeover
+%%DATADIR%%/help/operserv/listopers
+%%DATADIR%%/help/operserv/u-dbsync
+%%DATADIR%%/help/operserv/u-listopers
+%%DATADIR%%/help/operserv/die
+%%DATADIR%%/help/operserv/u-osjoin
+%%DATADIR%%/help/operserv/index-admin
+%%DATADIR%%/help/operserv/osjoin
+%%DATADIR%%/help/operserv/u-die
+%%DATADIR%%/help/operserv/u-omode
+%%DATADIR%%/help/operserv/omode
+%%DATADIR%%/help/operserv/rehash
+%%DATADIR%%/help/operserv/index
+%%DATADIR%%/help/operserv/ospart
+%%DATADIR%%/help/operserv/u-ospart
+%%DATADIR%%/help/operserv/general
+%%DATADIR%%/help/watchserv/index-admin
+%%DATADIR%%/help/watchserv/watch
+%%DATADIR%%/help/watchserv/index
+%%DATADIR%%/help/watchserv/u-watch
+%%DATADIR%%/help/watchserv/general
+%%DATADIR%%/help/alis/general
+%%DATADIR%%/help/alis/index
+%%DATADIR%%/help/alis/list
%%DATADIR%%/help/chanserv/chanunsuspend
-%%DATADIR%%/help/chanserv/clearallops
+%%DATADIR%%/help/chanserv/unsuspend
+%%DATADIR%%/help/chanserv/listbans
+%%DATADIR%%/help/chanserv/register
%%DATADIR%%/help/chanserv/clearbans
-%%DATADIR%%/help/chanserv/clearmodes
-%%DATADIR%%/help/chanserv/clearops
%%DATADIR%%/help/chanserv/delban
-%%DATADIR%%/help/chanserv/deluser
-%%DATADIR%%/help/chanserv/general
%%DATADIR%%/help/chanserv/getkey
-%%DATADIR%%/help/chanserv/index
-%%DATADIR%%/help/chanserv/index-admin
+%%DATADIR%%/help/chanserv/clearallops
%%DATADIR%%/help/chanserv/info
-%%DATADIR%%/help/chanserv/invite
-%%DATADIR%%/help/chanserv/listbans
-%%DATADIR%%/help/chanserv/listusers
-%%DATADIR%%/help/chanserv/modauto
-%%DATADIR%%/help/chanserv/modban
+%%DATADIR%%/help/chanserv/chanregister
+%%DATADIR%%/help/chanserv/deluser
+%%DATADIR%%/help/chanserv/voice
+%%DATADIR%%/help/chanserv/clearops
+%%DATADIR%%/help/chanserv/addban
%%DATADIR%%/help/chanserv/moduser
-%%DATADIR%%/help/chanserv/op
+%%DATADIR%%/help/chanserv/u-chaninfo
+%%DATADIR%%/help/chanserv/delowner
%%DATADIR%%/help/chanserv/set
-%%DATADIR%%/help/chanserv/register
+%%DATADIR%%/help/chanserv/clearmodes
+%%DATADIR%%/help/chanserv/op
+%%DATADIR%%/help/chanserv/u-chanunsuspend
+%%DATADIR%%/help/chanserv/u-chanregister
%%DATADIR%%/help/chanserv/suspend
+%%DATADIR%%/help/chanserv/chaninfo
+%%DATADIR%%/help/chanserv/index-admin
+%%DATADIR%%/help/chanserv/adduser
+%%DATADIR%%/help/chanserv/listusers
+%%DATADIR%%/help/chanserv/chandrop
+%%DATADIR%%/help/chanserv/invite
+%%DATADIR%%/help/chanserv/chansuspend
%%DATADIR%%/help/chanserv/u-chandrop
-%%DATADIR%%/help/chanserv/u-chaninfo
-%%DATADIR%%/help/chanserv/u-chanregister
-%%DATADIR%%/help/chanserv/u-chansuspend
-%%DATADIR%%/help/chanserv/u-chanunsuspend
+%%DATADIR%%/help/chanserv/modban
%%DATADIR%%/help/chanserv/unban
-%%DATADIR%%/help/chanserv/unsuspend
-%%DATADIR%%/help/chanserv/voice
-%%DATADIR%%/help/userserv/general
-%%DATADIR%%/help/userserv/index
-%%DATADIR%%/help/userserv/index-admin
-%%DATADIR%%/help/userserv/info
-%%DATADIR%%/help/userserv/login
-%%DATADIR%%/help/userserv/logout
-%%DATADIR%%/help/userserv/register
+%%DATADIR%%/help/chanserv/chanlist
+%%DATADIR%%/help/chanserv/index
+%%DATADIR%%/help/chanserv/modauto
+%%DATADIR%%/help/chanserv/u-chansuspend
+%%DATADIR%%/help/chanserv/general
+%%DATADIR%%/help/operbot/index-admin
+%%DATADIR%%/help/operbot/u-objoin
+%%DATADIR%%/help/operbot/objoin
+%%DATADIR%%/help/operbot/u-obpart
+%%DATADIR%%/help/operbot/index
+%%DATADIR%%/help/operbot/obpart
+%%DATADIR%%/help/operbot/general
+%%DATADIR%%/help/operbot/invite
+%%DATADIR%%/help/operbot/op
+%%DATADIR%%/help/userserv/activate
%%DATADIR%%/help/userserv/set
-%%DATADIR%%/help/userserv/u-userdrop
-%%DATADIR%%/help/userserv/u-userinfo
-%%DATADIR%%/help/userserv/u-userregister
-%%DATADIR%%/help/userserv/u-usersetpass
%%DATADIR%%/help/userserv/u-usersuspend
+%%DATADIR%%/help/userserv/usersuspend
+%%DATADIR%%/help/userserv/usersetpass
%%DATADIR%%/help/userserv/u-userunsuspend
-%%DATADIR%%/help/userserv/userdrop
-%%DATADIR%%/help/userserv/userinfo
-%%DATADIR%%/help/userserv/userlist
+%%DATADIR%%/help/userserv/u-usersetpass
%%DATADIR%%/help/userserv/userregister
-%%DATADIR%%/help/userserv/usersetpass
-%%DATADIR%%/help/userserv/usersuspend
%%DATADIR%%/help/userserv/userunsuspend
-%%DATADIR%%/help/jupeserv/calljupe
-%%DATADIR%%/help/jupeserv/callunjupe
-%%DATADIR%%/help/jupeserv/general
-%%DATADIR%%/help/jupeserv/index
-%%DATADIR%%/help/jupeserv/index-admin
-%%DATADIR%%/help/jupeserv/jupe
-%%DATADIR%%/help/jupeserv/pending
-%%DATADIR%%/help/jupeserv/u-jupe
-%%DATADIR%%/help/jupeserv/u-unjupe
-%%DATADIR%%/help/jupeserv/unjupe
-%%DATADIR%%/help/operserv/general
-%%DATADIR%%/help/operserv/index
-%%DATADIR%%/help/operserv/index-admin
-%%DATADIR%%/help/operserv/omode
-%%DATADIR%%/help/operserv/osjoin
-%%DATADIR%%/help/operserv/ospart
-%%DATADIR%%/help/operserv/takeover
-%%DATADIR%%/help/operserv/u-omode
-%%DATADIR%%/help/operserv/u-osjoin
-%%DATADIR%%/help/operserv/u-ospart
-%%DATADIR%%/help/operserv/u-takeover
-%%DATADIR%%/help/nickserv/drop
-%%DATADIR%%/help/nickserv/general
-%%DATADIR%%/help/nickserv/index
-%%DATADIR%%/help/nickserv/index-admin
-%%DATADIR%%/help/nickserv/info
-%%DATADIR%%/help/nickserv/nickdrop
-%%DATADIR%%/help/nickserv/regain
-%%DATADIR%%/help/nickserv/register
-%%DATADIR%%/help/nickserv/release
-%%DATADIR%%/help/nickserv/set
-%%DATADIR%%/help/nickserv/u-nickdrop
-%%DATADIR%%/help/global/general
-%%DATADIR%%/help/global/index
-%%DATADIR%%/help/global/index-admin
-%%DATADIR%%/help/global/netmsg
-%%DATADIR%%/help/global/u-netmsg
-%%DATADIR%%/help/banserv/findkline
-%%DATADIR%%/help/banserv/findresv
-%%DATADIR%%/help/banserv/findxline
-%%DATADIR%%/help/banserv/general
-%%DATADIR%%/help/banserv/index
-%%DATADIR%%/help/banserv/index-admin
-%%DATADIR%%/help/banserv/kline
-%%DATADIR%%/help/banserv/resv
-%%DATADIR%%/help/banserv/sync
-%%DATADIR%%/help/banserv/u-findkline
-%%DATADIR%%/help/banserv/u-findresv
-%%DATADIR%%/help/banserv/u-findxline
-%%DATADIR%%/help/banserv/u-kline
-%%DATADIR%%/help/banserv/u-resv
-%%DATADIR%%/help/banserv/u-sync
-%%DATADIR%%/help/banserv/u-unkline
-%%DATADIR%%/help/banserv/u-unresv
-%%DATADIR%%/help/banserv/u-unxline
-%%DATADIR%%/help/banserv/u-xline
-%%DATADIR%%/help/banserv/unkline
-%%DATADIR%%/help/banserv/unresv
-%%DATADIR%%/help/banserv/unxline
-%%DATADIR%%/help/banserv/xline
-@dirrm %%DATADIR%%/help/alis
-@dirrm %%DATADIR%%/help/main
+%%DATADIR%%/help/userserv/register
+%%DATADIR%%/help/userserv/u-userregister
+%%DATADIR%%/help/userserv/resetemail
+%%DATADIR%%/help/userserv/userinfo
+%%DATADIR%%/help/userserv/info
+%%DATADIR%%/help/userserv/index-admin
+%%DATADIR%%/help/userserv/u-userinfo
+%%DATADIR%%/help/userserv/resetpass
+%%DATADIR%%/help/userserv/userdrop
+%%DATADIR%%/help/userserv/u-userdrop
+%%DATADIR%%/help/userserv/index
+%%DATADIR%%/help/userserv/login
+%%DATADIR%%/help/userserv/userlist
+%%DATADIR%%/help/userserv/logout
+%%DATADIR%%/help/userserv/general
+@unexec f="/usr/local/share/ratbox-services/schema-mysql.txt"; if [ -f "$f" ]; then rm -f "$f"; fi
+@unexec f="/usr/local/share/ratbox-services/schema-pgsql.txt"; if [ -f "$f" ]; then rm -f "$f"; fi
+@unexec f="/usr/local/share/ratbox-services/schema-sqlite.txt"; if [ -f "$f" ]; then rm -f "$f"; fi
+@dirrm %%DATADIR%%/help/userserv
@dirrm %%DATADIR%%/help/operbot
@dirrm %%DATADIR%%/help/chanserv
-@dirrm %%DATADIR%%/help/userserv
-@dirrm %%DATADIR%%/help/jupeserv
+@dirrm %%DATADIR%%/help/alis
+@dirrm %%DATADIR%%/help/watchserv
@dirrm %%DATADIR%%/help/operserv
@dirrm %%DATADIR%%/help/nickserv
+@dirrm %%DATADIR%%/help/main
+@dirrm %%DATADIR%%/help/jupeserv
@dirrm %%DATADIR%%/help/global
@dirrm %%DATADIR%%/help/banserv
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%
@dirrmtry %%DBDIR%%
+@dirrmtry %%DOCSDIR%%
@unexec f="/var/log/ratbox-services.log"; if [ ! -s "$f" ]; then rm -f "$f"; fi
@unexec f="/var/run/ratbox-services.pid"; if [ ! -s "$f" ]; then rm -f "$f"; fi
+