aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--shells/Makefile1
-rw-r--r--shells/lshell/Makefile40
-rw-r--r--shells/lshell/distinfo3
-rw-r--r--shells/lshell/files/patch-setup.py14
-rw-r--r--shells/lshell/pkg-descr5
5 files changed, 63 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 5391bcfc52d0..084bed538519 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -20,6 +20,7 @@
SUBDIR += heirloom-sh
SUBDIR += ibsh
SUBDIR += ksh93
+ SUBDIR += lshell
SUBDIR += mksh
SUBDIR += nologinmsg
SUBDIR += osh
diff --git a/shells/lshell/Makefile b/shells/lshell/Makefile
new file mode 100644
index 000000000000..d8d979c93b14
--- /dev/null
+++ b/shells/lshell/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lshell
+# Date created: 2009-08-01
+# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lshell
+PORTVERSION= 0.9.5
+CATEGORIES= shells
+MASTER_SITES= SF
+
+MAINTAINER= scjamorim@bsd.com.br
+COMMENT= Shell environment to limited sets of commands to user's
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USE_PYDISTUTILS= yes
+USE_PYTHON= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/lshell.py \
+ %%PYTHON_SITELIBDIR%%/lshell.pyc \
+ %%PYTHON_SITELIBDIR%%/lshell.pyo \
+ bin/lshell \
+ etc/lshell.conf
+
+MAN1= lshell.1
+
+DOCS= README COPYING CHANGES
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/shells/lshell/distinfo b/shells/lshell/distinfo
new file mode 100644
index 000000000000..94230dcce371
--- /dev/null
+++ b/shells/lshell/distinfo
@@ -0,0 +1,3 @@
+MD5 (lshell-0.9.5.tar.gz) = 89f0a93725f762f31e3b0c5ac2599df2
+SHA256 (lshell-0.9.5.tar.gz) = 9261ceb5b076cdde576c946bc0b1dc8f1c6e8a23dca7629f61479f7c6d9f59da
+SIZE (lshell-0.9.5.tar.gz) = 30524
diff --git a/shells/lshell/files/patch-setup.py b/shells/lshell/files/patch-setup.py
new file mode 100644
index 000000000000..29a29b6f69ab
--- /dev/null
+++ b/shells/lshell/files/patch-setup.py
@@ -0,0 +1,14 @@
+--- setup.py 2009-07-28 15:20:50.000000000 -0300
++++ patch-setup.py 2009-08-05 08:41:06.000000000 -0300
+@@ -40,9 +40,8 @@
+ scripts = ['bin/lshell'],
+ package_dir = {'':'lshellmodule'},
+ packages = [''],
+- data_files = [('/etc', ['etc/lshell.conf']),
+- ('share/doc/lshell',['README', 'COPYING', 'CHANGES']),
+- ('share/man/man1/', ['man/lshell.1']) ],
++ data_files = [('etc', ['etc/lshell.conf']),
++ ('man/man1/', ['man/lshell.1']) ],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console'
diff --git a/shells/lshell/pkg-descr b/shells/lshell/pkg-descr
new file mode 100644
index 000000000000..0a1cd8b05819
--- /dev/null
+++ b/shells/lshell/pkg-descr
@@ -0,0 +1,5 @@
+lshell lets you restrict a user's shell environment to limited sets of commands,
+choose to enable or disable any command over SSH (e.g. SCP, SFTP, rsync, etc.)
+log user's commands, implement timing restrictions, and more.
+
+WWW: http://lshell.ghantoos.org