aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile84
-rw-r--r--emulators/linux-vmware-toolbox4/pkg-descr7
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile84
-rw-r--r--emulators/linux-vmware-toolbox5/pkg-descr7
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile84
-rw-r--r--emulators/linux-vmware-toolbox6/pkg-descr7
-rw-r--r--emulators/vmware-guestd4/Makefile9
-rw-r--r--emulators/vmware-guestd5/Makefile9
-rw-r--r--emulators/vmware-guestd6/Makefile9
-rw-r--r--emulators/vmware-tools4/Makefile8
-rw-r--r--emulators/vmware-tools4/pkg-descr2
-rw-r--r--emulators/vmware-tools5/Makefile8
-rw-r--r--emulators/vmware-tools5/pkg-descr2
-rw-r--r--emulators/vmware-tools6/Makefile8
-rw-r--r--emulators/vmware-tools6/pkg-descr2
15 files changed, 156 insertions, 174 deletions
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index ee82e72ab6a9..d57c556fbaff 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -13,51 +13,55 @@ PKGNAMEPREFIX= linux-
DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
+COMMENT=VMware toolbox for guest OS (for VMware 4.x, Linux version)
+
+DISTDIR= ${MOUNT_PT}
+IGNOREFILES= ${DISTFILES}
+WRKSRC= ${WRKDIR}/vmware-tools-distrib
+STRIP=
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
-.include <bsd.port.pre.mk>
-
-LINUX_FLP?= ${DISTDIR}/linux.flp
-MOUNT_PT?= ${WRKDIR}/mnt
-.if exists(${LINUX_FLP})
-.if ${OSVERSION} >= 500018
-DEV_ATTACH= /usr/sbin/mdconfig -a -t vnode -f ${LINUX_FLP} -u ${MOUNT_DEV}
-DEV_DETACH= /usr/sbin/mdconfig -d -u ${MOUNT_DEV}
-MOUNT_DEV?= md0
-.else
-DEV_ATTACH= /usr/sbin/vnconfig -c ${MOUNT_DEV} ${LINUX_FLP}
-DEV_DETACH= /usr/sbin/vnconfig -u ${MOUNT_DEV}
-MOUNT_DEV?= vn0
-.endif
-.else
-MOUNT_DEV?= fd0
-.endif
-VMWARE_VER= 2.0.4
-BUILD_VER= 1142
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
+MOUNT_DEV?= /dev/acd0
+MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
-pre-fetch:
-.if !exists("${DISTDIR}/${DISTFILES}")
+do-fetch:
+ @${DO_NADA}
+fetch-list:
+ @${DO_NADA}
+
+pre-extract:
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please:"
+ @${ECHO} "Before installing this port, please follow this instructions:"
@${ECHO} ""
- @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
- @${ECHO} " and choose the file \"linux.flp\"."
+ @${ECHO} " *) Be sure that your VM have an IDE CD-ROM."
+ @${ECHO} " *) Select \"Edit -> Removable Devices -> CD-ROM 1 -> Edit\" on VMware menu,"
+ @${ECHO} " *) Check \"Connected\" box."
+ @${ECHO} " *) Check \"Use ISO image\" radio button."
+ @${ECHO} " *) Choose the file \"linux.iso\" for the ISO image. You will find"
+ @${ECHO} " it under the directory VMware Workstation installed."
+ @${ECHO} " *) Press \"OK\" button."
+ @${ECHO} ""
+ @${ECHO} "Don\'t forget to restore the configuration after installing this port."
@${ECHO} ""
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+.if !defined(BATCH)
+ @${ECHO} -n "Ready to install this ports? [Y/n]: "
@(read line; \
case "$${line}" in \
[Nn]*) \
@@ -66,27 +70,15 @@ pre-fetch:
${TRUE} ;; \
esac)
.endif
-
-do-fetch:
-.if exists("${DISTDIR}/${DISTFILES}")
- @${ECHO} "Found ${DISTDIR}/${DISTFILES}."
-.else
${MKDIR} ${MOUNT_PT}
- -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
- -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
-.if exists(${LINUX_FLP})
- -@${DEV_DETACH} 2>&1 >/dev/null
- ${DEV_ATTACH}
-.endif
- ${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
- ${CP} ${MOUNT_PT}/${DISTFILES} ${DISTDIR}
- ${UMOUNT} /dev/${MOUNT_DEV}
-.if exists(${LINUX_FLP})
- ${DEV_DETACH}
-.endif
-.endif
+ -${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -${UMOUNT} ${MOUNT_DEV} 2>&1 >/dev/null
+ ${MOUNT} -t cd9660 -r ${MOUNT_DEV} ${MOUNT_PT}
+
+post-extract:
+ ${UMOUNT} ${MOUNT_DEV}
do-install:
- ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux-vmware-toolbox4/pkg-descr b/emulators/linux-vmware-toolbox4/pkg-descr
index 00996c8f08da..19e4af351d3b 100644
--- a/emulators/linux-vmware-toolbox4/pkg-descr
+++ b/emulators/linux-vmware-toolbox4/pkg-descr
@@ -7,9 +7,8 @@ synchronization between the virtual machine and the Host OS. That is
why this port is provided.
-Before installing this port, make sure you have a `linux.flp' file
+Before installing this port, make sure you have a `linux.iso' file
that comes with VMware:
- Windows NT/2000: C:\Program Files\VMware\Programs\linux.flp
- Linux: /usr/lib/vmware/lib/floppies/linux.flp
- FreeBSD (via ports): ${PREFIX}/lib/vmware/lib/floppies/linux.flp
+ Windows: C:\Program Files\VMware\VMware Workstation\linux.iso
+ Linux: /usr/lib/vmware/lib/isoimages/linux.iso
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index ee82e72ab6a9..d57c556fbaff 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -13,51 +13,55 @@ PKGNAMEPREFIX= linux-
DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
+COMMENT=VMware toolbox for guest OS (for VMware 4.x, Linux version)
+
+DISTDIR= ${MOUNT_PT}
+IGNOREFILES= ${DISTFILES}
+WRKSRC= ${WRKDIR}/vmware-tools-distrib
+STRIP=
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
-.include <bsd.port.pre.mk>
-
-LINUX_FLP?= ${DISTDIR}/linux.flp
-MOUNT_PT?= ${WRKDIR}/mnt
-.if exists(${LINUX_FLP})
-.if ${OSVERSION} >= 500018
-DEV_ATTACH= /usr/sbin/mdconfig -a -t vnode -f ${LINUX_FLP} -u ${MOUNT_DEV}
-DEV_DETACH= /usr/sbin/mdconfig -d -u ${MOUNT_DEV}
-MOUNT_DEV?= md0
-.else
-DEV_ATTACH= /usr/sbin/vnconfig -c ${MOUNT_DEV} ${LINUX_FLP}
-DEV_DETACH= /usr/sbin/vnconfig -u ${MOUNT_DEV}
-MOUNT_DEV?= vn0
-.endif
-.else
-MOUNT_DEV?= fd0
-.endif
-VMWARE_VER= 2.0.4
-BUILD_VER= 1142
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
+MOUNT_DEV?= /dev/acd0
+MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
-pre-fetch:
-.if !exists("${DISTDIR}/${DISTFILES}")
+do-fetch:
+ @${DO_NADA}
+fetch-list:
+ @${DO_NADA}
+
+pre-extract:
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please:"
+ @${ECHO} "Before installing this port, please follow this instructions:"
@${ECHO} ""
- @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
- @${ECHO} " and choose the file \"linux.flp\"."
+ @${ECHO} " *) Be sure that your VM have an IDE CD-ROM."
+ @${ECHO} " *) Select \"Edit -> Removable Devices -> CD-ROM 1 -> Edit\" on VMware menu,"
+ @${ECHO} " *) Check \"Connected\" box."
+ @${ECHO} " *) Check \"Use ISO image\" radio button."
+ @${ECHO} " *) Choose the file \"linux.iso\" for the ISO image. You will find"
+ @${ECHO} " it under the directory VMware Workstation installed."
+ @${ECHO} " *) Press \"OK\" button."
+ @${ECHO} ""
+ @${ECHO} "Don\'t forget to restore the configuration after installing this port."
@${ECHO} ""
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+.if !defined(BATCH)
+ @${ECHO} -n "Ready to install this ports? [Y/n]: "
@(read line; \
case "$${line}" in \
[Nn]*) \
@@ -66,27 +70,15 @@ pre-fetch:
${TRUE} ;; \
esac)
.endif
-
-do-fetch:
-.if exists("${DISTDIR}/${DISTFILES}")
- @${ECHO} "Found ${DISTDIR}/${DISTFILES}."
-.else
${MKDIR} ${MOUNT_PT}
- -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
- -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
-.if exists(${LINUX_FLP})
- -@${DEV_DETACH} 2>&1 >/dev/null
- ${DEV_ATTACH}
-.endif
- ${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
- ${CP} ${MOUNT_PT}/${DISTFILES} ${DISTDIR}
- ${UMOUNT} /dev/${MOUNT_DEV}
-.if exists(${LINUX_FLP})
- ${DEV_DETACH}
-.endif
-.endif
+ -${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -${UMOUNT} ${MOUNT_DEV} 2>&1 >/dev/null
+ ${MOUNT} -t cd9660 -r ${MOUNT_DEV} ${MOUNT_PT}
+
+post-extract:
+ ${UMOUNT} ${MOUNT_DEV}
do-install:
- ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux-vmware-toolbox5/pkg-descr b/emulators/linux-vmware-toolbox5/pkg-descr
index 00996c8f08da..19e4af351d3b 100644
--- a/emulators/linux-vmware-toolbox5/pkg-descr
+++ b/emulators/linux-vmware-toolbox5/pkg-descr
@@ -7,9 +7,8 @@ synchronization between the virtual machine and the Host OS. That is
why this port is provided.
-Before installing this port, make sure you have a `linux.flp' file
+Before installing this port, make sure you have a `linux.iso' file
that comes with VMware:
- Windows NT/2000: C:\Program Files\VMware\Programs\linux.flp
- Linux: /usr/lib/vmware/lib/floppies/linux.flp
- FreeBSD (via ports): ${PREFIX}/lib/vmware/lib/floppies/linux.flp
+ Windows: C:\Program Files\VMware\VMware Workstation\linux.iso
+ Linux: /usr/lib/vmware/lib/isoimages/linux.iso
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index ee82e72ab6a9..d57c556fbaff 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -13,51 +13,55 @@ PKGNAMEPREFIX= linux-
DISTNAME= vmware-linux-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
+COMMENT=VMware toolbox for guest OS (for VMware 4.x, Linux version)
+
+DISTDIR= ${MOUNT_PT}
+IGNOREFILES= ${DISTFILES}
+WRKSRC= ${WRKDIR}/vmware-tools-distrib
+STRIP=
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
+.if !defined(BATCH)
IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
-.include <bsd.port.pre.mk>
-
-LINUX_FLP?= ${DISTDIR}/linux.flp
-MOUNT_PT?= ${WRKDIR}/mnt
-.if exists(${LINUX_FLP})
-.if ${OSVERSION} >= 500018
-DEV_ATTACH= /usr/sbin/mdconfig -a -t vnode -f ${LINUX_FLP} -u ${MOUNT_DEV}
-DEV_DETACH= /usr/sbin/mdconfig -d -u ${MOUNT_DEV}
-MOUNT_DEV?= md0
-.else
-DEV_ATTACH= /usr/sbin/vnconfig -c ${MOUNT_DEV} ${LINUX_FLP}
-DEV_DETACH= /usr/sbin/vnconfig -u ${MOUNT_DEV}
-MOUNT_DEV?= vn0
-.endif
-.else
-MOUNT_DEV?= fd0
-.endif
-VMWARE_VER= 2.0.4
-BUILD_VER= 1142
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
+MOUNT_DEV?= /dev/acd0
+MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
-pre-fetch:
-.if !exists("${DISTDIR}/${DISTFILES}")
+do-fetch:
+ @${DO_NADA}
+fetch-list:
+ @${DO_NADA}
+
+pre-extract:
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} "To install this port, please:"
+ @${ECHO} "Before installing this port, please follow this instructions:"
@${ECHO} ""
- @${ECHO} " Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
- @${ECHO} " and choose the file \"linux.flp\"."
+ @${ECHO} " *) Be sure that your VM have an IDE CD-ROM."
+ @${ECHO} " *) Select \"Edit -> Removable Devices -> CD-ROM 1 -> Edit\" on VMware menu,"
+ @${ECHO} " *) Check \"Connected\" box."
+ @${ECHO} " *) Check \"Use ISO image\" radio button."
+ @${ECHO} " *) Choose the file \"linux.iso\" for the ISO image. You will find"
+ @${ECHO} " it under the directory VMware Workstation installed."
+ @${ECHO} " *) Press \"OK\" button."
+ @${ECHO} ""
+ @${ECHO} "Don\'t forget to restore the configuration after installing this port."
@${ECHO} ""
@${ECHO} "========================================================================"
@${ECHO} ""
- @${ECHO} -n "Are ready to install this ports? [Y/n]: "
+.if !defined(BATCH)
+ @${ECHO} -n "Ready to install this ports? [Y/n]: "
@(read line; \
case "$${line}" in \
[Nn]*) \
@@ -66,27 +70,15 @@ pre-fetch:
${TRUE} ;; \
esac)
.endif
-
-do-fetch:
-.if exists("${DISTDIR}/${DISTFILES}")
- @${ECHO} "Found ${DISTDIR}/${DISTFILES}."
-.else
${MKDIR} ${MOUNT_PT}
- -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
- -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
-.if exists(${LINUX_FLP})
- -@${DEV_DETACH} 2>&1 >/dev/null
- ${DEV_ATTACH}
-.endif
- ${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
- ${CP} ${MOUNT_PT}/${DISTFILES} ${DISTDIR}
- ${UMOUNT} /dev/${MOUNT_DEV}
-.if exists(${LINUX_FLP})
- ${DEV_DETACH}
-.endif
-.endif
+ -${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -${UMOUNT} ${MOUNT_DEV} 2>&1 >/dev/null
+ ${MOUNT} -t cd9660 -r ${MOUNT_DEV} ${MOUNT_PT}
+
+post-extract:
+ ${UMOUNT} ${MOUNT_DEV}
do-install:
- ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux-vmware-toolbox6/pkg-descr b/emulators/linux-vmware-toolbox6/pkg-descr
index 00996c8f08da..19e4af351d3b 100644
--- a/emulators/linux-vmware-toolbox6/pkg-descr
+++ b/emulators/linux-vmware-toolbox6/pkg-descr
@@ -7,9 +7,8 @@ synchronization between the virtual machine and the Host OS. That is
why this port is provided.
-Before installing this port, make sure you have a `linux.flp' file
+Before installing this port, make sure you have a `linux.iso' file
that comes with VMware:
- Windows NT/2000: C:\Program Files\VMware\Programs\linux.flp
- Linux: /usr/lib/vmware/lib/floppies/linux.flp
- FreeBSD (via ports): ${PREFIX}/lib/vmware/lib/floppies/linux.flp
+ Windows: C:\Program Files\VMware\VMware Workstation\linux.iso
+ Linux: /usr/lib/vmware/lib/isoimages/linux.iso
diff --git a/emulators/vmware-guestd4/Makefile b/emulators/vmware-guestd4/Makefile
index 52ebdd20fc23..4d3216d9e1e4 100644
--- a/emulators/vmware-guestd4/Makefile
+++ b/emulators/vmware-guestd4/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 4.x)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
@@ -22,14 +22,17 @@ WRKSRC= ${WRKDIR}/vmware-freebsd-tools
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+.if !defined(BATCH)
+IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index 52ebdd20fc23..4d3216d9e1e4 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 4.x)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
@@ -22,14 +22,17 @@ WRKSRC= ${WRKDIR}/vmware-freebsd-tools
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+.if !defined(BATCH)
+IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index 52ebdd20fc23..4d3216d9e1e4 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware time synchronization daemon for FreeBSD guest OS (for VMware 4.x)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
@@ -22,14 +22,17 @@ WRKSRC= ${WRKDIR}/vmware-freebsd-tools
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
+.if !defined(BATCH)
+IS_INTERACTIVE= yes
+.endif
RESTRICTED= "Not sure if we can redistribute this."
.if defined(PACKAGE_BUILDING)
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-tools4/Makefile b/emulators/vmware-tools4/Makefile
index 065972ce96de..16ec6b698037 100644
--- a/emulators/vmware-tools4/Makefile
+++ b/emulators/vmware-tools4/Makefile
@@ -12,10 +12,10 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware tools for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware tools for guest OS (for VMware 4.x, FreeBSD version)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
-RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd
+RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd4
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
@@ -30,8 +30,8 @@ RESTRICTED= "Not sure if we can redistribute this."
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-tools4/pkg-descr b/emulators/vmware-tools4/pkg-descr
index e8deec969f96..68165f70e46f 100644
--- a/emulators/vmware-tools4/pkg-descr
+++ b/emulators/vmware-tools4/pkg-descr
@@ -11,6 +11,6 @@ This ports will install vmware-toolbox to your computer, and
XFree86 X server if you set XFREE86_VERSION to 3 in /etc/make.conf,
If you already use XFree86 4.1.0 or later, you may use 'vmware'
driver for X server. Vmware-guestd is installed as a separate port,
-ports/emulators/vmware-guestd, but this port install guestd automatically.
+ports/emulators/vmware-guestd4, but this port install guestd automatically.
WWW: http://www.vmware.com/products/desktop/ws_features.html
diff --git a/emulators/vmware-tools5/Makefile b/emulators/vmware-tools5/Makefile
index 065972ce96de..16ec6b698037 100644
--- a/emulators/vmware-tools5/Makefile
+++ b/emulators/vmware-tools5/Makefile
@@ -12,10 +12,10 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware tools for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware tools for guest OS (for VMware 4.x, FreeBSD version)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
-RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd
+RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd4
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
@@ -30,8 +30,8 @@ RESTRICTED= "Not sure if we can redistribute this."
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-tools5/pkg-descr b/emulators/vmware-tools5/pkg-descr
index e8deec969f96..68165f70e46f 100644
--- a/emulators/vmware-tools5/pkg-descr
+++ b/emulators/vmware-tools5/pkg-descr
@@ -11,6 +11,6 @@ This ports will install vmware-toolbox to your computer, and
XFree86 X server if you set XFREE86_VERSION to 3 in /etc/make.conf,
If you already use XFree86 4.1.0 or later, you may use 'vmware'
driver for X server. Vmware-guestd is installed as a separate port,
-ports/emulators/vmware-guestd, but this port install guestd automatically.
+ports/emulators/vmware-guestd4, but this port install guestd automatically.
WWW: http://www.vmware.com/products/desktop/ws_features.html
diff --git a/emulators/vmware-tools6/Makefile b/emulators/vmware-tools6/Makefile
index 065972ce96de..16ec6b698037 100644
--- a/emulators/vmware-tools6/Makefile
+++ b/emulators/vmware-tools6/Makefile
@@ -12,10 +12,10 @@ MASTER_SITES= # none
DISTNAME= vmware-freebsd-tools
MAINTAINER= matusita@FreeBSD.org
-COMMENT=VMware tools for FreeBSD guest OS (for VMware 3.x)
+COMMENT=VMware tools for guest OS (for VMware 4.x, FreeBSD version)
LIB_DEPENDS= c.3:${PORTSDIR}/misc/compat3x
-RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd
+RUN_DEPENDS= ${LOCALBASE}/sbin/vmware-guestd:${PORTSDIR}/emulators/vmware-guestd4
DISTDIR= ${MOUNT_PT}
IGNOREFILES= ${DISTFILES}
@@ -30,8 +30,8 @@ RESTRICTED= "Not sure if we can redistribute this."
IGNORE= "Can't build this port since it requires VMware."
.endif
-VMWARE_VER= 3.1.1
-BUILD_VER= 1790
+VMWARE_VER= 4.0.0
+BUILD_VER= 4460
MOUNT_DEV?= /dev/acd0c
MOUNT_PT?= /mnt
diff --git a/emulators/vmware-tools6/pkg-descr b/emulators/vmware-tools6/pkg-descr
index e8deec969f96..68165f70e46f 100644
--- a/emulators/vmware-tools6/pkg-descr
+++ b/emulators/vmware-tools6/pkg-descr
@@ -11,6 +11,6 @@ This ports will install vmware-toolbox to your computer, and
XFree86 X server if you set XFREE86_VERSION to 3 in /etc/make.conf,
If you already use XFree86 4.1.0 or later, you may use 'vmware'
driver for X server. Vmware-guestd is installed as a separate port,
-ports/emulators/vmware-guestd, but this port install guestd automatically.
+ports/emulators/vmware-guestd4, but this port install guestd automatically.
WWW: http://www.vmware.com/products/desktop/ws_features.html