aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Number-Format-Metric/Makefile20
-rw-r--r--textproc/p5-Number-Format-Metric/distinfo3
-rw-r--r--textproc/p5-Number-Format-Metric/pkg-descr8
-rw-r--r--textproc/p5-Number-Format-Metric/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f4ee5b8f68ce..1fb3ccfec1a3 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -630,6 +630,7 @@
SUBDIR += p5-Net-YASA
SUBDIR += p5-NetAddr-IP-Find
SUBDIR += p5-Number-Format
+ SUBDIR += p5-Number-Format-Metric
SUBDIR += p5-Number-Spell
SUBDIR += p5-ODF-lpOD
SUBDIR += p5-OpenOffice-OODoc
diff --git a/textproc/p5-Number-Format-Metric/Makefile b/textproc/p5-Number-Format-Metric/Makefile
new file mode 100644
index 000000000000..2cff1aee6b48
--- /dev/null
+++ b/textproc/p5-Number-Format-Metric/Makefile
@@ -0,0 +1,20 @@
+# Created by: Zane C. Bowers-Hadley <vvelox@vvelox.net>
+
+PORTNAME= Number-Format-Metric
+PORTVERSION= 0.60
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Format number with metric prefix
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Number-Format-Metric/distinfo b/textproc/p5-Number-Format-Metric/distinfo
new file mode 100644
index 000000000000..2d4a813fcc9a
--- /dev/null
+++ b/textproc/p5-Number-Format-Metric/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633971826
+SHA256 (Number-Format-Metric-0.60.tar.gz) = f46c5c32f2979dcecc8fbaf054eb17adb6dd306d4be9db98397bde706857bbb3
+SIZE (Number-Format-Metric-0.60.tar.gz) = 13772
diff --git a/textproc/p5-Number-Format-Metric/pkg-descr b/textproc/p5-Number-Format-Metric/pkg-descr
new file mode 100644
index 000000000000..6747844b8a4d
--- /dev/null
+++ b/textproc/p5-Number-Format-Metric/pkg-descr
@@ -0,0 +1,8 @@
+Format number with metric prefix.
+
+format_metric(14 , {base=>10}); # => "14"
+format_metric(12000 , {base=> 2, precision=>1}); # => "11.7K"
+format_metric(12000 , {base=>10, precision=>1}); # => "11.7Ki"
+format_metric(-0.0017, {base=>10}); # => "1.7m"
+
+WWW: https://metacpan.org/dist/Number-Format-Metric
diff --git a/textproc/p5-Number-Format-Metric/pkg-plist b/textproc/p5-Number-Format-Metric/pkg-plist
new file mode 100644
index 000000000000..f2139e4c587a
--- /dev/null
+++ b/textproc/p5-Number-Format-Metric/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Number/Format/Metric.pm
+%%PERL5_MAN3%%/Number::Format::Metric.3.gz