aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/ocaml/Makefile5
-rw-r--r--lang/ocaml/files/patch-camlp4-lib::Makefile10
-rw-r--r--lang/ocaml/files/patch-camlp4-meta::Makefile11
-rw-r--r--lang/ocaml/files/patch-camlp4-ocaml_src-lib::Makefile10
-rw-r--r--lang/ocaml/files/patch-camlp4-ocaml_src-meta::Makefile11
-rw-r--r--lang/ocaml/files/patch-configure125
-rw-r--r--lang/ocaml/pkg-plist6
7 files changed, 174 insertions, 4 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 48adc7026dd9..5e72af960511 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ocaml
PORTVERSION= 3.07
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME}/ \
ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME}/ \
@@ -82,9 +83,7 @@ MLINKS= ocamlc.1 ocamlc.opt.1 ocamlopt.1 ocamlopt.opt.1 \
CONFIGURE_ARGS= -prefix ${PREFIX} \
-with-pthread
-.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+= -tk-no-x11 -no-tk
-.else
+.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= -x11include ${X11BASE}/include \
-x11lib ${X11BASE}/lib
.if defined(WITHOUT_TK)
diff --git a/lang/ocaml/files/patch-camlp4-lib::Makefile b/lang/ocaml/files/patch-camlp4-lib::Makefile
new file mode 100644
index 000000000000..c36518c27c5c
--- /dev/null
+++ b/lang/ocaml/files/patch-camlp4-lib::Makefile
@@ -0,0 +1,10 @@
+--- camlp4/lib/Makefile.orig Sun Dec 14 02:41:09 2003
++++ camlp4/lib/Makefile Sun Dec 14 02:41:24 2003
+@@ -43,6 +43,6 @@
+
+ installopt:
+ cp $(TARGET:.cma=.cmxa) *.cmx "$(LIBDIR)/camlp4/."
+- tar cf - $(TARGET:.cma=.$(A)) | (cd "$(LIBDIR)/camlp4/."; tar xf -)
++ tar cf - $(TARGET:S/.cma$/.$(A)/) | (cd "$(LIBDIR)/camlp4/."; tar xf -)
+
+ include .depend
diff --git a/lang/ocaml/files/patch-camlp4-meta::Makefile b/lang/ocaml/files/patch-camlp4-meta::Makefile
new file mode 100644
index 000000000000..9c5b0cb99abb
--- /dev/null
+++ b/lang/ocaml/files/patch-camlp4-meta::Makefile
@@ -0,0 +1,11 @@
+--- camlp4/meta/Makefile.orig Sun Dec 14 02:40:05 2003
++++ camlp4/meta/Makefile Sun Dec 14 02:40:20 2003
+@@ -49,7 +49,7 @@
+ cp camlp4r$(EXE) "$(BINDIR)/."
+ if test -f camlp4r.opt; then \
+ cp camlp4r.opt "$(BINDIR)/camlp4r.opt$(EXE)" ;\
+- for target in $(OBJSX) $(OBJSX:.cmx=.$(O)) ; do \
++ for target in $(OBJSX) $(OBJSX:S/.cmx$/.$(O)/) ; do \
+ if test -f $$target; then \
+ cp $$target "$(LIBDIR)/camlp4/."; \
+ fi; \
diff --git a/lang/ocaml/files/patch-camlp4-ocaml_src-lib::Makefile b/lang/ocaml/files/patch-camlp4-ocaml_src-lib::Makefile
new file mode 100644
index 000000000000..d3a97fbe1c94
--- /dev/null
+++ b/lang/ocaml/files/patch-camlp4-ocaml_src-lib::Makefile
@@ -0,0 +1,10 @@
+--- camlp4/ocaml_src/lib/Makefile.orig Sun Dec 14 02:38:28 2003
++++ camlp4/ocaml_src/lib/Makefile Sun Dec 14 02:38:55 2003
+@@ -43,6 +43,6 @@
+
+ installopt:
+ cp $(TARGET:.cma=.cmxa) *.cmx "$(LIBDIR)/camlp4/."
+- tar cf - $(TARGET:.cma=.$(A)) | (cd "$(LIBDIR)/camlp4/."; tar xf -)
++ tar cf - $(TARGET:S/.cma$/.$(A)/) | (cd "$(LIBDIR)/camlp4/."; tar xf -)
+
+ include .depend
diff --git a/lang/ocaml/files/patch-camlp4-ocaml_src-meta::Makefile b/lang/ocaml/files/patch-camlp4-ocaml_src-meta::Makefile
new file mode 100644
index 000000000000..17435d8a05aa
--- /dev/null
+++ b/lang/ocaml/files/patch-camlp4-ocaml_src-meta::Makefile
@@ -0,0 +1,11 @@
+--- camlp4/ocaml_src/meta/Makefile.orig Sun Dec 14 02:33:49 2003
++++ camlp4/ocaml_src/meta/Makefile Sun Dec 14 02:35:12 2003
+@@ -49,7 +49,7 @@
+ cp camlp4r$(EXE) "$(BINDIR)/."
+ if test -f camlp4r.opt; then \
+ cp camlp4r.opt "$(BINDIR)/camlp4r.opt$(EXE)" ;\
+- for target in $(OBJSX) $(OBJSX:.cmx=.$(O)) ; do \
++ for target in $(OBJSX) $(OBJSX:S/.cmx$/.$(O)/) ; do \
+ if test -f $$target; then \
+ cp $$target "$(LIBDIR)/camlp4/."; \
+ fi; \
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
new file mode 100644
index 000000000000..8c1859c9a004
--- /dev/null
+++ b/lang/ocaml/files/patch-configure
@@ -0,0 +1,125 @@
+--- configure.orig Thu Sep 25 10:17:13 2003
++++ configure Thu Dec 11 13:39:49 2003
+@@ -1097,116 +1097,14 @@
+ x11_include="not found"
+ x11_link="not found"
+
+-for dir in \
+- $x11_include_dir \
+- \
+- /usr/X11R6/include \
+- /usr/include/X11R6 \
+- /usr/local/X11R6/include \
+- /usr/local/include/X11R6 \
+- /opt/X11R6/include \
+- \
+- /usr/X11/include \
+- /usr/include/X11 \
+- /usr/local/X11/include \
+- /usr/local/include/X11 \
+- /opt/X11/include \
+- \
+- /usr/X11R5/include \
+- /usr/include/X11R5 \
+- /usr/local/X11R5/include \
+- /usr/local/include/X11R5 \
+- /usr/local/x11r5/include \
+- /opt/X11R5/include \
+- \
+- /usr/X11R4/include \
+- /usr/include/X11R4 \
+- /usr/local/X11R4/include \
+- /usr/local/include/X11R4 \
+- \
+- /usr/X386/include \
+- /usr/x386/include \
+- /usr/XFree86/include/X11 \
+- \
+- /usr/include \
+- /usr/local/include \
+- /usr/unsupported/include \
+- /usr/athena/include \
+- /usr/lpp/Xamples/include \
+- \
+- /usr/openwin/include \
+- /usr/openwin/share/include \
+- ; \
+-do
+- if test -f $dir/X11/X.h; then
+- x11_include=$dir
+- break
+- fi
+-done
+-
+-if test "$x11_include" = "not found"; then
+- x11_try_lib_dir=''
+-else
+- x11_try_lib_dir=`echo $x11_include | sed -e 's|include|lib|'`
++if [ -n "$x11_include_dir" ]; then
++ x11_include="$x11_include_dir"
+ fi
+
+-for dir in \
+- $x11_lib_dir \
+- $x11_try_lib_dir \
+- \
+- /usr/X11R6/lib \
+- /usr/lib/X11R6 \
+- /usr/local/X11R6/lib \
+- /usr/local/lib/X11R6 \
+- /opt/X11R6/lib \
+- \
+- /usr/X11/lib \
+- /usr/lib/X11 \
+- /usr/local/X11/lib \
+- /usr/local/lib/X11 \
+- /opt/X11/lib \
+- \
+- /usr/X11R5/lib \
+- /usr/lib/X11R5 \
+- /usr/local/X11R5/lib \
+- /usr/local/lib/X11R5 \
+- /usr/local/x11r5/lib \
+- /opt/X11R5/lib \
+- \
+- /usr/X11R4/lib \
+- /usr/lib/X11R4 \
+- /usr/local/X11R4/lib \
+- /usr/local/lib/X11R4 \
+- \
+- /usr/X386/lib \
+- /usr/x386/lib \
+- /usr/XFree86/lib/X11 \
+- \
+- /usr/lib \
+- /usr/local/lib \
+- /usr/unsupported/lib \
+- /usr/athena/lib \
+- /usr/lpp/Xamples/lib \
+- /lib/usr/lib/X11 \
+- \
+- /usr/openwin/lib \
+- /usr/openwin/share/lib \
+- ; \
+-do
+- if test -f $dir/libX11.a || \
+- test -f $dir/libX11.so || \
+- test -f $dir/libX11.dll.a || \
+- test -f $dir/libX11.sa; then
+- if test $dir = /usr/lib; then
+- x11_link="-lX11"
+- else
+- x11_link="-L$dir -lX11"
+- x11_libs="-L$dir"
+- fi
+- break
+- fi
+-done
+-
++if [ -n "$x11_lib_dir" ]; then
++ x11_link="-L$x11_lib_dir -lX11"
++ x11_libs="-L$x11_lib_dir"
++fi
+
+ if test "$x11_include" = "not found" || test "$x11_link" = "not found"
+ then
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index aee69c808d7c..c6cc4501233e 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -59,6 +59,7 @@ lib/ocaml/camlp4/fstream.mli
lib/ocaml/camlp4/gramext.cmi
lib/ocaml/camlp4/gramext.cmx
lib/ocaml/camlp4/gramext.mli
+lib/ocaml/camlp4/gramlib.a
lib/ocaml/camlp4/gramlib.cma
lib/ocaml/camlp4/gramlib.cmxa
lib/ocaml/camlp4/grammar.cmi
@@ -92,8 +93,10 @@ lib/ocaml/camlp4/pa_oop.cmo
lib/ocaml/camlp4/pa_op.cmo
lib/ocaml/camlp4/pa_r.cmo
lib/ocaml/camlp4/pa_r.cmx
+lib/ocaml/camlp4/pa_r.o
lib/ocaml/camlp4/pa_rp.cmo
lib/ocaml/camlp4/pa_rp.cmx
+lib/ocaml/camlp4/pa_rp.o
lib/ocaml/camlp4/pa_ru.cmo
lib/ocaml/camlp4/pa_scheme.cmo
lib/ocaml/camlp4/pa_sml.cmo
@@ -105,6 +108,7 @@ lib/ocaml/camlp4/plexer.mli
lib/ocaml/camlp4/pr_depend.cmo
lib/ocaml/camlp4/pr_dump.cmo
lib/ocaml/camlp4/pr_dump.cmx
+lib/ocaml/camlp4/pr_dump.o
lib/ocaml/camlp4/pr_extend.cmo
lib/ocaml/camlp4/pr_extfun.cmo
lib/ocaml/camlp4/pr_null.cmo
@@ -662,7 +666,7 @@ lib/ocaml/libasmrun.a
lib/ocaml/libasmrunp.a
lib/ocaml/libbigarray.a
lib/ocaml/libcamlrun.a
-lib/ocaml/libgraphics.a
+%%X11%%lib/ocaml/libgraphics.a
lib/ocaml/libmldbm.a
lib/ocaml/libnums.a
lib/ocaml/libstr.a