aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/tcltutor/Makefile21
-rw-r--r--lang/tcltutor/distinfo1
-rw-r--r--lang/tcltutor/files/patch-aa40
-rw-r--r--lang/tcltutor/pkg-comment1
-rw-r--r--lang/tcltutor/pkg-descr5
-rw-r--r--lang/tcltutor/pkg-plist49
7 files changed, 118 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 537c9381ba69..6a2c5fb49664 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -136,6 +136,7 @@
SUBDIR += tclX80
SUBDIR += tclX82
SUBDIR += tclplugin
+ SUBDIR += tcltutor
SUBDIR += tinycobol
SUBDIR += wamcc
SUBDIR += yabasic
diff --git a/lang/tcltutor/Makefile b/lang/tcltutor/Makefile
new file mode 100644
index 000000000000..90a72a41d407
--- /dev/null
+++ b/lang/tcltutor/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: tcltutor
+# Date created: 11 November 2000
+# Whom: Edwin Groothuis (mavetju@chello.nl)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcltutor
+PORTVERSION= 2.b.4
+CATEGORIES= lang tk82 tcl82
+MASTER_SITES= http://www.msen.com/~clif/
+DISTNAME= Tutor2b4
+
+MAINTAINER= mavetju@chello.nl
+
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+
+WRKSRC= ${WRKDIR}/TclTutor
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/lang/tcltutor/distinfo b/lang/tcltutor/distinfo
new file mode 100644
index 000000000000..cfc20d11d2fb
--- /dev/null
+++ b/lang/tcltutor/distinfo
@@ -0,0 +1 @@
+MD5 (Tutor2b4.tar.gz) = 4f8be3277c2aa6c298613d24f7165116
diff --git a/lang/tcltutor/files/patch-aa b/lang/tcltutor/files/patch-aa
new file mode 100644
index 000000000000..8ea5f13547bb
--- /dev/null
+++ b/lang/tcltutor/files/patch-aa
@@ -0,0 +1,40 @@
+--- ../TclTutor/Makefile Sat Nov 11 23:11:44 2000
++++ Makefile Sat Nov 11 23:37:04 2000
+@@ -0,0 +1,8 @@
++#
++# Fake makefile to copy everything into the right directory.
++#
++
++install:
++ mkdir -p /usr/local/share/doc/TclTutor
++ install -c -g wheel -o root -m 0644 *.lsn *.cfg /usr/local/share/doc/TclTutor
++ install -c -g wheel -o root -m 0755 scaler.tcl htmllib.tcl TclTutor.tcl /usr/local/bin
+--- ../TclTutor/TclTutor.tcl Tue May 9 02:50:40 2000
++++ TclTutor.tcl Sat Nov 11 22:58:07 2000
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec wish "$0" "$@"
++exec wish8.2 "$0" "$@"
+
+ ;# NAME: TclTutor.tcl
+ ;# AUTHOR: Clif Flynt
+@@ -214,6 +214,8 @@
+ set Tutor(Tcl.lessonFile) "G:/TCL_STUFF/TclTutor/TclTutor/Tcl0.lsn"
+ }
+
++set Tutor(lessonHome) "/usr/local/share/doc/TclTutor/"
++set Tutor(Tcl.lessonFile) "Tcl0.lsn"
+
+ # Initialize the various state indices.
+
+--- ../TclTutor/htmllib.tcl Tue May 9 02:50:39 2000
++++ htmllib.tcl Sat Nov 11 22:17:29 2000
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec wish "$0" ${1+"$@"}
++exec wish8.2 "$0" ${1+"$@"}
+
+ # CONFIGURATION DETAIL: SET THIS FOR YOUR IMAGE VIEWER:
+ # (xli, xv, ee, etc)
diff --git a/lang/tcltutor/pkg-comment b/lang/tcltutor/pkg-comment
new file mode 100644
index 000000000000..40470661388f
--- /dev/null
+++ b/lang/tcltutor/pkg-comment
@@ -0,0 +1 @@
+A Tcl/Tk based tutorial for Tcl
diff --git a/lang/tcltutor/pkg-descr b/lang/tcltutor/pkg-descr
new file mode 100644
index 000000000000..0078b3f2b9f6
--- /dev/null
+++ b/lang/tcltutor/pkg-descr
@@ -0,0 +1,5 @@
+TclTutor is a computer aided instruction package for learning the
+Tcl language. It consists of 43 lessons covering all of the basic
+Tcl commands and most of the recent (8.0) additions.
+
+http://www.msen.com/~clif/TclTutor.html
diff --git a/lang/tcltutor/pkg-plist b/lang/tcltutor/pkg-plist
new file mode 100644
index 000000000000..fd6658f6ad80
--- /dev/null
+++ b/lang/tcltutor/pkg-plist
@@ -0,0 +1,49 @@
+bin/TclTutor.tcl
+bin/scaler.tcl
+bin/htmllib.tcl
+share/doc/TclTutor/Tcl0.lsn
+share/doc/TclTutor/Tcl1.lsn
+share/doc/TclTutor/Tcl2.lsn
+share/doc/TclTutor/Tcl3.lsn
+share/doc/TclTutor/Tcl4.lsn
+share/doc/TclTutor/Tcl5.lsn
+share/doc/TclTutor/Tcl6.lsn
+share/doc/TclTutor/Tcl7.lsn
+share/doc/TclTutor/Tcl8.lsn
+share/doc/TclTutor/Tcl9.lsn
+share/doc/TclTutor/Tcl10.lsn
+share/doc/TclTutor/Tcl11.lsn
+share/doc/TclTutor/Tcl12.lsn
+share/doc/TclTutor/Tcl13.lsn
+share/doc/TclTutor/Tcl14.lsn
+share/doc/TclTutor/Tcl15.lsn
+share/doc/TclTutor/Tcl16.lsn
+share/doc/TclTutor/Tcl17.lsn
+share/doc/TclTutor/Tcl18.lsn
+share/doc/TclTutor/Tcl19.lsn
+share/doc/TclTutor/Tcl20.lsn
+share/doc/TclTutor/Tcl21.lsn
+share/doc/TclTutor/Tcl22.lsn
+share/doc/TclTutor/Tcl23.lsn
+share/doc/TclTutor/Tcl24.lsn
+share/doc/TclTutor/Tcl25.lsn
+share/doc/TclTutor/Tcl26.lsn
+share/doc/TclTutor/Tcl27.lsn
+share/doc/TclTutor/Tcl28.lsn
+share/doc/TclTutor/Tcl29.lsn
+share/doc/TclTutor/Tcl30.lsn
+share/doc/TclTutor/Tcl31.lsn
+share/doc/TclTutor/Tcl32.lsn
+share/doc/TclTutor/Tcl33.lsn
+share/doc/TclTutor/Tcl34.lsn
+share/doc/TclTutor/Tcl35.lsn
+share/doc/TclTutor/Tcl36.lsn
+share/doc/TclTutor/Tcl37.lsn
+share/doc/TclTutor/Tcl38.lsn
+share/doc/TclTutor/Tcl39.lsn
+share/doc/TclTutor/Tcl40.lsn
+share/doc/TclTutor/Tcl41.lsn
+share/doc/TclTutor/Tcl42.lsn
+share/doc/TclTutor/Tcl43.lsn
+share/doc/TclTutor/Tcl.cfg
+@dirrm share/doc/TclTutor