aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/monitord/Makefile3
-rw-r--r--sysutils/monitord/files/patch-mail.c39
2 files changed, 41 insertions, 1 deletions
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
index 05399cf9b24d..02a0dea49306 100644
--- a/sysutils/monitord/Makefile
+++ b/sysutils/monitord/Makefile
@@ -7,6 +7,7 @@
PORTNAME= monitord
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.erudition.net/pub/monitord/
@@ -16,6 +17,6 @@ COMMENT= Service that restarts other standalone services
MAN8= monitord.8
post-install:
- @${CP} ${WRKSRC}/monitord.conf.sample ${PREFIX}/etc/monitord.conf.sample
+ @${INSTALL_DATA} ${WRKSRC}/monitord.conf.sample ${PREFIX}/etc/monitord.conf.sample
.include <bsd.port.mk>
diff --git a/sysutils/monitord/files/patch-mail.c b/sysutils/monitord/files/patch-mail.c
new file mode 100644
index 000000000000..b0359e23696b
--- /dev/null
+++ b/sysutils/monitord/files/patch-mail.c
@@ -0,0 +1,39 @@
+--- ./mail.c.orig Thu Aug 21 15:44:20 2003
++++ ./mail.c Wed Mar 15 11:09:01 2006
+@@ -81,13 +81,13 @@
+ read (serversd, buf, _BUFSIZE);
+
+ // Set "MAIL FROM"
+- sprintf(buf, "MAIL FROM: monitord-notification@%s\n", thisname);
++ sprintf(buf, "MAIL FROM: <monitord-notification@%s>\n", thisname);
+ write(serversd, buf, strlen(buf));
+ read (serversd, buf, _BUFSIZE);
+
+ // set "RCPT TO"
+ bzero (buf, _BUFSIZE );
+- sprintf(buf, "RCPT TO: %s\n", address);
++ sprintf(buf, "RCPT TO: <%s>\n", address);
+ write(serversd, buf, strlen(buf));
+ read (serversd, buf, _BUFSIZE);
+
+@@ -97,17 +97,17 @@
+ read (serversd, buf, _BUFSIZE);
+
+ // Set "FROM"
+- sprintf(buf, "FROM: monitord-notification@%s\n", thisname);
++ sprintf(buf, "From: <monitord-notification@%s>\n", thisname);
+ write(serversd, buf, strlen(buf));
+
+ // set "TO"
+ bzero (buf, _BUFSIZE );
+- sprintf(buf, "TO: %s\n", address);
++ sprintf(buf, "To: <%s>\n", address);
+ write(serversd, buf, strlen(buf));
+
+ // set "SUBJECT"
+ bzero (buf, _BUFSIZE );
+- sprintf(buf, "SUBJECT: %s\n", subject);
++ sprintf(buf, "Subject: %s\n", subject);
+ write(serversd, buf, strlen(buf));
+
+ // send actual data