aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Precise/Makefile25
-rw-r--r--devel/p5-DateTime-Precise/distinfo1
-rw-r--r--devel/p5-DateTime-Precise/pkg-descr11
-rw-r--r--devel/p5-DateTime-Precise/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d144826d4c7f..2cd71580d447 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -543,6 +543,7 @@
SUBDIR += p5-DateConvert
SUBDIR += p5-DateTime
SUBDIR += p5-DateTime-LeapSecond
+ SUBDIR += p5-DateTime-Precise
SUBDIR += p5-DateTime-Set
SUBDIR += p5-DateTime-TimeZone
SUBDIR += p5-Devel-Constants
diff --git a/devel/p5-DateTime-Precise/Makefile b/devel/p5-DateTime-Precise/Makefile
new file mode 100644
index 000000000000..7d6ec6b4c7bd
--- /dev/null
+++ b/devel/p5-DateTime-Precise/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DateTime-Precise
+# Date created: 26 june 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Precise
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Perform common time and date operations with additional GPS operations
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Precise.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Precise/distinfo b/devel/p5-DateTime-Precise/distinfo
new file mode 100644
index 000000000000..0551f06fa980
--- /dev/null
+++ b/devel/p5-DateTime-Precise/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Precise-1.05.tar.gz) = 05845b6e53a528b406d10a231d0af091
diff --git a/devel/p5-DateTime-Precise/pkg-descr b/devel/p5-DateTime-Precise/pkg-descr
new file mode 100644
index 000000000000..8e67622f570a
--- /dev/null
+++ b/devel/p5-DateTime-Precise/pkg-descr
@@ -0,0 +1,11 @@
+The purpose of this library was to replace our dependence on Unix epoch time,
+which, being limited to a range of about 1970 to 2030, is inadequate for our
+purposes (we have data as old as 1870). This date library effectively handles
+dates from A.D. 1000 to infinity, and would probably work all the way back to 0
+(ignoring, of course, the switch-over to the Gregorian calendar). The useful
+features of Unix epoch time (ease of date difference calculation and date
+comparison, strict ordering) are preserved, and elements such as
+human-legibility are added. The library handles fractional seconds and some
+date/time manipulations used for the Global Positioning Satellite system.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Precise/pkg-plist b/devel/p5-DateTime-Precise/pkg-plist
new file mode 100644
index 000000000000..4bce58abc854
--- /dev/null
+++ b/devel/p5-DateTime-Precise/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Precise/.packlist
+%%SITE_PERL%%/DateTime/Precise.pm
+%%SITE_PERL%%/DateTime/Math/bigint.pl
+%%SITE_PERL%%/DateTime/Math/bigfloat.pl
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Precise
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/5.00503/man/man3 2>/dev/null || true