aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/alf/Makefile20
-rw-r--r--devel/alf/distinfo1
-rw-r--r--devel/alf/pkg-comment1
-rw-r--r--devel/alf/pkg-descr5
-rw-r--r--devel/alf/pkg-plist9
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 85d9b9e0778d..671a3399f926 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -19,6 +19,7 @@
SUBDIR += agenda-snow-libs
SUBDIR += agenda-static-libs
SUBDIR += ald
+ SUBDIR += alf
SUBDIR += allegro
SUBDIR += anjuta
SUBDIR += apr
diff --git a/devel/alf/Makefile b/devel/alf/Makefile
new file mode 100644
index 000000000000..271f1f4a49ba
--- /dev/null
+++ b/devel/alf/Makefile
@@ -0,0 +1,20 @@
+# ex:ts=8
+# Ports collection makefile for: alf
+# Date created: Sep 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= alf
+PORTVERSION= 0.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= largefiles
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_LIBTOOL= yes
+
+.include <bsd.port.mk>
diff --git a/devel/alf/distinfo b/devel/alf/distinfo
new file mode 100644
index 000000000000..e6662c85f725
--- /dev/null
+++ b/devel/alf/distinfo
@@ -0,0 +1 @@
+MD5 (alf-0.1.tar.gz) = 3c04379f2ff3dc0d94a7a5a56b5580d3
diff --git a/devel/alf/pkg-comment b/devel/alf/pkg-comment
new file mode 100644
index 000000000000..00025b3d72af
--- /dev/null
+++ b/devel/alf/pkg-comment
@@ -0,0 +1 @@
+Abstract Large File
diff --git a/devel/alf/pkg-descr b/devel/alf/pkg-descr
new file mode 100644
index 000000000000..34f8b6568371
--- /dev/null
+++ b/devel/alf/pkg-descr
@@ -0,0 +1,5 @@
+The Abstract Large File (ALF) project is a portable library for writing files
+that can be larger than 2GB or contain holes on systems that don't natively
+support one or both properties.
+
+WWW: http://sourceforge.net/projects/largefiles/
diff --git a/devel/alf/pkg-plist b/devel/alf/pkg-plist
new file mode 100644
index 000000000000..a70a163b0cd5
--- /dev/null
+++ b/devel/alf/pkg-plist
@@ -0,0 +1,9 @@
+include/alf/alf.h
+include/alf/common.h
+lib/libalf.a
+lib/libalf.la
+lib/libalf.so
+lib/libalf.so.0
+%%PYTHON_SITELIBDIR%%/alfmodule.a
+%%PYTHON_SITELIBDIR%%/alfmodule.la
+%%PYTHON_SITELIBDIR%%/alfmodule.so