aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/crafty-open-medium/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/crafty-open-medium/Makefile b/games/crafty-open-medium/Makefile
index 703182719af5..bef8b17981a0 100644
--- a/games/crafty-open-medium/Makefile
+++ b/games/crafty-open-medium/Makefile
@@ -21,6 +21,12 @@ DIST_SUBDIR= crafty
USE_ZIP= yes
NO_WRKSUBDIR= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Coredump during build"
+.endif
+
do-build:
@${ECHO_MSG} '================================================================'
@${ECHO_MSG} 'Ignore warnings about illegal moves. These warnings are normal.'
@@ -31,4 +37,4 @@ do-install:
${MKDIR} ${PREFIX}/lib/crafty
${INSTALL_DATA} ${WRKDIR}/book.bin ${PREFIX}/lib/crafty/medium-book.bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>