aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libusb/Makefile19
-rw-r--r--devel/libusb/distinfo1
-rw-r--r--devel/libusb/pkg-comment1
-rw-r--r--devel/libusb/pkg-descr8
-rw-r--r--devel/libusb/pkg-plist7
6 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index fbf3343fe3d2..cf3cde801439 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -173,6 +173,7 @@
SUBDIR += libtecla
SUBDIR += libtool
SUBDIR += libunicode
+ SUBDIR += libusb
SUBDIR += libxalloc
SUBDIR += lincvs
SUBDIR += linguist
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
new file mode 100644
index 000000000000..66fd9f0dd2a1
--- /dev/null
+++ b/devel/libusb/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: libusb
+# Date created: 27 January 2001
+# Whom: John Reynolds <jjreynold@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libusb
+PORTVERSION= 0.1.3b
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libusb
+
+MAINTAINER= jjreynold@home.com
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libusb/distinfo b/devel/libusb/distinfo
new file mode 100644
index 000000000000..5b0d08f105fe
--- /dev/null
+++ b/devel/libusb/distinfo
@@ -0,0 +1 @@
+MD5 (libusb-0.1.3b.tar.gz) = a5d80dff371935ca0bb0e4f9547ac401
diff --git a/devel/libusb/pkg-comment b/devel/libusb/pkg-comment
new file mode 100644
index 000000000000..357dc3eba768
--- /dev/null
+++ b/devel/libusb/pkg-comment
@@ -0,0 +1 @@
+Library giving userland programs access to USB devices
diff --git a/devel/libusb/pkg-descr b/devel/libusb/pkg-descr
new file mode 100644
index 000000000000..dc8fb6e8149c
--- /dev/null
+++ b/devel/libusb/pkg-descr
@@ -0,0 +1,8 @@
+A library originally developed under Linux to give userland programs
+an API to access to USB hardware. The FreeBSD port was originally
+done by Richard Tobin <richard@cogsci.ed.ac.uk> and should still
+be considered "beta" (not all calls implemented in the Linux port
+are available). Allows gPhoto, gPhoto2, s10sh and others to access
+USB under FreeBSD successfully.
+
+WWW: http://sourceforge.net/projects/libusb/
diff --git a/devel/libusb/pkg-plist b/devel/libusb/pkg-plist
new file mode 100644
index 000000000000..90bf30c76104
--- /dev/null
+++ b/devel/libusb/pkg-plist
@@ -0,0 +1,7 @@
+bin/libusb-config
+include/usb.h
+lib/libusb-0.1.so.3
+lib/libusb-0.1.so
+lib/libusb.so
+lib/libusb.la
+lib/libusb.a