aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/genius/Makefile3
-rw-r--r--devel/avr-gcc-devel/Makefile3
-rw-r--r--devel/cross-gcc/Makefile2
-rw-r--r--devel/djgpp-gcc/Makefile2
-rw-r--r--devel/mingw32-gcc/Makefile2
-rw-r--r--lang/gcc/Makefile2
-rw-r--r--lang/gcc42/Makefile2
-rw-r--r--lang/gcc43/Makefile2
-rw-r--r--lang/gcc44/Makefile2
-rw-r--r--lang/gcc45/Makefile2
-rw-r--r--lang/gcc46/Makefile2
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gnat-gcc43/Makefile3
-rw-r--r--math/gretl/Makefile3
-rw-r--r--math/sdpa-gmp/Makefile3
-rw-r--r--math/wcalc/Makefile3
17 files changed, 23 insertions, 17 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index d9368f76bbd7..47b4caa802bd 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -7,6 +7,7 @@
PORTNAME= genius
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME \
http://ftp.5z.com/pub/genius/
@@ -14,7 +15,7 @@ MASTER_SITES= GNOME \
MAINTAINER= ports@FreeBSD.org
COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
-LIB_DEPENDS= mpfr.2:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= mpfr.3:${PORTSDIR}/math/mpfr
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview2 intlhack \
diff --git a/devel/avr-gcc-devel/Makefile b/devel/avr-gcc-devel/Makefile
index fe61aedc5b1f..0c4f009430ba 100644
--- a/devel/avr-gcc-devel/Makefile
+++ b/devel/avr-gcc-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc-devel
PORTVERSION= 4.3.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -22,7 +23,7 @@ COMMENT= FSF GCC 4.3.x for Atmel AVR 8-bit RISC cross-development
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
-LIB_DEPENDS= mpfr.2:${PORTSDIR}/math/mpfr \
+LIB_DEPENDS= mpfr.3:${PORTSDIR}/math/mpfr \
gmp.7:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index cd527e430675..a33aebe355b3 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -158,7 +158,7 @@ TGTLANGS:= "${TGTLANGS},objc"
.if defined(WITH_FORTRAN)
TGTLANGS:= "${TGTLANGS},fortran"
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
PLIST_FILES+= bin/${OURTARGET}-gfortran \
${OURTARGET}/bin/gfortran
diff --git a/devel/djgpp-gcc/Makefile b/devel/djgpp-gcc/Makefile
index 1ca74f3bfa09..5d26bc285f90 100644
--- a/devel/djgpp-gcc/Makefile
+++ b/devel/djgpp-gcc/Makefile
@@ -33,7 +33,7 @@ BUILD_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
aclocal-1.9:${PORTSDIR}/devel/automake19
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
.endif
RUN_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${LOCALBASE}/${TARGET}/bin/stubify:${PORTSDIR}/devel/${PKGNAMEPREFIX}crx
diff --git a/devel/mingw32-gcc/Makefile b/devel/mingw32-gcc/Makefile
index 31f1d4eae658..06a116abe894 100644
--- a/devel/mingw32-gcc/Makefile
+++ b/devel/mingw32-gcc/Makefile
@@ -115,7 +115,7 @@ PLIST_SUB+= OBJCXX="@comment "
.if defined(WITH_LANG_FORTRAN)
DISTFILES+= gcc-fortran-${GCCVERSION}${EXTRACT_SUFX}
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE} \
--with-mpfr=${LOCALBASE}
MAN1+= ${PKGNAMEPREFIX}gfortran.1
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 49054a1ade6a..1219c5f2baf1 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.2
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 42
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index dfac2d310926..2905de9bcb5d 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index aaa372dad9bb..f7df721d1d67 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
SUFFIX= 44
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index c37e12796539..9f2bdbba8724 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -9,6 +9,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.3.2
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/releases/gcc-${PORTVERSION} \
CENKES:boot \
@@ -22,7 +23,7 @@ MAINTAINER= karel@lovetemple.net
COMMENT= The GNU Ada Compiler system
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 7778218a6c6f..8c08af478d55 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gretl
PORTVERSION= 1.7.9
+PORTREVISION= 1
CATEGORIES= math finance
MASTER_SITES= SF
@@ -16,7 +17,7 @@ COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
diff --git a/math/sdpa-gmp/Makefile b/math/sdpa-gmp/Makefile
index 0c1fbc3b5ee5..0f668258f76d 100644
--- a/math/sdpa-gmp/Makefile
+++ b/math/sdpa-gmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdpa-gmp
PORTVERSION= 7.1.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://sdpa.indsys.chuo-u.ac.jp/sdpa/files/
DISTFILES= ${SRCFILE} ${MANUALFILE}
@@ -25,7 +26,7 @@ MANUALFILE= sdpa.${PORTVERSION}.manual.${MANDATE}.pdf
GNU_CONFIGURE= yes
LIB_DEPENDS+= spooles:${PORTSDIR}/math/spooles \
gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-system-spooles
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/wcalc/Makefile b/math/wcalc/Makefile
index ffc3c797e5b4..c620cb79ae61 100644
--- a/math/wcalc/Makefile
+++ b/math/wcalc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wcalc
PORTVERSION= 2.4
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= w-calc
@@ -16,7 +17,7 @@ MAINTAINER= amarendra.godbole@gmail.com
COMMENT= A natural-expression command-line calculator
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.2:${PORTSDIR}/math/mpfr
+ mpfr.3:${PORTSDIR}/math/mpfr
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib