aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/mupen64plus-core/Makefile.common2
-rw-r--r--emulators/mupen64plus/Makefile8
2 files changed, 5 insertions, 5 deletions
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 36ad55645a42..486db1dc65a5 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -84,7 +84,7 @@ do-install:
. if ${PKGNAMESUFFIX} != "-ui-console"
@${MKDIR} ${PREFIX}/lib/${PORTNAME}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${PREFIX}/lib/${PORTNAME}
. else
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
. endif
diff --git a/emulators/mupen64plus/Makefile b/emulators/mupen64plus/Makefile
index 44197a479534..1c27951e0ff7 100644
--- a/emulators/mupen64plus/Makefile
+++ b/emulators/mupen64plus/Makefile
@@ -21,14 +21,14 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64
RUN_DEPENDS+= mupen64plus:${PORTSDIR}/emulators/mupen64plus-ui-console
# Audio plugins
-RUN_DEPENDS+= ${LOCALBASE}/lib/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl
# Input plugins
-RUN_DEPENDS+= ${LOCALBASE}/lib/mupen64plus-input-sdl.so:${PORTSDIR}/emulators/mupen64plus-input-sdl
-RUN_DEPENDS+= ${LOCALBASE}/lib/mupen64plus-rsp-hle.so:${PORTSDIR}/emulators/mupen64plus-rsp-hle
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-input-sdl.so:${PORTSDIR}/emulators/mupen64plus-input-sdl
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-rsp-hle.so:${PORTSDIR}/emulators/mupen64plus-rsp-hle
# Graphics plugins
-RUN_DEPENDS+= ${LOCALBASE}/lib/mupen64plus-video-rice.so:${PORTSDIR}/emulators/mupen64plus-video-rice
+RUN_DEPENDS+= ${LOCALBASE}/lib/${PORTNAME}/mupen64plus-video-rice.so:${PORTSDIR}/emulators/mupen64plus-video-rice
NO_MTREE= yes
NO_BUILD= yes