aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rsyslog4-devel-mysql/Makefile27
-rw-r--r--sysutils/rsyslog4-devel-mysql/pkg-plist4
-rw-r--r--sysutils/rsyslog4-mysql/Makefile27
-rw-r--r--sysutils/rsyslog4-mysql/pkg-plist4
-rw-r--r--sysutils/rsyslog5-devel-mysql/Makefile27
-rw-r--r--sysutils/rsyslog5-devel-mysql/pkg-plist4
-rw-r--r--sysutils/rsyslog5-mysql/Makefile27
-rw-r--r--sysutils/rsyslog5-mysql/pkg-plist4
-rw-r--r--sysutils/rsyslog55-mysql/Makefile27
-rw-r--r--sysutils/rsyslog55-mysql/pkg-plist4
-rw-r--r--sysutils/rsyslog6-devel-mysql/Makefile27
-rw-r--r--sysutils/rsyslog6-devel-mysql/pkg-plist4
13 files changed, 187 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index aa0484337ce4..364eb83d2ff3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -642,6 +642,7 @@
SUBDIR += rsyslog4-dbi
SUBDIR += rsyslog4-gnutls
SUBDIR += rsyslog4-gssapi
+ SUBDIR += rsyslog4-mysql
SUBDIR += rtty
SUBDIR += ruby-log4r
SUBDIR += ruby-quota
diff --git a/sysutils/rsyslog4-devel-mysql/Makefile b/sysutils/rsyslog4-devel-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog4-devel-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog4-devel-mysql/pkg-plist b/sysutils/rsyslog4-devel-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog4-devel-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/sysutils/rsyslog4-mysql/Makefile b/sysutils/rsyslog4-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog4-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog4-mysql/pkg-plist b/sysutils/rsyslog4-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog4-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/sysutils/rsyslog5-devel-mysql/Makefile b/sysutils/rsyslog5-devel-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog5-devel-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog5-devel-mysql/pkg-plist b/sysutils/rsyslog5-devel-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog5-devel-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/sysutils/rsyslog5-mysql/Makefile b/sysutils/rsyslog5-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog5-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog5-mysql/pkg-plist b/sysutils/rsyslog5-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog5-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/sysutils/rsyslog55-mysql/Makefile b/sysutils/rsyslog55-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog55-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog55-mysql/pkg-plist b/sysutils/rsyslog55-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog55-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
diff --git a/sysutils/rsyslog6-devel-mysql/Makefile b/sysutils/rsyslog6-devel-mysql/Makefile
new file mode 100644
index 000000000000..b79f1b0acb65
--- /dev/null
+++ b/sysutils/rsyslog6-devel-mysql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rsyslog4-mysql
+# Date created: 29 December 2008
+# Whom: Cristiano Rolim Pereira <cristianorolim@hotmail.com>
+#
+# $FreeBSD$
+#
+
+COMMENT= MySQL output module for rsyslog
+
+MNAME= mysql
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../rsyslog4/bsd.rsyslog.mk"
+
+CONFIGURE_ARGS+=--enable-mysql
+
+do-install:
+ @${INSTALL_PROGRAM} \
+ ${WRKSRC}/plugins/ommysql/.libs/ommysql.so ${PREFIX}/lib/rsyslog
+ @${INSTALL_DATA} \
+ ${WRKSRC}/plugins/ommysql/ommysql.la ${PREFIX}/lib/rsyslog
+post-install:
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/plugins/ommysql/createDB.sql ${EXAMPLESDIR}/mysql_createDB.sql
+.endif
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog6-devel-mysql/pkg-plist b/sysutils/rsyslog6-devel-mysql/pkg-plist
new file mode 100644
index 000000000000..3321cd33fa3a
--- /dev/null
+++ b/sysutils/rsyslog6-devel-mysql/pkg-plist
@@ -0,0 +1,4 @@
+lib/rsyslog/ommysql.la
+lib/rsyslog/ommysql.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql_createDB.sql
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%