aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/doscmd/Makefile26
-rw-r--r--emulators/doscmd/distinfo2
-rw-r--r--emulators/doscmd/pkg-descr2
-rw-r--r--emulators/doscmd/pkg-plist9
5 files changed, 40 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 152cbc94d7be..1a0f30ba8453 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -16,6 +16,7 @@
SUBDIR += dgen-sdl
SUBDIR += dlx
SUBDIR += dosbox
+ SUBDIR += doscmd
SUBDIR += extract-xiso
SUBDIR += fceu
SUBDIR += fmsx
diff --git a/emulators/doscmd/Makefile b/emulators/doscmd/Makefile
new file mode 100644
index 000000000000..2a6f7feaf6f8
--- /dev/null
+++ b/emulators/doscmd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: doscmd
+# Date created: 2004-03-23
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= doscmd
+PORTVERSION= 20040323
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= des
+
+MAINTAINER= des@freebsd.org
+COMMENT= DOS emulator
+
+ONLY_FOR_ARCHS= i386
+.ifdef WITHOUT_X11
+MAKE_ARGS+= -DNO_X
+PLIST_SUB+= X11="@comment "
+.else
+USE_XLIB= yes
+PLIST_SUB+= X11=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/doscmd/distinfo b/emulators/doscmd/distinfo
new file mode 100644
index 000000000000..144fb3d5909c
--- /dev/null
+++ b/emulators/doscmd/distinfo
@@ -0,0 +1,2 @@
+MD5 (doscmd-20040323.tar.gz) = 9c3c4f6d5c542a8d8f54d6ab434aad75
+SIZE (doscmd-20040323.tar.gz) = 183322
diff --git a/emulators/doscmd/pkg-descr b/emulators/doscmd/pkg-descr
new file mode 100644
index 000000000000..1dbe5940d0af
--- /dev/null
+++ b/emulators/doscmd/pkg-descr
@@ -0,0 +1,2 @@
+The doscmd utility emulates a sufficiently large subset of the PC BIOS
+to boot older DOS versions and run DOS applications.
diff --git a/emulators/doscmd/pkg-plist b/emulators/doscmd/pkg-plist
new file mode 100644
index 000000000000..35fccfebccbd
--- /dev/null
+++ b/emulators/doscmd/pkg-plist
@@ -0,0 +1,9 @@
+bin/doscmd
+share/doscmd/emsdriv.sys
+%%X11%%share/doscmd/fonts/cp437-8x14.pcf.gz
+%%X11%%share/doscmd/fonts/cp437-8x16.pcf.gz
+%%X11%%share/doscmd/fonts/cp437-8x8.pcf.gz
+%%X11%%share/doscmd/fonts/fonts.dir
+share/doscmd/redir.com
+%%X11%%@dirrm share/doscmd/fonts
+@dirrm share/doscmd