aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/ezquake/Makefile3
-rw-r--r--games/vultures-claw/Makefile3
-rw-r--r--games/vultures-eye/Makefile5
-rw-r--r--games/xmoto/Makefile4
4 files changed, 14 insertions, 1 deletions
diff --git a/games/ezquake/Makefile b/games/ezquake/Makefile
index 47996de73191..0d9d043fef2e 100644
--- a/games/ezquake/Makefile
+++ b/games/ezquake/Makefile
@@ -81,8 +81,9 @@ do-extract:
post-patch:
@${REINPLACE_CMD} -e 's|libtcl\.so|libtcl${TCL_VER:S/.//}|' \
${WRKSRC}/embed_tcl.h
-# Resolve name collision with jpeg-8
+# Resolve name collision with jpeg-8 and API png
${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
${WRKSRC}/image.c
do-install:
diff --git a/games/vultures-claw/Makefile b/games/vultures-claw/Makefile
index c86f85e01b32..df12ad2f2913 100644
--- a/games/vultures-claw/Makefile
+++ b/games/vultures-claw/Makefile
@@ -39,5 +39,8 @@ post-configure:
@${REINPLACE_CMD} -e \
's|#include <SDL_image.h>||g' \
${WRKSRC}/win/vultures/vultures_gfl.c
+ @${REINPLACE_CMD} -e \
+ 's|png_infopp_NULL|NULL|g' \
+ ${WRKSRC}/win/vultures/util/tiletrans.c
.include <bsd.port.mk>
diff --git a/games/vultures-eye/Makefile b/games/vultures-eye/Makefile
index 21b2296622da..64a4337df521 100644
--- a/games/vultures-eye/Makefile
+++ b/games/vultures-eye/Makefile
@@ -31,6 +31,11 @@ DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
MAKE_ENV+= DATADIR="${DATADIR}" MAKE="${GMAKE}"
MAKE_JOBS_UNSAFE= yes
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|png_infopp_NULL|NULL|g' \
+ ${WRKSRC}/win/vultures/util/tiletrans.c
+
pre-configure:
@${CHMOD} 755 ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 4359002f0a33..8fb5d0e0ec87 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -68,6 +68,10 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/src/image/tim_png.cpp
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}