aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-CIDR-Set/Makefile19
-rw-r--r--net/p5-Net-CIDR-Set/distinfo2
-rw-r--r--net/p5-Net-CIDR-Set/pkg-descr11
-rw-r--r--net/p5-Net-CIDR-Set/pkg-plist9
5 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e9d759a169e3..07c6a79402ac 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -549,6 +549,7 @@
SUBDIR += p5-Net-Blogger
SUBDIR += p5-Net-CIDR-Lite
SUBDIR += p5-Net-CIDR-MobileJP
+ SUBDIR += p5-Net-CIDR-Set
SUBDIR += p5-Net-CLI-Interact
SUBDIR += p5-Net-CSTA
SUBDIR += p5-Net-CascadeCopy
diff --git a/net/p5-Net-CIDR-Set/Makefile b/net/p5-Net-CIDR-Set/Makefile
new file mode 100644
index 000000000000..4480e3d8cca5
--- /dev/null
+++ b/net/p5-Net-CIDR-Set/Makefile
@@ -0,0 +1,19 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= Net-CIDR-Set
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anes@anes.su
+COMMENT= Manipulate sets of IP addresses
+
+LICENSE= GPLv2 ART20
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-CIDR-Set/distinfo b/net/p5-Net-CIDR-Set/distinfo
new file mode 100644
index 000000000000..2b9403ae49c9
--- /dev/null
+++ b/net/p5-Net-CIDR-Set/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-CIDR-Set-0.11.tar.gz) = 96b77d0e4d532435690857f027507f9ea28c947d8e1d8d85093ec768bf812fc4
+SIZE (Net-CIDR-Set-0.11.tar.gz) = 10941
diff --git a/net/p5-Net-CIDR-Set/pkg-descr b/net/p5-Net-CIDR-Set/pkg-descr
new file mode 100644
index 000000000000..0107bd2f292f
--- /dev/null
+++ b/net/p5-Net-CIDR-Set/pkg-descr
@@ -0,0 +1,11 @@
+Net::CIDR::Set represents sets of IP addresses and
+allows standard set operations (union, intersection,
+membership test etc) to be performed on them.
+
+In spite of the name it can work with sets consisting
+of arbitrary ranges of IP addresses - not just CIDR blocks.
+
+Both IPv4 and IPv6 addresses are handled - but they may not
+be mixed in the same set.
+
+WWW: http://search.cpan.org/dist/Net-CIDR-Set/
diff --git a/net/p5-Net-CIDR-Set/pkg-plist b/net/p5-Net-CIDR-Set/pkg-plist
new file mode 100644
index 000000000000..aed44f8c055b
--- /dev/null
+++ b/net/p5-Net-CIDR-Set/pkg-plist
@@ -0,0 +1,9 @@
+%%PERL5_MAN3%%/Net::CIDR::Set.3.gz
+%%PERL5_MAN3%%/Net::CIDR::Set::IPv4.3.gz
+%%PERL5_MAN3%%/Net::CIDR::Set::IPv6.3.gz
+%%SITE_PERL%%/Net/CIDR/Set.pm
+%%SITE_PERL%%/Net/CIDR/Set/IPv4.pm
+%%SITE_PERL%%/Net/CIDR/Set/IPv6.pm
+@dirrm %%SITE_PERL%%/Net/CIDR/Set
+@dirrmtry %%SITE_PERL%%/Net/CIDR
+@dirrmtry %%SITE_PERL%%/Net