aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Filesys-Virtual/Makefile28
-rw-r--r--devel/p5-Filesys-Virtual/distinfo2
-rw-r--r--devel/p5-Filesys-Virtual/files/5.005_03-Virtual.pm11
-rw-r--r--devel/p5-Filesys-Virtual/files/5.005_03-Virtual::Plain.pm18
-rw-r--r--devel/p5-Filesys-Virtual/pkg-descr7
-rw-r--r--devel/p5-Filesys-Virtual/pkg-plist6
7 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 19e4525e6b03..1a0d2811bda2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -777,6 +777,7 @@
SUBDIR += p5-File-chdir
SUBDIR += p5-FileHandle-Unget
SUBDIR += p5-Filesys-Statvfs_Df
+ SUBDIR += p5-Filesys-Virtual
SUBDIR += p5-Filter
SUBDIR += p5-Filter-CBC
SUBDIR += p5-FreezeThaw
diff --git a/devel/p5-Filesys-Virtual/Makefile b/devel/p5-Filesys-Virtual/Makefile
new file mode 100644
index 000000000000..a21ce23b6b4c
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Filesys-Virtual
+# Date created: 27 June 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Filesys-Virtual
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Filesys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Perl extension to provide a framework for a virtual filesystem
+
+PERL_CONFIGURE= yes
+
+MAN3= Filesys::Virtual.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+EXTRA_PATCHES= ${PATCHDIR}/5.005_03-*
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Filesys-Virtual/distinfo b/devel/p5-Filesys-Virtual/distinfo
new file mode 100644
index 000000000000..8677346b4f71
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/distinfo
@@ -0,0 +1,2 @@
+MD5 (Filesys-Virtual-0.04.tar.gz) = c4a92c5aeb7a64530e9461c266fa6ac8
+SIZE (Filesys-Virtual-0.04.tar.gz) = 5388
diff --git a/devel/p5-Filesys-Virtual/files/5.005_03-Virtual.pm b/devel/p5-Filesys-Virtual/files/5.005_03-Virtual.pm
new file mode 100644
index 000000000000..acda579ea84f
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/files/5.005_03-Virtual.pm
@@ -0,0 +1,11 @@
+--- Virtual.pm.orig Sun Jun 27 20:45:37 2004
++++ Virtual.pm Sun Jun 27 20:46:10 2004
+@@ -18,7 +18,7 @@
+ use Carp;
+ use IO::File;
+
+-our $VERSION = '0.04';
++use vars qw($VERSION); $VERSION = '0.04';
+
+ # login:
+
diff --git a/devel/p5-Filesys-Virtual/files/5.005_03-Virtual::Plain.pm b/devel/p5-Filesys-Virtual/files/5.005_03-Virtual::Plain.pm
new file mode 100644
index 000000000000..d05fcb97d240
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/files/5.005_03-Virtual::Plain.pm
@@ -0,0 +1,18 @@
+--- Virtual/Plain.pm.orig Sun Jun 27 20:46:26 2004
++++ Virtual/Plain.pm Sun Jun 27 20:47:17 2004
+@@ -20,11 +20,11 @@
+ use User::grent;
+ use IO::File;
+
+-our $AUTOLOAD;
+-our $VERSION = '0.04';
+-our @ISA = qw(Filesys::Virtual);
++use vars qw($AUTOLOAD $VERSION @ISA %_fields);
++$VERSION = '0.04';
++@ISA = qw(Filesys::Virtual);
+
+-our %_fields = (
++%_fields = (
+ 'cwd' => '1',
+ 'root_path' => '1',
+ 'home_path' => '1',
diff --git a/devel/p5-Filesys-Virtual/pkg-descr b/devel/p5-Filesys-Virtual/pkg-descr
new file mode 100644
index 000000000000..d1d19e702c2c
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/pkg-descr
@@ -0,0 +1,7 @@
+Perl extension to provide a framework for a virtual filesystem.
+Currently this module only exists to complement
+POE::Component::Server::FTP.
+
+Author: L.M.Orchard <deus_x@pobox.com>, David Davis <xantus@cpan.org>
+
+WWW: http://search.cpan.org/dist/Filesys-Virtual/
diff --git a/devel/p5-Filesys-Virtual/pkg-plist b/devel/p5-Filesys-Virtual/pkg-plist
new file mode 100644
index 000000000000..0e5636c4749d
--- /dev/null
+++ b/devel/p5-Filesys-Virtual/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Filesys/Virtual.pm
+%%SITE_PERL%%/Filesys/Virtual/Plain.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Virtual/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Virtual 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Filesys/Virtual 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Filesys 2>/dev/null || true