aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/mozc-server/Makefile68
-rw-r--r--japanese/mozc-server/files/patch-base_base.gyp6
-rw-r--r--japanese/mozc-server/files/patch-base_iconv.cc6
-rw-r--r--japanese/mozc-server/files/patch-base_mutex.cc11
-rw-r--r--japanese/mozc-server/files/patch-base_mutex.h26
-rw-r--r--japanese/mozc-server/files/patch-base_process.cc4
-rw-r--r--japanese/mozc-server/files/patch-build_tools_util.py4
-rw-r--r--japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc4
-rw-r--r--japanese/mozc-server/files/patch-gyp_common.gypi10
-rw-r--r--japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc6
-rw-r--r--japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc4
-rw-r--r--japanese/mozc-server/files/patch-ipc_unix_ipc.cc12
-rw-r--r--japanese/mozc-server/files/patch-server_mozc_server.cc10
-rw-r--r--japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py8
-rw-r--r--japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py4
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py10
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_mozc.xml2
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc6
-rw-r--r--japanese/mozc-server/files/patch-unix_ibus_path_util.cc4
-rw-r--r--japanese/mozc-server/files/patch-unix_scim_scim.gyp11
-rw-r--r--japanese/scim-mozc/Makefile2
21 files changed, 81 insertions, 137 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index afe1316cc00e..736e0d2e4c6e 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= mozc
-PORTVERSION= 1.5.1090.102
-PORTREVISION= 7
+PORTVERSION= 1.6.1187.102
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
PKGNAMESUFFIX?= -server
MAINTAINER= daichi@FreeBSD.org
-COMMENT?= Mozc server for IBus, SCIM, and others
+COMMENT?= Mozc server for IBus and others
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
gtest.0:${PORTSDIR}/devel/googletest \
@@ -32,9 +31,8 @@ BUILD_MOZC_LIST?= mozc_server
.if ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool"
USE_QT4+= gui dbus qmake_build moc_build uic_build rcc_build
-.elif ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc" || \
- ${BUILD_MOZC_LIST:Mscim_mozc} == "scim_mozc"
-USE_GNOME+= pygtk2
+.elif ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
+USE_GNOME+= glib20 gtk20 pygtk2
.elif ${BUILD_MOZC_LIST:Mfcitx_mozc} == "fcitx_mozc"
USE_GNOME+= glib20 gtk20
.elif ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
@@ -62,8 +60,6 @@ LOCALBASE_REPLACE_FILES= \
unix/ibus/gen_mozc_xml.py \
unix/ibus/mozc.xml \
unix/ibus/path_util.cc \
- unix/scim/scim.gyp \
- unix/scim/scim_mozc.cc \
base/util.cc \
base/process.cc \
gui/about_dialog/about_dialog.cc \
@@ -73,13 +69,7 @@ SSL_REINPLACE_STR=
SSL_REINPLACE_STR+= -e "s,%%${V}%%,${${V}},"
.endfor
-.if ${BUILD_MOZC_LIST:Mmozc_server} == "mozc_server" || \
- ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool" || \
- ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
-GYP_DEFINES="use_libprotobuf=1 enable_gtk_renderer=0"
-.else
GYP_DEFINES="use_libprotobuf=1"
-.endif
BUILD_CMD= ${SETENV} ${MAKE_ENV} ${GMAKE}
BUILD_MOZC_CMD= cd ${BUILD_WRKSRC} && \
@@ -154,7 +144,8 @@ do-install-mozc_tool:
# ibus_mozc
.if ${BUILD_MOZC_LIST:Mibus_mozc} == "ibus_mozc"
-LIB_DEPENDS+= ibus-1.0.401:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS+= ibus-1.0.401:${PORTSDIR}/textproc/ibus \
+ xcb-xfixes.0:${PORTSDIR}/x11/libxcb
RUN_DEPENDS+= mozc_server:${PORTSDIR}/japanese/mozc-server \
mozc_tool:${PORTSDIR}/japanese/mozc-tool \
mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
@@ -196,53 +187,6 @@ do-install-ibus_mozc:
${DATADIR}/icons/product_logo.png
.endif
-# scim_mozc
-.if ${BUILD_MOZC_LIST:Mscim_mozc} == "scim_mozc"
-BUILD_DEPENDS+= scim:${PORTSDIR}/textproc/scim
-RUN_DEPENDS+= scim:${PORTSDIR}/textproc/scim \
- mozc_server:${PORTSDIR}/japanese/mozc-server \
- mozc_tool:${PORTSDIR}/japanese/mozc-tool \
- mozc_server_start:${PORTSDIR}/japanese/mozc-additions \
- ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
-
-PLIST_FILES+= lib/scim-1.0/1.4.0/IMEngine/mozc.so \
- lib/scim-1.0/1.4.0/SetupUI/mozc_setup.so \
- ${DATADIR_REL}/icons/scim-mozc-alpha_full.png \
- ${DATADIR_REL}/icons/scim-mozc-alpha_half.png \
- ${DATADIR_REL}/icons/scim-mozc-dictionary.png \
- ${DATADIR_REL}/icons/scim-mozc-direct.png \
- ${DATADIR_REL}/icons/scim-mozc-hiragana.png \
- ${DATADIR_REL}/icons/scim-mozc-katakana_full.png \
- ${DATADIR_REL}/icons/scim-mozc-katakana_half.png \
- ${DATADIR_REL}/icons/scim-mozc-properties.png \
- ${DATADIR_REL}/icons/scim-mozc-tool.png \
- ${DATADIR_REL}/icons/scim-mozc.png
-PLIST_DIRS+= ${DATADIR_REL}/icons ${DATADIR_REL}
-
-do-build-scim_mozc:
- ${BUILD_MOZC_CMD} build -c ${BUILD_MODE} \
- unix/scim/scim.gyp:scim_mozc \
- unix/scim/scim.gyp:scim_mozc_setup
-
-do-install-scim_mozc:
- ${INSTALL_LIB} \
- ${WRKSRC}/out_linux/${BUILD_MODE}/lib.target/libscim_mozc.so \
- ${PREFIX}/lib/scim-1.0/1.4.0/IMEngine/mozc.so
- ${INSTALL_LIB} \
- ${WRKSRC}/out_linux/${BUILD_MODE}/lib.target/libscim_mozc_setup.so \
- ${PREFIX}/lib/scim-1.0/1.4.0/SetupUI/mozc_setup.so
- @${MKDIR} ${DATADIR}/icons
-.for F in ui-alpha_full ui-alpha_half ui-dictionary ui-direct \
- ui-hiragana ui-katakana_full ui-katakana_half ui-properties ui-tool
- @${INSTALL_DATA} \
- ${WRKSRC}/data/images/unix/${F}.png \
- ${DATADIR}/icons/${F:S/^ui-/scim-mozc-/}.png
-.endfor
- @${INSTALL_DATA} \
- ${WRKSRC}/data/images/unix/ime_product_icon_opensource-32.png \
- ${DATADIR}/icons/scim-mozc.png
-.endif
-
# fcitx_mozc
.if ${BUILD_MOZC_LIST:Mfcitx_mozc} == "fcitx_mozc"
PATCH_SITES= http://fcitx.googlecode.com/files/
diff --git a/japanese/mozc-server/files/patch-base_base.gyp b/japanese/mozc-server/files/patch-base_base.gyp
index 7d9909e2ad04..3c58e4d6d940 100644
--- a/japanese/mozc-server/files/patch-base_base.gyp
+++ b/japanese/mozc-server/files/patch-base_base.gyp
@@ -1,6 +1,6 @@
---- base/base.gyp.orig 2012-05-29 15:36:59.656961284 +0900
-+++ base/base.gyp 2012-05-29 16:04:46.528961427 +0900
-@@ -237,20 +237,20 @@
+--- base/base.gyp.orig 2012-09-07 10:21:29.099021913 +0900
++++ base/base.gyp 2012-09-07 10:30:46.575021640 +0900
+@@ -262,20 +262,20 @@
}],
['OS=="linux" and target_platform!="Android"', {
'cflags': [
diff --git a/japanese/mozc-server/files/patch-base_iconv.cc b/japanese/mozc-server/files/patch-base_iconv.cc
index bd61a8cdf2e7..75427d395572 100644
--- a/japanese/mozc-server/files/patch-base_iconv.cc
+++ b/japanese/mozc-server/files/patch-base_iconv.cc
@@ -1,6 +1,6 @@
---- base/iconv.cc.orig 2012-05-29 15:36:59.653960903 +0900
-+++ base/iconv.cc 2012-03-16 10:59:56.300711667 +0900
-@@ -52,7 +52,11 @@
+--- base/iconv.cc.orig 2012-09-07 10:21:29.102021368 +0900
++++ base/iconv.cc 2012-09-07 10:38:00.914022679 +0900
+@@ -53,7 +53,11 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
while (ilen != 0) {
diff --git a/japanese/mozc-server/files/patch-base_mutex.cc b/japanese/mozc-server/files/patch-base_mutex.cc
new file mode 100644
index 000000000000..b7db6d4cf773
--- /dev/null
+++ b/japanese/mozc-server/files/patch-base_mutex.cc
@@ -0,0 +1,11 @@
+--- base/mutex.cc.orig 2012-09-07 10:21:29.105022147 +0900
++++ base/mutex.cc 2012-09-07 11:37:36.899021514 +0900
+@@ -296,7 +296,7 @@
+ // PTHREAD_MUTEX_RECURSIVE_NP but Mac OS X 10.5 does not
+ pthread_mutexattr_t attr;
+ pthread_mutexattr_init(&attr);
+-#if defined(OS_MACOSX)
++#if defined(OS_MACOSX) || defined(__FreeBSD__)
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);
+ #elif defined(OS_LINUX)
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
diff --git a/japanese/mozc-server/files/patch-base_mutex.h b/japanese/mozc-server/files/patch-base_mutex.h
index b75e003eb075..cc608c86499d 100644
--- a/japanese/mozc-server/files/patch-base_mutex.h
+++ b/japanese/mozc-server/files/patch-base_mutex.h
@@ -1,16 +1,14 @@
---- base/mutex.h.orig 2012-05-29 15:36:59.661959825 +0900
-+++ base/mutex.h 2012-05-01 12:46:18.966692632 +0900
-@@ -93,11 +93,11 @@
- // PTHREAD_MUTEX_RECURSIVE_NP and PTHREAD_MUTEX_RECURSIVE seem to be
- // variants. For example, Mac OS X 10.4 had
- // PTHREAD_MUTEX_RECURSIVE_NP but Mac OS X 10.5 does not
--#ifdef OS_MACOSX
-+#if defined(OS_MACOSX) || defined(__FreeBSD__)
- #define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE
- #endif
-
--#ifdef OS_LINUX
-+#if defined(OS_LINUX) && !defined(__FreeBSD__)
- #define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE_NP
+--- base/mutex.h.orig 2012-09-07 11:34:00.553021416 +0900
++++ base/mutex.h 2012-09-07 11:36:19.333021260 +0900
+@@ -56,6 +56,11 @@
+ #define MOZC_RW_MUTEX_PTR_ARRAYSIZE 10
#endif
++#if defined(__FreeBSD__)
++#define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE
++#define PTHREAD_MUTEX_RECURSIVE_VALUE PTHREAD_MUTEX_RECURSIVE_NP
++#endif
++
+ class LOCKABLE Mutex {
+ public:
+ Mutex();
diff --git a/japanese/mozc-server/files/patch-base_process.cc b/japanese/mozc-server/files/patch-base_process.cc
index 5ce31b8ea156..d8dc9029a184 100644
--- a/japanese/mozc-server/files/patch-base_process.cc
+++ b/japanese/mozc-server/files/patch-base_process.cc
@@ -1,5 +1,5 @@
---- base/process.cc.orig 2012-05-29 15:36:59.660961653 +0900
-+++ base/process.cc 2012-01-29 13:49:21.340806019 +0900
+--- base/process.cc.orig 2012-09-07 10:21:29.100021069 +0900
++++ base/process.cc 2012-09-07 10:38:01.060021966 +0900
@@ -120,13 +120,18 @@
return ShellExecuteInSystemDir(L"open", wurl.c_str(), NULL, SW_SHOW);
#endif
diff --git a/japanese/mozc-server/files/patch-build_tools_util.py b/japanese/mozc-server/files/patch-build_tools_util.py
index f84bc2ac81fe..0e77fc5b409b 100644
--- a/japanese/mozc-server/files/patch-build_tools_util.py
+++ b/japanese/mozc-server/files/patch-build_tools_util.py
@@ -1,5 +1,5 @@
---- build_tools/util.py.orig 2012-05-29 15:37:00.289960660 +0900
-+++ build_tools/util.py 2012-05-01 13:03:43.227693771 +0900
+--- build_tools/util.py.orig 2012-09-07 10:21:29.190021513 +0900
++++ build_tools/util.py 2012-09-07 10:30:26.180021509 +0900
@@ -54,7 +54,7 @@
def IsLinux():
diff --git a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
index 94e9aed7a106..682d0e81f52c 100644
--- a/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
+++ b/japanese/mozc-server/files/patch-gui_about_dialog_about_dialog.cc
@@ -1,5 +1,5 @@
---- gui/about_dialog/about_dialog.cc.orig 2012-05-29 15:37:00.325961325 +0900
-+++ gui/about_dialog/about_dialog.cc 2012-01-29 13:49:18.542805785 +0900
+--- gui/about_dialog/about_dialog.cc.orig 2012-09-07 10:21:29.218021887 +0900
++++ gui/about_dialog/about_dialog.cc 2012-01-29 13:49:18.542805000 +0900
@@ -119,7 +119,11 @@
SetLabelText(label_terms);
SetLabelText(label_credits);
diff --git a/japanese/mozc-server/files/patch-gyp_common.gypi b/japanese/mozc-server/files/patch-gyp_common.gypi
index d6e23f2277d0..807aceeff0a5 100644
--- a/japanese/mozc-server/files/patch-gyp_common.gypi
+++ b/japanese/mozc-server/files/patch-gyp_common.gypi
@@ -1,6 +1,6 @@
---- gyp/common.gypi.orig 2012-05-29 15:37:00.311960872 +0900
-+++ gyp/common.gypi 2012-05-29 16:04:45.995960165 +0900
-@@ -46,7 +46,7 @@
+--- gyp/common.gypi.orig 2012-09-07 10:21:29.209021370 +0900
++++ gyp/common.gypi 2012-09-07 10:30:44.919021522 +0900
+@@ -58,7 +58,7 @@
# warning_cflags will be shared with Mac and Linux.
'warning_cflags': [
'-Wall',
@@ -9,7 +9,7 @@
'-Wno-char-subscripts',
'-Wno-sign-compare',
'-Wno-deprecated-declarations',
-@@ -730,6 +730,12 @@
+@@ -752,6 +752,12 @@
# <unordered_map> and <unordered_set>.
'-Wno-deprecated',
],
@@ -20,5 +20,5 @@
+ '-L@@LOCALBASE@@/lib'
+ ],
'conditions': [
- ['chromeos==1', {
+ ['target_platform=="ChromeOS"', {
'defines': [
diff --git a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
index 7bf3d645e00c..0646ae24ebe0 100644
--- a/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
+++ b/japanese/mozc-server/files/patch-handwriting_zinnia_handwriting.cc
@@ -1,6 +1,6 @@
---- handwriting/zinnia_handwriting.cc.orig 2012-05-29 15:37:00.311960872 +0900
-+++ handwriting/zinnia_handwriting.cc 2012-04-02 08:38:43.657727715 +0900
-@@ -49,10 +49,16 @@
+--- handwriting/zinnia_handwriting.cc.orig 2012-09-07 10:21:29.209021370 +0900
++++ handwriting/zinnia_handwriting.cc 2012-09-07 10:38:01.976021756 +0900
+@@ -50,10 +50,16 @@
const char kModelFile[] = "handwriting-light-ja.model";
return Util::JoinPath(MacUtil::GetResourcesDirectory(), kModelFile);
#elif defined(USE_LIBZINNIA)
diff --git a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
index fd383670cdbb..3bb7ecad19e2 100644
--- a/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
+++ b/japanese/mozc-server/files/patch-ipc_ipc_path_manager.cc
@@ -1,5 +1,5 @@
---- ipc/ipc_path_manager.cc.orig 2012-05-29 15:37:10.807960643 +0900
-+++ ipc/ipc_path_manager.cc 2012-05-01 12:46:21.263693646 +0900
+--- ipc/ipc_path_manager.cc.orig 2012-09-07 10:21:32.692021977 +0900
++++ ipc/ipc_path_manager.cc 2012-05-01 12:46:21.263693000 +0900
@@ -284,7 +284,7 @@
*ipc_name = kIPCPrefix;
#endif // OS_WINDOWS
diff --git a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
index dd42471dadea..f4c3876fac03 100644
--- a/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
+++ b/japanese/mozc-server/files/patch-ipc_unix_ipc.cc
@@ -1,5 +1,5 @@
---- ipc/unix_ipc.cc.orig 2012-05-29 15:37:10.806961005 +0900
-+++ ipc/unix_ipc.cc 2012-05-29 16:04:46.619961889 +0900
+--- ipc/unix_ipc.cc.orig 2012-09-07 10:21:32.692021977 +0900
++++ ipc/unix_ipc.cc 2012-09-07 10:38:01.136021395 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
#include <sys/types.h>
@@ -9,7 +9,7 @@
#include <sys/ucred.h>
#endif
#include <sys/wait.h>
-@@ -124,7 +124,7 @@
+@@ -125,7 +125,7 @@
bool IsPeerValid(int socket, pid_t *pid) {
*pid = 0;
@@ -18,7 +18,7 @@
// If the OS is MAC, we should validate the peer by using LOCAL_PEERCRED.
struct xucred peer_cred;
socklen_t peer_cred_len = sizeof(struct xucred);
-@@ -146,7 +146,7 @@
+@@ -147,7 +147,7 @@
*pid = 0;
#endif
@@ -27,7 +27,7 @@
// On ARM Linux, we do nothing and just return true since the platform
// sometimes doesn't support the getsockopt(sock, SOL_SOCKET, SO_PEERCRED)
// system call.
-@@ -309,7 +309,7 @@
+@@ -310,7 +310,7 @@
address.sun_family = AF_UNIX;
::memcpy(address.sun_path, server_address.data(), server_address_length);
address.sun_path[server_address_length] = '\0';
@@ -36,7 +36,7 @@
address.sun_len = SUN_LEN(&address);
const size_t sun_len = sizeof(address);
#else
-@@ -434,21 +434,21 @@
+@@ -435,21 +435,21 @@
SO_REUSEADDR,
reinterpret_cast<char *>(&on),
sizeof(on));
diff --git a/japanese/mozc-server/files/patch-server_mozc_server.cc b/japanese/mozc-server/files/patch-server_mozc_server.cc
index 7fb19681fdf2..c9b414b0b7c2 100644
--- a/japanese/mozc-server/files/patch-server_mozc_server.cc
+++ b/japanese/mozc-server/files/patch-server_mozc_server.cc
@@ -1,5 +1,5 @@
---- server/mozc_server.cc.orig 2012-05-29 15:37:00.266961647 +0900
-+++ server/mozc_server.cc 2012-04-02 08:24:24.633727039 +0900
+--- server/mozc_server.cc.orig 2012-09-07 10:21:29.170020927 +0900
++++ server/mozc_server.cc 2012-09-07 10:30:28.034021395 +0900
@@ -32,6 +32,9 @@
#ifdef OS_WINDOWS
#include <windows.h>
@@ -9,8 +9,8 @@
+#endif
#include "base/base.h"
- #include "base/process.h"
-@@ -49,6 +52,23 @@
+ #include "base/crash_report_util.h"
+@@ -51,6 +54,23 @@
mozc::SessionServer *g_session_server = NULL;
}
@@ -34,7 +34,7 @@
namespace mozc {
namespace {
-@@ -127,6 +147,12 @@
+@@ -132,6 +152,12 @@
return -1;
}
diff --git a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
index 45f3f8c4ec91..de684c8508f3 100644
--- a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
+++ b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_common.py
@@ -1,6 +1,6 @@
---- third_party/gyp/pylib/gyp/common.py.orig 2012-05-29 15:36:59.734962050 +0900
-+++ third_party/gyp/pylib/gyp/common.py 2012-05-01 12:46:18.154691389 +0900
-@@ -353,8 +353,10 @@
+--- third_party/gyp/pylib/gyp/common.py.orig 2012-09-07 10:21:29.147021135 +0900
++++ third_party/gyp/pylib/gyp/common.py 2012-09-07 10:30:44.711021503 +0900
+@@ -362,8 +362,10 @@
'win32': 'win',
'darwin': 'mac',
'sunos5': 'solaris',
@@ -10,6 +10,6 @@
+ 'freebsd8': 'linux',
+ 'freebsd9': 'linux',
+ 'freebsd10': 'linux',
+ 'freebsd9': 'freebsd',
}
flavor = flavors.get(sys.platform, 'linux')
- return params.get('flavor', flavor)
diff --git a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
index fb4b5e79934c..b088a5ef5894 100644
--- a/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
+++ b/japanese/mozc-server/files/patch-third_party_gyp_pylib_gyp_generator_make.py
@@ -1,5 +1,5 @@
---- third_party/gyp/pylib/gyp/generator/make.py.orig 2012-05-29 15:36:59.732960259 +0900
-+++ third_party/gyp/pylib/gyp/generator/make.py 2012-05-01 12:46:18.211693101 +0900
+--- third_party/gyp/pylib/gyp/generator/make.py.orig 2012-09-07 10:21:29.146021648 +0900
++++ third_party/gyp/pylib/gyp/generator/make.py 2012-09-07 10:30:44.778021410 +0900
@@ -1963,6 +1963,9 @@
srcdir_prefix = '$(srcdir)/'
diff --git a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
index b72771cde1ce..6850aa6d5d66 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
+++ b/japanese/mozc-server/files/patch-unix_ibus_gen_mozc_xml.py
@@ -1,14 +1,14 @@
---- unix/ibus/gen_mozc_xml.py.orig 2012-05-29 15:36:59.663960777 +0900
-+++ unix/ibus/gen_mozc_xml.py 2012-01-29 13:49:15.972806246 +0900
-@@ -39,6 +39,7 @@
-
+--- unix/ibus/gen_mozc_xml.py.orig 2012-09-07 10:21:29.111022215 +0900
++++ unix/ibus/gen_mozc_xml.py 2012-09-07 10:30:26.421021738 +0900
+@@ -40,6 +40,7 @@
import optparse
+ import os
import sys
+import os
# Information to generate <component> part of mozc.xml. %s will be replaced with
# a product name, 'Mozc' or 'Google Japanese Input'.
-@@ -64,6 +65,24 @@
+@@ -65,6 +66,24 @@
'rank': '80',
}
diff --git a/japanese/mozc-server/files/patch-unix_ibus_mozc.xml b/japanese/mozc-server/files/patch-unix_ibus_mozc.xml
index 436519119edc..d2a8fb6683ec 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_mozc.xml
+++ b/japanese/mozc-server/files/patch-unix_ibus_mozc.xml
@@ -1,5 +1,5 @@
--- unix/ibus/mozc.xml.orig 1970-01-01 09:00:00.000000000 +0900
-+++ unix/ibus/mozc.xml 2011-12-04 16:04:42.283606379 +0900
++++ unix/ibus/mozc.xml 2011-12-04 16:04:42.283606000 +0900
@@ -0,0 +1,21 @@
+<component>
+ <name>com.google.IBus.Mozc</name>
diff --git a/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
index 5806011e1d05..777eebb2b93b 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
+++ b/japanese/mozc-server/files/patch-unix_ibus_mozc_engine.cc
@@ -1,6 +1,6 @@
---- unix/ibus/mozc_engine.cc.orig 2012-05-29 15:36:59.665961241 +0900
-+++ unix/ibus/mozc_engine.cc 2012-05-01 12:45:44.250693013 +0900
-@@ -893,7 +893,7 @@
+--- unix/ibus/mozc_engine.cc.orig 2012-09-07 10:21:29.111022215 +0900
++++ unix/ibus/mozc_engine.cc 2012-09-07 10:30:26.452021649 +0900
+@@ -756,7 +756,7 @@
// on size_t, not uint32.
string selection_text;
const uint32 selection_start = min(cursor_pos, anchor_pos);
diff --git a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
index 20b24aa7d472..43270812acd6 100644
--- a/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
+++ b/japanese/mozc-server/files/patch-unix_ibus_path_util.cc
@@ -1,5 +1,5 @@
---- unix/ibus/path_util.cc.orig 2012-05-29 15:36:59.663960777 +0900
-+++ unix/ibus/path_util.cc 2012-01-29 13:49:15.994806248 +0900
+--- unix/ibus/path_util.cc.orig 2012-09-07 10:21:29.112021454 +0900
++++ unix/ibus/path_util.cc 2012-01-29 13:49:15.994806000 +0900
@@ -30,14 +30,22 @@
#include "unix/ibus/path_util.h"
diff --git a/japanese/mozc-server/files/patch-unix_scim_scim.gyp b/japanese/mozc-server/files/patch-unix_scim_scim.gyp
deleted file mode 100644
index f41e123aea27..000000000000
--- a/japanese/mozc-server/files/patch-unix_scim_scim.gyp
+++ /dev/null
@@ -1,11 +0,0 @@
---- unix/scim/scim.gyp.orig 2012-05-29 15:36:59.667960727 +0900
-+++ unix/scim/scim.gyp 2012-05-01 12:45:44.903691176 +0900
-@@ -39,7 +39,7 @@
- 'gtk+-2.0',
- ],
- 'scim_defines': [
-- 'SCIM_ICONDIR="<!@(<(pkg_config_command) --variable=icondir scim)"',
-+ 'SCIM_ICONDIR="@@LOCALBASE@@/share/scim-mozc/icons/"',
- ]
- },
- 'targets': [
diff --git a/japanese/scim-mozc/Makefile b/japanese/scim-mozc/Makefile
index b0251263b42a..c2708bbc443a 100644
--- a/japanese/scim-mozc/Makefile
+++ b/japanese/scim-mozc/Makefile
@@ -13,6 +13,8 @@ DATADIR= ${PREFIX}/share/scim-${PORTNAME}
MASTERDIR= ${.CURDIR}/../../japanese/mozc-server
PKGMESSAGE= ${.CURDIR}/pkg-message
+BROKEN= Google droped SCIM support from Mozc. This port will be deleted.
+
BUILD_MOZC_LIST= scim_mozc
post-install: