aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-kqueue/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index e13bea97a726..690c7345b4de 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= dwhite@FreeBSD.org
COMMENT= Python interface to kqueue(2) and kevent(2) system calls
USE_PYTHON= yes
+USE_REINPLACE= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
.include <bsd.port.pre.mk>
@@ -29,6 +30,11 @@ IGNORE="requires new kqueue API"
IGNORE="requires new kqueue API"
.endif
+post-patch:
+.if ${PYTHON_REL} >= 230
+ @${REINPLACE_CMD} -e 's,@DEFS@,,' ${WRKSRC}/Makefile.pre.in
+.endif
+
do-configure:
@(cd ${WRKSRC} && \
make -f Makefile.pre.in boot)