aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/qt4-style-phase/Makefile38
-rw-r--r--x11-themes/qt4-style-phase/distinfo2
-rw-r--r--x11-themes/qt4-style-phase/files/patch-phasestyle.cpp26
-rw-r--r--x11-themes/qt4-style-phase/pkg-descr13
4 files changed, 79 insertions, 0 deletions
diff --git a/x11-themes/qt4-style-phase/Makefile b/x11-themes/qt4-style-phase/Makefile
new file mode 100644
index 000000000000..41068d44860b
--- /dev/null
+++ b/x11-themes/qt4-style-phase/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: qt4-style-phase
+# Date created: 26 Nov 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phase
+PORTVERSION= 0.8
+CATEGORIES= x11-themes
+MASTER_SITES= http://kde-look.org/CONTENT/content-files/ \
+ http://mirror.amdmi3.ru/distfiles/
+PKGNAMEPREFIX= qt4-style-
+DISTNAME= 11402-phase-${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Widget style for Qt 4 and KDE 4
+
+LICENSE= MIT
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui qmake_build moc_build
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/libphasestyle.so
+PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/styles
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${QT_PLUGINDIR_REL}/styles/
+ ${INSTALL_PROGRAM} ${WRKSRC}/libphasestyle.so ${PREFIX}/${QT_PLUGINDIR_REL}/styles/
+
+.include <bsd.port.mk>
diff --git a/x11-themes/qt4-style-phase/distinfo b/x11-themes/qt4-style-phase/distinfo
new file mode 100644
index 000000000000..622b9287c653
--- /dev/null
+++ b/x11-themes/qt4-style-phase/distinfo
@@ -0,0 +1,2 @@
+SHA256 (11402-phase-0.8.tar.bz2) = 8646e11b868b9345ceb6c6cf5445ff53cbb4d1b7ff821ed6069e44580b597d61
+SIZE (11402-phase-0.8.tar.bz2) = 17397
diff --git a/x11-themes/qt4-style-phase/files/patch-phasestyle.cpp b/x11-themes/qt4-style-phase/files/patch-phasestyle.cpp
new file mode 100644
index 000000000000..fa9c88562e28
--- /dev/null
+++ b/x11-themes/qt4-style-phase/files/patch-phasestyle.cpp
@@ -0,0 +1,26 @@
+--- phasestyle.cpp.orig 2007-05-03 08:48:44.000000000 +0400
++++ phasestyle.cpp 2010-11-26 05:07:37.000000000 +0300
+@@ -2367,6 +2367,8 @@
+ return 2;
+
+ case PM_TabBarTabVSpace: {
++ if (!option)
++ return QWindowsStyle::pixelMetric(metric, option, widget);
+ const QStyleOptionTab *tab;
+ tab = qstyleoption_cast<const QStyleOptionTab *>(option);
+ if (tab) {
+@@ -2380,10 +2382,14 @@
+ }
+
+ case PM_ProgressBarChunkWidth: {
++ if (!option)
++ return QWindowsStyle::pixelMetric(metric, option, widget);
+ int breadth = qMax(option->rect.width(), option->rect.height());
+ return qMax(breadth / 10, 10);
+ }
+ case PM_TitleBarHeight:
++ if (!option)
++ return QWindowsStyle::pixelMetric(metric, option, widget);
+ return qMax(option->fontMetrics.lineSpacing(), 20);
+
+ default:
diff --git a/x11-themes/qt4-style-phase/pkg-descr b/x11-themes/qt4-style-phase/pkg-descr
new file mode 100644
index 000000000000..62d4314e0678
--- /dev/null
+++ b/x11-themes/qt4-style-phase/pkg-descr
@@ -0,0 +1,13 @@
+Phase is a widget style for Qt 4 and KDE 4. It is designed to be
+functional but not drab, and aesthetic but not distracting.
+
+Artistic design draws upon the genius of earlier masters. This is
+particularly true for minimalistic designs. Therefore I cannot in
+good conscience claim this look to be truly original. But I have
+done my best. I hope you like it!
+
+Phase is now being maintained in kdeartwork. These are only "snapshot"
+releases. This is a "pure" Qt style, in that it does not require
+KDE.
+
+WWW: http://kde-look.org/content/show.php?content=11402