aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/pyrex/Makefile1
-rw-r--r--devel/pyrex/files/patch-Pyrex::Distutils::build_ext.py11
-rw-r--r--devel/pyrex/pkg-plist3
3 files changed, 15 insertions, 0 deletions
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
index 29085fdfe41f..06fa891f8fde 100644
--- a/devel/pyrex/Makefile
+++ b/devel/pyrex/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pyrex
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= devel lang python
MASTER_SITES= http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
diff --git a/devel/pyrex/files/patch-Pyrex::Distutils::build_ext.py b/devel/pyrex/files/patch-Pyrex::Distutils::build_ext.py
new file mode 100644
index 000000000000..74153ae6f364
--- /dev/null
+++ b/devel/pyrex/files/patch-Pyrex::Distutils::build_ext.py
@@ -0,0 +1,11 @@
+--- Pyrex/Distutils/build_ext.py.orig Sun Dec 5 12:11:14 2004
++++ Pyrex/Distutils/build_ext.py Sun Dec 5 12:11:41 2004
+@@ -32,7 +32,7 @@
+ if self.compiler == 'mingw32':
+ self.swig_cpp = 1
+
+- def swig_sources (self, sources):
++ def swig_sources (self, sources, extension=None): # workaround for 2.4 compat
+ if not self.extensions:
+ return
+
diff --git a/devel/pyrex/pkg-plist b/devel/pyrex/pkg-plist
index 35ec35016006..0edec0c28e7f 100644
--- a/devel/pyrex/pkg-plist
+++ b/devel/pyrex/pkg-plist
@@ -9,6 +9,7 @@ bin/pyrexc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.py
%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyc
@@ -104,6 +105,7 @@ bin/pyrexc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.py
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Regexps.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.py
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.pyc
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Scanners.pyo
%%PYTHON_SITELIBDIR%%/Pyrex/Plex/Timing.py
@@ -151,6 +153,7 @@ bin/pyrexc
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/cheesefinder.c
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/cheesefinder.h
%%PORTDOCS%%%%EXAMPLESDIR%%/callback/run_cheese.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.msc
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.msc.static
%%PORTDOCS%%%%EXAMPLESDIR%%/embed/Makefile.unix