aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/impressive/Makefile15
-rw-r--r--graphics/impressive/pkg-descr2
2 files changed, 7 insertions, 10 deletions
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 21c1e6e9f844..3fcb8582d7cb 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -24,24 +24,21 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
USE_PYTHON= yes
USE_GHOSTSCRIPT_RUN= yes
NO_BUILD= yes
-PLIST_FILES= bin/${PORTNAME}
-
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
PORTDOCS= ${PORTNAME}.html demo.pdf
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/impressive/pkg-descr b/graphics/impressive/pkg-descr
index f3af0e46fed9..63c263068e3b 100644
--- a/graphics/impressive/pkg-descr
+++ b/graphics/impressive/pkg-descr
@@ -3,4 +3,4 @@ Smooth alpha-blended slide transitions are provided for the sake of eye
candy, but in addition to this, Impressive offers some unique tools that
are very useful for presentations.
-WWW: http://impressive.sourceforge.net/
+WWW: http://impressive.sourceforge.net/