aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/m4/Makefile2
-rw-r--r--devel/ninja/Makefile2
-rw-r--r--games/freesweep/Makefile6
-rw-r--r--misc/figlet/Makefile2
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--textproc/py-pygments/Makefile2
6 files changed, 13 insertions, 3 deletions
diff --git a/devel/m4/Makefile b/devel/m4/Makefile
index 7dfee5d5cb10..c1bf3a0b8b47 100644
--- a/devel/m4/Makefile
+++ b/devel/m4/Makefile
@@ -20,7 +20,7 @@ INFO= m4
EXAMPLESDIR= share/examples/gm4
-OPTIONS_DEFINE= LIBSIGSEGV
+OPTIONS_DEFINE= LIBSIGSEGV EXAMPLES
LIBSIGSEGV_DESC= Use alternative page fault handler (GNU libsigsegv)
LIBSIGSEGV_LIB_DEPENDS= libsigsegv.so:${PORTSDIR}/devel/libsigsegv
LIBSIGSEGV_CONFIGURE_ON= --with-libsigsegv-prefix=${LOCALBASE}
diff --git a/devel/ninja/Makefile b/devel/ninja/Makefile
index ec332b486b2f..c51a3e771a12 100644
--- a/devel/ninja/Makefile
+++ b/devel/ninja/Makefile
@@ -22,6 +22,8 @@ USE_PYTHON_BUILD= yes
PLIST_FILES= bin/ninja
PORTDOCS= COPYING HACKING.md README manual.asciidoc
+OPTIONS_DEFINE= DOCS
+
do-build:
@(cd ${WRKSRC} && \
CXX="${CXX}" CFLAGS="${CXXFLAGS}" ${PYTHON_CMD} bootstrap.py --verbose)
diff --git a/games/freesweep/Makefile b/games/freesweep/Makefile
index 1c44bc2b723a..92f519fbe1c1 100644
--- a/games/freesweep/Makefile
+++ b/games/freesweep/Makefile
@@ -12,7 +12,7 @@ COMMENT= Minesweeper-style game for text-mode terminals
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= gmake
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-prefsdir=${DATADIR} \
--with-scoresdir=${DATADIR} \
@@ -21,9 +21,11 @@ ALL_TARGET= ${PORTNAME}
PORTDOCS= CHANGES README
PLIST_FILES= bin/${PORTNAME} man/man6/${PORTNAME}.6.gz \
- %%DATADIR%%/sweeprc %%DATADIR%%/sweeptimes
+ %%DATADIR%%/sweeprc %%DATADIR%%/sweeptimes
PLIST_DIRS= %%DATADIR%%
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
diff --git a/misc/figlet/Makefile b/misc/figlet/Makefile
index 2bb95cef456e..413128559884 100644
--- a/misc/figlet/Makefile
+++ b/misc/figlet/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MAKE_ENV= datadir=${DATADIR} prefix=${PREFIX}
MAKE_ARGS= LD=${CC}
+OPTIONS_DEFINE= DOCS
+
regression-test:
@ cd ${WRKSRC} && ${MAKE} check
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 96e3d332c479..2563e1df6025 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -24,6 +24,8 @@ PLIST_FILES= bin/portlint \
PORTEXAMPLES= portlintgrep
+OPTIONS_DEFINE= EXAMPLES
+
pre-patch:
@${CP} -R ${SRC} ${WRKDIR}
diff --git a/textproc/py-pygments/Makefile b/textproc/py-pygments/Makefile
index 310b8cbd203c..e7c83ba70fb4 100644
--- a/textproc/py-pygments/Makefile
+++ b/textproc/py-pygments/Makefile
@@ -18,4 +18,6 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>