aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/tagutils/Makefile25
-rw-r--r--deskutils/tagutils/distinfo3
-rw-r--r--deskutils/tagutils/pkg-descr8
-rw-r--r--deskutils/tagutils/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c2e97ffd7ea2..a958435f7e80 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -141,6 +141,7 @@
SUBDIR += sunbird
SUBDIR += superkaramba-lwp
SUBDIR += superswitcher
+ SUBDIR += tagutils
SUBDIR += taskjuggler
SUBDIR += taskstep
SUBDIR += teapot
diff --git a/deskutils/tagutils/Makefile b/deskutils/tagutils/Makefile
new file mode 100644
index 000000000000..6d6c5118fa4a
--- /dev/null
+++ b/deskutils/tagutils/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: tagutils
+# Date Created: 24 May 2006
+# Whom: Khairil Yusof <kaeru@inigo-tech.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagutils
+PORTVERSION= 0.3.0
+CATEGORIES= deskutils
+MASTER_SITES= http://releases.chipx86.com/leaftag/tagutils/
+
+MAINTAINER= kaeru@inigo-tech.com
+COMMENT= A command line tool for tagging files
+
+LIB_DEPENDS= leaftag.0:${PORTSDIR}/devel/libleaftag
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20 pkgconfig
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/deskutils/tagutils/distinfo b/deskutils/tagutils/distinfo
new file mode 100644
index 000000000000..4429f11317d1
--- /dev/null
+++ b/deskutils/tagutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (tagutils-0.3.0.tar.gz) = 7982695e411f6ba558080cbefe5a7940
+SHA256 (tagutils-0.3.0.tar.gz) = 0d12dc57d7e49bddf835f233d2a0726e0c0ca5a5dafbcbb62bec7c93a41dae10
+SIZE (tagutils-0.3.0.tar.gz) = 151036
diff --git a/deskutils/tagutils/pkg-descr b/deskutils/tagutils/pkg-descr
new file mode 100644
index 000000000000..5ebb91b691a7
--- /dev/null
+++ b/deskutils/tagutils/pkg-descr
@@ -0,0 +1,8 @@
+Leaftag is a library and set of utilities for tagging files on the desktop.
+
+tagutils is the primary way of tagging files from the command line.
+It can tag, untag, display a list of known tags, manipulate tag properties,
+and show files belonging to a tag.
+
+Project homepage:
+WWW: http://www.chipx86.com/wiki/Leaftag
diff --git a/deskutils/tagutils/pkg-plist b/deskutils/tagutils/pkg-plist
new file mode 100644
index 000000000000..e8d7308830d1
--- /dev/null
+++ b/deskutils/tagutils/pkg-plist
@@ -0,0 +1,6 @@
+bin/tag
+bin/tagls
+bin/tagprop
+bin/tags
+bin/tagutils
+bin/untag