aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/net-snmp4/Makefile13
-rw-r--r--net-mgmt/net-snmp4/files/patch-scapi.c10
-rw-r--r--net-mgmt/net-snmp4/pkg-plist6
3 files changed, 21 insertions, 8 deletions
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index 1346819dd183..d80170a44d44 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.6
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
@@ -94,17 +94,20 @@ CONFIGURE_ARGS+= --with-openssl=/usr
CFLAGS+= -DOPENSSL_DES_LIBDES_COMPATIBILITY
.endif
-SHLIB_VERSION= 4
-PLIST_SUB+= shlib=${SHLIB_VERSION}
-
OPTIONS= IPV6 "Enable IPv6 support" On
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700019
-BROKEN= Does not compile on FreeBSD >= 7.0
+SHLIB_VERSION= 4.0
+PLIST_SUB+= LEGACYLINKS="@comment "
+.else
+SHLIB_VERSION= 4
+PLIST_SUB+= LEGACYLINKS=""
.endif
+PLIST_SUB+= shlib=${SHLIB_VERSION}
+
.if ${OSVERSION} >= 600000
CFLAGS+= -Dfreebsd5
.endif
diff --git a/net-mgmt/net-snmp4/files/patch-scapi.c b/net-mgmt/net-snmp4/files/patch-scapi.c
new file mode 100644
index 000000000000..166fbb42ef8e
--- /dev/null
+++ b/net-mgmt/net-snmp4/files/patch-scapi.c
@@ -0,0 +1,10 @@
+--- ../../work/ucd-snmp-4.2.6/snmplib/scapi.c 2001-10-01 02:52:49.000000000 -0700
++++ snmplib/scapi.c 2008-03-04 16:41:52.000000000 -0800
+@@ -56,6 +56,7 @@
+ #include <openssl/hmac.h>
+ #include <openssl/evp.h>
+ #include <openssl/rand.h>
++#include <openssl/des.h>
+ #endif
+
+ #ifdef QUITFUN
diff --git a/net-mgmt/net-snmp4/pkg-plist b/net-mgmt/net-snmp4/pkg-plist
index e3c7a8ce4b7c..1e09e4bb5481 100644
--- a/net-mgmt/net-snmp4/pkg-plist
+++ b/net-mgmt/net-snmp4/pkg-plist
@@ -63,15 +63,15 @@ include/ucd-snmp/version.h
@dirrm include/ucd-snmp
lib/libsnmp.a
lib/libsnmp.la
-lib/libsnmp.so
+%%LEGACYLINKS%%lib/libsnmp.so
lib/libsnmp.so.%%shlib%%
lib/libucdagent.a
lib/libucdagent.la
-lib/libucdagent.so
+%%LEGACYLINKS%%lib/libucdagent.so
lib/libucdagent.so.%%shlib%%
lib/libucdmibs.a
lib/libucdmibs.la
-lib/libucdmibs.so
+%%LEGACYLINKS%%lib/libucdmibs.so
lib/libucdmibs.so.%%shlib%%
sbin/snmpd
sbin/snmptrapd