aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/templatelite/Makefile6
-rw-r--r--www/templatelite/distinfo6
-rw-r--r--www/templatelite/pkg-plist18
3 files changed, 17 insertions, 13 deletions
diff --git a/www/templatelite/Makefile b/www/templatelite/Makefile
index 14da7d51a98e..0737371a53a6 100644
--- a/www/templatelite/Makefile
+++ b/www/templatelite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= templatelite
-PORTVERSION= 1.90
+PORTVERSION= 2.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +18,7 @@ COMMENT= A smaller, faster alternative to the Smarty template engine
NO_BUILD= yes
USE_PHP= pcre
WANT_PHP_WEB= yes
-NO_WRKSUBDIR= yes
+WRKSRC= ${WRKDIR}/template_lite
SUB_FILES= pkg-message
do-install:
@@ -26,7 +26,7 @@ do-install:
@cd ${WRKSRC}/src && ${FIND} * | ${TAR} cTf - - | ${TAR} xUCf ${DATADIR} -
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/docs && ${FIND} * -type f -exec ${INSTALL_DATA} {} ${DOCSDIR} \;
+ @cd ${WRKSRC}/docs && ${FIND} * | ${TAR} cTf - - | ${TAR} xUCf ${DOCSDIR} -
.endif
post-install:
diff --git a/www/templatelite/distinfo b/www/templatelite/distinfo
index 7a13835234ff..31e921645ba2 100644
--- a/www/templatelite/distinfo
+++ b/www/templatelite/distinfo
@@ -1,3 +1,3 @@
-MD5 (template_lite_1.90.tar.gz) = 0e5d62e9a5958dd4e54d4369b8341d72
-SHA256 (template_lite_1.90.tar.gz) = d2468a578792c47c3906e53198fb57648883ebe8e8ac3adc96dd2684ca9c78bf
-SIZE (template_lite_1.90.tar.gz) = 89816
+MD5 (template_lite_2.10.tar.gz) = 8878a7c8269f6335a9da8d266ae08e33
+SHA256 (template_lite_2.10.tar.gz) = 7d3a3d9a7872c2680143598a8f57d80e36d01cab98abb4b97e5495140fd0873f
+SIZE (template_lite_2.10.tar.gz) = 202242
diff --git a/www/templatelite/pkg-plist b/www/templatelite/pkg-plist
index 38f37fa1c5e6..b45c7213e1e8 100644
--- a/www/templatelite/pkg-plist
+++ b/www/templatelite/pkg-plist
@@ -16,14 +16,22 @@
%%PORTDOCS%%%%DOCSDIR%%/programming.methods.html
%%PORTDOCS%%%%DOCSDIR%%/programming.variables.html
%%PORTDOCS%%%%DOCSDIR%%/what.is.html
+%%PORTDOCS%%%%DOCSDIR%%/images/templatelite.jpg
%%DATADIR%%/class.compiler.php
%%DATADIR%%/class.config.php
%%DATADIR%%/class.template.php
+%%DATADIR%%/internal/compile.compile_config.php
+%%DATADIR%%/internal/compile.compile_custom_block.php
+%%DATADIR%%/internal/compile.compile_custom_function.php
+%%DATADIR%%/internal/compile.compile_if.php
%%DATADIR%%/internal/compile.generate_compiler_debug_output.php
%%DATADIR%%/internal/compile.include.php
+%%DATADIR%%/internal/compile.parse_is_expr.php
%%DATADIR%%/internal/compile.section_start.php
%%DATADIR%%/internal/debug.tpl
+%%DATADIR%%/internal/template.build_dir.php
%%DATADIR%%/internal/template.config_loader.php
+%%DATADIR%%/internal/template.destroy_dir.php
%%DATADIR%%/internal/template.fetch_compile_include.php
%%DATADIR%%/internal/template.generate_debug_output.php
%%DATADIR%%/plugins/block.capture.php
@@ -50,11 +58,10 @@
%%DATADIR%%/plugins/function.math.php
%%DATADIR%%/plugins/function.popup.php
%%DATADIR%%/plugins/function.popup_init.php
-%%DATADIR%%/plugins/modifier.array_reverse.php
+%%DATADIR%%/plugins/function.resize_image.php
%%DATADIR%%/plugins/modifier.bbcode2html.php
%%DATADIR%%/plugins/modifier.capitalize.php
%%DATADIR%%/plugins/modifier.cat.php
-%%DATADIR%%/plugins/modifier.count.php
%%DATADIR%%/plugins/modifier.count_characters.php
%%DATADIR%%/plugins/modifier.count_paragraphs.php
%%DATADIR%%/plugins/modifier.count_sentences.php
@@ -66,24 +73,21 @@
%%DATADIR%%/plugins/modifier.escape.php
%%DATADIR%%/plugins/modifier.indent.php
%%DATADIR%%/plugins/modifier.lower.php
-%%DATADIR%%/plugins/modifier.nl2br.php
-%%DATADIR%%/plugins/modifier.number_format.php
%%DATADIR%%/plugins/modifier.regex_replace.php
%%DATADIR%%/plugins/modifier.replace.php
%%DATADIR%%/plugins/modifier.spacify.php
%%DATADIR%%/plugins/modifier.string_format.php
%%DATADIR%%/plugins/modifier.strip.php
-%%DATADIR%%/plugins/modifier.strip_tags.php
%%DATADIR%%/plugins/modifier.truncate.php
%%DATADIR%%/plugins/modifier.upper.php
-%%DATADIR%%/plugins/modifier.urlencode.php
-%%DATADIR%%/plugins/modifier.wordwrap.php
%%DATADIR%%/plugins/outputfilter.gzip.php
%%DATADIR%%/plugins/outputfilter.trimwhitespace.php
%%DATADIR%%/plugins/postfilter.showtemplatevars.php
+%%DATADIR%%/plugins/prefilter.jstrip.php
%%DATADIR%%/plugins/prefilter.showinfoheader.php
%%DATADIR%%/plugins/shared.escape_chars.php
%%DATADIR%%/plugins/shared.make_timestamp.php
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/internal
@dirrm %%DATADIR%%/plugins