aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mysql2pgsql/Makefile26
-rw-r--r--databases/mysql2pgsql/distinfo1
-rw-r--r--databases/mysql2pgsql/pkg-comment1
-rw-r--r--databases/mysql2pgsql/pkg-descr10
-rw-r--r--databases/mysql2pgsql/pkg-plist1
6 files changed, 40 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 15293e268917..460722c63328 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -33,6 +33,7 @@
SUBDIR += mysql-editor
SUBDIR += mysql-jdbc-mm
SUBDIR += mysql-navigator
+ SUBDIR += mysql2pgsql
SUBDIR += mysql323-client
SUBDIR += mysql323-server
SUBDIR += mysqltcl
diff --git a/databases/mysql2pgsql/Makefile b/databases/mysql2pgsql/Makefile
new file mode 100644
index 000000000000..70454b5981d2
--- /dev/null
+++ b/databases/mysql2pgsql/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mysql2pgsql
+# Date Created: 27 May 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql2pgsql
+PORTVERSION= 20010527
+CATEGORIES= databases
+MASTER_SITES= http://www.rot13.org/~dpavlin/projects/sql/
+DISTNAME= ${PORTNAME}
+EXTRACT_ONLY= # empty
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/mysql2pgsql ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/databases/mysql2pgsql/distinfo b/databases/mysql2pgsql/distinfo
new file mode 100644
index 000000000000..0e55a7efda2a
--- /dev/null
+++ b/databases/mysql2pgsql/distinfo
@@ -0,0 +1 @@
+MD5 (mysql2pgsql) = 5ffeb56aacb9ab60753727b3358e0d75
diff --git a/databases/mysql2pgsql/pkg-comment b/databases/mysql2pgsql/pkg-comment
new file mode 100644
index 000000000000..b5dc7eccb821
--- /dev/null
+++ b/databases/mysql2pgsql/pkg-comment
@@ -0,0 +1 @@
+Convert a MySQL dump to a PostgreSQL dump
diff --git a/databases/mysql2pgsql/pkg-descr b/databases/mysql2pgsql/pkg-descr
new file mode 100644
index 000000000000..b61a565eefbb
--- /dev/null
+++ b/databases/mysql2pgsql/pkg-descr
@@ -0,0 +1,10 @@
+The perl script mysql2pgsql can be used to convert MySQL database
+dumps to a -compatible format (so the data can be imported into
+PostgreSQL). This can be useful if you are switching from MySQL
+to PostgreSQL and you have quite a bit of data in your MySQL
+databases.
+
+WWW: http://www.rot13.org/~dpavlin/projects.html
+
+- Pete
+petef@databits.net
diff --git a/databases/mysql2pgsql/pkg-plist b/databases/mysql2pgsql/pkg-plist
new file mode 100644
index 000000000000..5e511a6feff8
--- /dev/null
+++ b/databases/mysql2pgsql/pkg-plist
@@ -0,0 +1 @@
+bin/mysql2pgsql