aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/ruby-qt2gl/Makefile1
-rw-r--r--textproc/ruby-qt2xml/Makefile1
-rw-r--r--x11-toolkits/ruby-qt2/Makefile1
-rw-r--r--x11-toolkits/ruby-qt2canvas/Makefile1
-rw-r--r--x11-toolkits/ruby-qt2iconview/Makefile1
-rw-r--r--x11-toolkits/ruby-qt2table/Makefile1
6 files changed, 6 insertions, 0 deletions
diff --git a/graphics/ruby-qt2gl/Makefile b/graphics/ruby-qt2gl/Makefile
index 71f8721b5d4e..0586bc4a2339 100644
--- a/graphics/ruby-qt2gl/Makefile
+++ b/graphics/ruby-qt2gl/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR} \
USE_MESA= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
diff --git a/textproc/ruby-qt2xml/Makefile b/textproc/ruby-qt2xml/Makefile
index 1564e0124172..e071aa987bb0 100644
--- a/textproc/ruby-qt2xml/Makefile
+++ b/textproc/ruby-qt2xml/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/ruby-qt2/Makefile b/x11-toolkits/ruby-qt2/Makefile
index 8f7add664b8e..69e1d318580b 100644
--- a/x11-toolkits/ruby-qt2/Makefile
+++ b/x11-toolkits/ruby-qt2/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= knu@FreeBSD.org
USE_QT_VER= 2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/ruby-qt2canvas/Makefile b/x11-toolkits/ruby-qt2canvas/Makefile
index 8919766ea7ba..7813113f84ab 100644
--- a/x11-toolkits/ruby-qt2canvas/Makefile
+++ b/x11-toolkits/ruby-qt2canvas/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/ruby-qt2iconview/Makefile b/x11-toolkits/ruby-qt2iconview/Makefile
index 28d8a54f4cf6..616025c6e2f2 100644
--- a/x11-toolkits/ruby-qt2iconview/Makefile
+++ b/x11-toolkits/ruby-qt2iconview/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes
diff --git a/x11-toolkits/ruby-qt2table/Makefile b/x11-toolkits/ruby-qt2table/Makefile
index 9eb3baa4ab1b..0d40f12b6318 100644
--- a/x11-toolkits/ruby-qt2table/Makefile
+++ b/x11-toolkits/ruby-qt2table/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_WITH_PTHREAD= yes
USE_GMAKE= yes