aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/scanhill/Makefile6
-rw-r--r--sysutils/ucspi-tcp/Makefile42
2 files changed, 24 insertions, 24 deletions
diff --git a/security/scanhill/Makefile b/security/scanhill/Makefile
index 1abbe9977bba..2a38a431e5ee 100644
--- a/security/scanhill/Makefile
+++ b/security/scanhill/Makefile
@@ -23,11 +23,11 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= README.txt INSTALL.txt mysql.sql
-OPTIONS= MYSQL "Enable MySQL support" off
+OPTIONS_DEFINE= MYSQL
.include <bsd.port.pre.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --enable-mysql
USE_MYSQL= yes
.endif
@@ -38,7 +38,7 @@ do-install:
.if !exists(${PREFIX}/etc/scanhill.conf)
${INSTALL_DATA} ${WRKSRC}/scanhill.conf ${PREFIX}/etc/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/sysutils/ucspi-tcp/Makefile b/sysutils/ucspi-tcp/Makefile
index 10abc6978351..902e107e3c11 100644
--- a/sysutils/ucspi-tcp/Makefile
+++ b/sysutils/ucspi-tcp/Makefile
@@ -18,12 +18,12 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= garga@FreeBSD.org
COMMENT= Command-line tools for building TCP client-server applications
-OPTIONS= MAN "Install man(1) pages" on \
- RSS_DIFF "Patch rblsmtpd for qmail users" off \
- SSL "Adds support for SSL (Secure Socket Layer)" off \
- RBL2SMTPD "Don't drop connection, pass envvar to smtpd" off \
- LIMITS "Implement per-connection and other limits" off \
- IPV6 "Add IPv6 support" off
+OPTIONS_DEFINE= MANPAGES RSS_DIFF RBL2SMTPD IPV6 SSL LIMITS
+OPTIONS_DEFAULT=MANPAGES
+
+RSS_DIFF_DESC= Patch rblsmtpd for qmail users
+RBL2SMTPD_DESC= Don't drop connection, pass envvar to smtpd
+LIMITS_DESC= Implement per-connection and other limits
MAKE_JOBS_SAFE= yes
@@ -57,7 +57,7 @@ SCRIPTS= date@ \
.include <bsd.port.pre.mk>
# SSL and LIMITS can't coexist
-.if defined(WITH_SSL) && defined(WITH_LIMITS)
+.if ${PORT_OPTIONS:MSSL} && ${PORT_OPTIONS:MLIMITS}
BROKEN= SSL and LIMITS options cannot coexist, please choose one of them
.endif
@@ -66,7 +66,7 @@ BROKEN= SSL and LIMITS options cannot coexist, please choose one of them
CFLAGS+= -O
.endif
-.if defined(WITH_MAN)
+.if ${PORT_OPTIONS:MMANPAGES}
MASTER_SITES+= http://smarden.org/pape/djb/manpages/:man \
${MASTER_SITE_LOCAL:S/$/:man/}
MASTER_SITE_SUBDIR+= garga/ucspi-tcp/:man
@@ -77,38 +77,38 @@ MAN1= addcr.1 argv0.1 date@.1 delcr.1 finger@.1 fixcrio.1 \
tcpclient.1 tcprules.1 tcprulescheck.1 tcpserver.1 who@.1
.endif
-.if defined(WITH_RSS_DIFF)
+.if ${PORT_OPTIONS:MRSS_DIFF}
PATCH_SITES+= http://www.qmail.org/:rss
PATCHFILES+= ucspi-rss.diff:rss
.endif
-.if defined(WITH_SSL)
+.if ${PORT_OPTIONS:MSSL}
# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
PATCH_SITES+= http://www.nrg4u.com/qmail/:ssl
PATCHFILES+= ucspi-tcp-ssl-20050405.patch.gz:ssl
.endif
-.if defined(WITH_RBL2SMTPD)
+.if ${PORT_OPTIONS:MRBL2SMTPD}
PATCHFILES+= ucspi-tcp_rbl2smtpd.diff:rbl2smtpd
.endif
-.if defined(WITH_LIMITS)
+.if ${PORT_OPTIONS:MLIMITS}
PATCH_SITES+= http://linux.voyager.hr/ucspi-tcp/files/:limits
PATCHFILES+= tcpserver-limits-2006-01-26.diff:limits
.endif
+.if ${PORT_OPTIONS:MIPV6}
# Neither can IPv6 and SSL
-.if defined(WITH_IPV6) && defined(WITH_SSL)
-BROKEN= SSL and IPv6 options cannot coexist, please choose one of them
-.endif
+. if ${PORT_OPTIONS:MSSL}
+BROKEN= SSL and IPv6 options cannot coexist, please choose one of them
+. endif
# Same for IPv6 and LIMITS
-.if defined(WITH_IPV6) && defined(WITH_LIMITS)
-BROKEN= IPv6 and LIMITS options cannot coexist, please choose one of them
-.endif
+. if ${PORT_OPTIONS:MLIMITS}
+BROKEN= IPv6 and LIMITS options cannot coexist, please choose one of them
+. endif
-.if defined(WITH_IPV6)
PATCH_SITES+= http://www.fefe.de/ucspi/:ipv6
PATCHFILES+= ucspi-tcp-0.88-ipv6.diff19.bz2:ipv6
.endif
@@ -117,7 +117,7 @@ PATCH_SITES+= ${MASTER_SITE_LOCAL:S/$/:rss,ssl,rbl2smtpd/}
PATCH_SITE_SUBDIR+= garga/ucspi-tcp/:rss,ssl,rbl2smtpd
post-patch:
-.if defined(WITH_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${REINPLACE_CMD} -e 's|#INCS=-I/usr/local/include|INCS=-I${OPENSSLBASE}/include|g; \
s|-lcrypto|-L${OPENSSLBASE}/lib |g' \
${WRKSRC}/Makefile
@@ -135,7 +135,7 @@ do-install:
.for file_name in ${SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/${file_name} ${PREFIX}/bin
.endfor
-.if defined(WITH_MAN)
+.if ${PORT_OPTIONS:MMANPAGES}
. for file_name in ${MAN1}
${INSTALL_MAN} ${WRKSRC}-man/${file_name} ${MAN1PREFIX}/man/man1/
. endfor