aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/asciio/Makefile3
-rw-r--r--graphics/cuttlefish/Makefile9
-rw-r--r--graphics/imageindex/Makefile9
-rw-r--r--graphics/npretty/Makefile3
-rw-r--r--graphics/p5-Cairo/Makefile3
-rw-r--r--graphics/p5-Captcha-reCAPTCHA-Mailhide/Makefile9
-rw-r--r--graphics/p5-Color-Rgb/Makefile9
-rw-r--r--graphics/p5-GD-Graph-ohlc/Makefile3
-rw-r--r--graphics/p5-Geo-Proj4/Makefile9
-rw-r--r--graphics/p5-Image-ExifTool-devel/Makefile3
-rw-r--r--graphics/p5-Image-ExifTool/Makefile3
-rw-r--r--graphics/p5-Image-Heatmap/Makefile9
-rw-r--r--graphics/p5-Image-Math-Constrain/Makefile3
-rw-r--r--graphics/p5-Image-MetaData-JPEG/Makefile9
-rw-r--r--graphics/p5-Image-Scale/Makefile3
-rw-r--r--graphics/p5-Imager-AverageGray/Makefile9
-rw-r--r--graphics/p5-Imager-Graph/Makefile9
-rw-r--r--graphics/p5-SVG-DOM2/Makefile9
-rw-r--r--graphics/zphoto/Makefile9
19 files changed, 49 insertions, 74 deletions
diff --git a/graphics/asciio/Makefile b/graphics/asciio/Makefile
index 185e9f65e300..4761f6df1cb4 100644
--- a/graphics/asciio/Makefile
+++ b/graphics/asciio/Makefile
@@ -33,7 +33,8 @@ BUILD_DEPENDS= p5-Directory-Scratch>=0:${PORTSDIR}/devel/p5-Directory-Scratch \
p5-Check-ISA>=0:${PORTSDIR}/devel/p5-Check-ISA
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= App::Asciio::setup::import_export::perl.3 \
App::Asciio.3 \
diff --git a/graphics/cuttlefish/Makefile b/graphics/cuttlefish/Makefile
index 41fbd2a34f90..d7147c713d47 100644
--- a/graphics/cuttlefish/Makefile
+++ b/graphics/cuttlefish/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: cuttlefish
-# Date created: 20 March 2006
-# Whom: Matthew Luckie <mjl@luckie.org.nz>
-#
+# Created by: Matthew Luckie <mjl@luckie.org.nz>
# $FreeBSD$
-#
PORTNAME= cuttlefish
PORTVERSION= 1.3
@@ -18,7 +14,8 @@ RUN_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
convert:${PORTSDIR}/graphics/ImageMagick \
gifsicle:${PORTSDIR}/graphics/gifsicle
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
IMAGES= caida_logo.gif caida_logo_gray.gif \
diff --git a/graphics/imageindex/Makefile b/graphics/imageindex/Makefile
index 8753ade92189..f445e14aa5f5 100644
--- a/graphics/imageindex/Makefile
+++ b/graphics/imageindex/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: imageindex
-# Date created: Sat Sep 7 15:53:33 MST 2002
-# Whom: John Reynolds <johnjen@reynoldsnet.org>
-#
+# Created by: John Reynolds <johnjen@reynoldsnet.org>
# $FreeBSD$
-#
PORTNAME= imageindex
PORTVERSION= 1.1
@@ -21,7 +17,8 @@ RUN_DEPENDS= \
${LOCALBASE}/bin/mplayer:${PORTSDIR}/multimedia/mplayer \
p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAKE_ARGS+= PERLPATH=${PERL}
PLIST_FILES= bin/imageindex bin/autocaption
diff --git a/graphics/npretty/Makefile b/graphics/npretty/Makefile
index 54d0a49a234b..e88edccf47d6 100644
--- a/graphics/npretty/Makefile
+++ b/graphics/npretty/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Image-ExifTool>=0:${PORTSDIR}/graphics/p5-Image-ExifTool \
LIB_DEPENDS+= Magick.*:${PORTSDIR}/graphics/ImageMagick
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
post-patch:
@ ${REINPLACE_CMD} -e "s|/etc/|${PREFIX}/etc/|" ${WRKSRC}/npretty.pl
diff --git a/graphics/p5-Cairo/Makefile b/graphics/p5-Cairo/Makefile
index 03105941a240..6047f1d0039c 100644
--- a/graphics/p5-Cairo/Makefile
+++ b/graphics/p5-Cairo/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
TEST_DEPENDS= p5-Font-FreeType>=0:${PORTSDIR}/print/p5-Font-FreeType \
p5-Test-Number-Delta>=1:${PORTSDIR}/devel/p5-Test-Number-Delta
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Cairo.3
diff --git a/graphics/p5-Captcha-reCAPTCHA-Mailhide/Makefile b/graphics/p5-Captcha-reCAPTCHA-Mailhide/Makefile
index edb21f5c1cff..a0d3c75c7936 100644
--- a/graphics/p5-Captcha-reCAPTCHA-Mailhide/Makefile
+++ b/graphics/p5-Captcha-reCAPTCHA-Mailhide/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Captcha-reCAPTCHA-Mailhide
-# Date created: 7 January 2009
-# Whom: gerard
-#
+# Created by: gerard
# $FreeBSD$
-#
PORTNAME= Captcha-reCAPTCHA-Mailhide
PORTVERSION= 0.94
@@ -22,6 +18,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Captcha::reCAPTCHA::Mailhide.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Color-Rgb/Makefile b/graphics/p5-Color-Rgb/Makefile
index dffe3bf4124d..feb242111ee5 100644
--- a/graphics/p5-Color-Rgb/Makefile
+++ b/graphics/p5-Color-Rgb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/p5-Color-Rgb
-# Date created: Sep 17 2004
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= Color-Rgb
PORTVERSION= 1.4
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Simple rgb.txt parsing class
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Color::Rgb.3
diff --git a/graphics/p5-GD-Graph-ohlc/Makefile b/graphics/p5-GD-Graph-ohlc/Makefile
index 626d64ddb5a1..7a3bfae6ed35 100644
--- a/graphics/p5-GD-Graph-ohlc/Makefile
+++ b/graphics/p5-GD-Graph-ohlc/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GD::Graph::candlesticks.3 \
GD::Graph::ohlc.3
diff --git a/graphics/p5-Geo-Proj4/Makefile b/graphics/p5-Geo-Proj4/Makefile
index e7cf5546c3a7..98d9e08b3595 100644
--- a/graphics/p5-Geo-Proj4/Makefile
+++ b/graphics/p5-Geo-Proj4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Proj4
-# Date created: 27 January 2006
-# Whom: Eric Stith
-#
+# Created by: Eric Stith
# $FreeBSD$
-#
PORTNAME= Geo-Proj4
PORTVERSION= 1.04
@@ -19,6 +15,7 @@ LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj
MAN3= Geo::Proj4.3
CONFIGURE_ENV= GEOPROJ_FWTOOLS_DIR=${LOCALBASE}
MAKE_ENV= INC=-I${LOCALBASE}/include
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-ExifTool-devel/Makefile b/graphics/p5-Image-ExifTool-devel/Makefile
index f44e7073b59d..f93dda7f55c2 100644
--- a/graphics/p5-Image-ExifTool-devel/Makefile
+++ b/graphics/p5-Image-ExifTool-devel/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
CONFLICTS= p5-Image-ExifTool-[0-9]*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= exiftool.1
MAN3= File::RandomAccess.3 Image::ExifTool.3 \
diff --git a/graphics/p5-Image-ExifTool/Makefile b/graphics/p5-Image-ExifTool/Makefile
index f41fe0af5b01..2f87213808a0 100644
--- a/graphics/p5-Image-ExifTool/Makefile
+++ b/graphics/p5-Image-ExifTool/Makefile
@@ -25,7 +25,8 @@ LICENSE_COMB= dual
CONFLICTS= p5-Image-ExifTool-devel-[0-9]*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MANTAGS= AES AFCP AIFF APE APP12 ASF BMP BigTIFF BuildTagLookup \
BZZ Canon CanonCustom CanonRaw CanonVRD Casio Charset \
diff --git a/graphics/p5-Image-Heatmap/Makefile b/graphics/p5-Image-Heatmap/Makefile
index 80f0f5def31f..477f0b585fe1 100644
--- a/graphics/p5-Image-Heatmap/Makefile
+++ b/graphics/p5-Image-Heatmap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Image-Heatmap
-# Date created: 2009-07-20
-# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
-#
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Image-Heatmap
PORTVERSION= 0.565
@@ -21,7 +17,8 @@ LICENSE= ART20 GPLv1
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Image::Heatmap.3
diff --git a/graphics/p5-Image-Math-Constrain/Makefile b/graphics/p5-Image-Math-Constrain/Makefile
index 24924b658d51..8adf8414547d 100644
--- a/graphics/p5-Image-Math-Constrain/Makefile
+++ b/graphics/p5-Image-Math-Constrain/Makefile
@@ -13,7 +13,8 @@ COMMENT= Scaling math used in image size constraining (such as thumbnails)
BUILD_DEPENDS= p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Image::Math::Constrain.3
diff --git a/graphics/p5-Image-MetaData-JPEG/Makefile b/graphics/p5-Image-MetaData-JPEG/Makefile
index 34fcd13e2d19..ad050c5711ac 100644
--- a/graphics/p5-Image-MetaData-JPEG/Makefile
+++ b/graphics/p5-Image-MetaData-JPEG/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Image-MetaData-JPEG
-# Date created: 2006-08-05
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= Image-MetaData-JPEG
PORTVERSION= 0.153
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= Perl extension for showing/modifying JPEG (meta)data]
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Image::MetaData::JPEG.3 \
Image::MetaData::JPEG::MakerNotes.3 \
diff --git a/graphics/p5-Image-Scale/Makefile b/graphics/p5-Image-Scale/Makefile
index df3501419e95..4cd1fec96ee1 100644
--- a/graphics/p5-Image-Scale/Makefile
+++ b/graphics/p5-Image-Scale/Makefile
@@ -20,6 +20,7 @@ TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
MAN3= Image::Scale.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Imager-AverageGray/Makefile b/graphics/p5-Imager-AverageGray/Makefile
index daaab988cbdd..8d6a27d30ec7 100644
--- a/graphics/p5-Imager-AverageGray/Makefile
+++ b/graphics/p5-Imager-AverageGray/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/p5-Imager/AverageGray
-# Date created: 2009-10-24
-# Whom: vvelox@vvelox.net
-#
+# Created by: vvelox@vvelox.net
# $FreeBSD$
-#
PORTNAME= Imager-AverageGray
PORTVERSION= 0.0.0
@@ -17,7 +13,8 @@ COMMENT= Finds the average gray for a Imager object or image
RUN_DEPENDS= p5-Imager>=0:${PORTSDIR}/graphics/p5-Imager
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Imager::AverageGray.3
diff --git a/graphics/p5-Imager-Graph/Makefile b/graphics/p5-Imager-Graph/Makefile
index 244be0cfb569..e13498bf2af4 100644
--- a/graphics/p5-Imager-Graph/Makefile
+++ b/graphics/p5-Imager-Graph/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/p5-Imager-Graph
-# Date created: 11 Feb 2005
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
# $FreeBSD$
-#
PORTNAME= Imager-Graph
PORTVERSION= 0.10
@@ -17,7 +13,8 @@ COMMENT= Perl extension for producing Graphs using the Imager library
BUILD_DEPENDS= p5-Imager>=0.75:${PORTSDIR}/graphics/p5-Imager
RUN_DEPENDS= p5-Imager>=0.75:${PORTSDIR}/graphics/p5-Imager
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Imager::Graph.3 \
Imager::Graph::Area.3 \
diff --git a/graphics/p5-SVG-DOM2/Makefile b/graphics/p5-SVG-DOM2/Makefile
index ed2f3c312f7b..dd1a0062a921 100644
--- a/graphics/p5-SVG-DOM2/Makefile
+++ b/graphics/p5-SVG-DOM2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SVG-DOM2
-# Date created: 2006-07-14
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= SVG-DOM2
PORTVERSION= 1.00
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= SVG extension to the popular XML::DOM2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVG::DOM2.3 SVG::DOM2::Attribute::Transform.3 \
SVG::DOM2::Element::Document.3 SVG::DOM2::Element::Shape.3 \
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index b5ae191d02af..ee1cd83c7031 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zphoto
-# Date created: 19 Jul 2002
-# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
-#
+# Created by: UMENO Takashi <umeno@rr.iij4u.or.jp>
# $FreeBSD$
-#
PORTNAME= zphoto
PORTVERSION= 1.2
@@ -38,7 +34,8 @@ CONFIGURE_ARGS+= --disable-wx
CONFIGURE_ARGS+= --disable-zip
.endif
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
post-patch:
@${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure