aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/balsa2/Makefile22
-rw-r--r--mail/balsa2/distinfo4
-rw-r--r--mail/balsa2/files/patch-configure41
-rw-r--r--mail/balsa2/files/patch-ltmain.sh30
4 files changed, 38 insertions, 59 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index a853d455f80e..98d2d9f80620 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= balsa2
-PORTVERSION= 2.0.17
-PORTREVISION= 1
+PORTVERSION= 2.0.18
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
@@ -19,14 +18,14 @@ LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell \
pcre.0:${PORTSDIR}/devel/pcre \
esmtp.6:${PORTSDIR}/mail/libesmtp
-USE_LIBLTDL= yes
+USE_GMAKE= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_OPENSSL= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=13
+USE_ICONV= yes
CONFIGURE_ARGS= --enable-threads \
--enable-gtkhtml \
--disable-more-warnings \
@@ -39,14 +38,19 @@ MAN1= balsa.1
CONFLICTS= balsa-*
-#.if defined(WITH_GPG)
-#LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme
-#CONFIGURE_ARGS+= --enable-gpgme
-#.endif
+OPTIONS= GPG "Enable GnuPG support" off \
+ LDAP "Enable LDAP support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GPG)
+LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}/bin/gpgme-config
+.endif
.if !defined(WITHOUT_LDAP)
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/balsa2/distinfo b/mail/balsa2/distinfo
index 16f2cd8600e3..d3762c14ed4a 100644
--- a/mail/balsa2/distinfo
+++ b/mail/balsa2/distinfo
@@ -1,2 +1,2 @@
-MD5 (balsa-2.0.17.tar.bz2) = 851db68728ed9adea615eb2f249fa1ee
-SIZE (balsa-2.0.17.tar.bz2) = 2970206
+MD5 (balsa-2.0.18.tar.bz2) = 9ceacf1bd44e090470b3285190179978
+SIZE (balsa-2.0.18.tar.bz2) = 3121513
diff --git a/mail/balsa2/files/patch-configure b/mail/balsa2/files/patch-configure
index e9fad9bed9a6..44f3f1b582cc 100644
--- a/mail/balsa2/files/patch-configure
+++ b/mail/balsa2/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Mar 24 23:43:20 2003
-+++ configure Wed Mar 26 17:00:43 2003
-@@ -9004,13 +9004,13 @@
+--- configure.orig Wed Jul 7 18:16:55 2004
++++ configure Wed Jul 7 18:16:55 2004
+@@ -20976,13 +20976,13 @@
else
@@ -16,9 +16,9 @@
-LIBS="-lpspell -lstdc++ -lpspell-modules $LIBS"
+LIBS="-lpspell -lstdc++ $LIBS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
-@@ -9025,11 +9025,11 @@
+ _ACEOF
+@@ -20996,11 +20996,11 @@
#endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@@ -32,41 +32,16 @@
;
return 0;
}
-@@ -9046,19 +9046,19 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_lib_pspell_new_pspell_manager=yes
-+ ac_cv_lib_pspell_new_aspell_speller=yes
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_lib_pspell_new_pspell_manager=no
-+ ac_cv_lib_pspell_new_aspell_speller=no
- fi
- rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
- LIBS=$ac_check_lib_save_LIBS
- fi
--echo "$as_me:$LINENO: result: $ac_cv_lib_pspell_new_pspell_manager" >&5
--echo "${ECHO_T}$ac_cv_lib_pspell_new_pspell_manager" >&6
--if test $ac_cv_lib_pspell_new_pspell_manager = yes; then
-+ echo "$as_me:$LINENO: result: $ac_cv_lib_pspell_new_aspell_speller" >&5
-+ echo "${ECHO_T}$ac_cv_lib_pspell_new_aspell_speller" >&6
-+ if test $ac_cv_lib_pspell_new_aspell_speller = yes; then
- cat >>confdefs.h <<_ACEOF
- #define HAVE_LIBPSPELL 1
- _ACEOF
-@@ -10491,7 +10491,7 @@
+@@ -23045,7 +23045,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lldap -llber -lresolv $LIBS"
+LIBS="-lldap -llber $LIBS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
-@@ -10545,7 +10545,7 @@
+ _ACEOF
+@@ -23109,7 +23109,7 @@
#define ENABLE_LDAP 1
_ACEOF
diff --git a/mail/balsa2/files/patch-ltmain.sh b/mail/balsa2/files/patch-ltmain.sh
index 8afc42e3986c..5d2266f8c055 100644
--- a/mail/balsa2/files/patch-ltmain.sh
+++ b/mail/balsa2/files/patch-ltmain.sh
@@ -1,15 +1,15 @@
---- ltmain.sh.orig Fri Apr 25 15:18:44 2003
-+++ ltmain.sh Sun May 11 02:27:13 2003
-@@ -1061,7 +1061,7 @@
+--- ltmain.sh.orig Sun Jul 4 13:15:31 2004
++++ ltmain.sh Wed Jul 7 18:18:07 2004
+@@ -1359,7 +1359,7 @@
esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1071,8 +1071,16 @@
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1374,8 +1374,16 @@
continue
;;
@@ -26,17 +26,17 @@
continue
;;
-@@ -2471,6 +2479,9 @@
- *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
+@@ -3075,6 +3083,9 @@
+ # problems, so we reset it completely
+ verstring=
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4280,10 +4291,12 @@
+ verstring="0.0"
+ ;;
+@@ -5550,10 +5561,12 @@
fi
# Install the pseudo-library for information purposes.