aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Algorithm-KMeans/Makefile21
-rw-r--r--math/p5-Algorithm-KMeans/distinfo3
-rw-r--r--math/p5-Algorithm-KMeans/pkg-descr10
-rw-r--r--math/p5-Algorithm-KMeans/pkg-plist6
5 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7360ce9a168f..0bd6eb9b047d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -292,6 +292,7 @@
SUBDIR += p5-AI-Perceptron
SUBDIR += p5-Algorithm-Combinatorics
SUBDIR += p5-Algorithm-CurveFit
+ SUBDIR += p5-Algorithm-KMeans
SUBDIR += p5-Algorithm-Munkres
SUBDIR += p5-Bit-ShiftReg
SUBDIR += p5-Bit-Vector
diff --git a/math/p5-Algorithm-KMeans/Makefile b/math/p5-Algorithm-KMeans/Makefile
new file mode 100644
index 000000000000..c695c35c3f07
--- /dev/null
+++ b/math/p5-Algorithm-KMeans/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Algorithm-KMeans
+# Date created: 30 June, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-KMeans
+PORTVERSION= 1.1.1
+CATEGORIES= math perl5
+MASTER_SITES= CPAN/../../authors/id/A/AV/AVIKAK/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Clustering multi-dimensional data with a pure-Perl implementation
+
+MAN3= Algorithm::KMeans.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/p5-Algorithm-KMeans/distinfo b/math/p5-Algorithm-KMeans/distinfo
new file mode 100644
index 000000000000..048329cd980d
--- /dev/null
+++ b/math/p5-Algorithm-KMeans/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-KMeans-1.1.1.tar.gz) = f56cf7cee1f78614bc0947854af5e106
+SHA256 (Algorithm-KMeans-1.1.1.tar.gz) = 90189133f9760f0f6cbe311830b0db930a5d8259e87de48c86631caf61f79ec1
+SIZE (Algorithm-KMeans-1.1.1.tar.gz) = 26494
diff --git a/math/p5-Algorithm-KMeans/pkg-descr b/math/p5-Algorithm-KMeans/pkg-descr
new file mode 100644
index 000000000000..45555f166e73
--- /dev/null
+++ b/math/p5-Algorithm-KMeans/pkg-descr
@@ -0,0 +1,10 @@
+Algorithm::KMeans is a perl5 module for the clustering of numerical data
+in multidimensional spaces. Since the module is entirely in Perl (in the
+sense that it is not a Perl wrapper around a C library that actually does
+the clustering), the code in the module can easily be modified to experiment
+with several aspects of automatic clustering. For example, one can change
+the criterion used to measure the "distance" between two data points, the
+stopping condition for accepting final clusters, the criterion used for
+measuring the quality of the clustering achieved, etc.
+
+WWW: http://search.cpan.org/dist/Algorithm-KMeans
diff --git a/math/p5-Algorithm-KMeans/pkg-plist b/math/p5-Algorithm-KMeans/pkg-plist
new file mode 100644
index 000000000000..0dc1a1d4d40e
--- /dev/null
+++ b/math/p5-Algorithm-KMeans/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Algorithm/KMeans.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/KMeans/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/KMeans
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrm %%SITE_PERL%%/Algorithm/KMeans
+@dirrmtry %%SITE_PERL%%/Algorithm