aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/observium/Makefile10
-rw-r--r--net-mgmt/observium/distinfo6
-rw-r--r--net-mgmt/observium/files/observium.conf.sample.in10
3 files changed, 17 insertions, 9 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 5970a67cff86..b1f95f9e5eb2 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -3,8 +3,8 @@
# Observium version can be found by looking at ${WRKSRC}/includes/definitions/version.inc.php
PORTNAME= observium
-PORTVERSION= 0.17.9.8859
-PORTREVISION= 1
+PORTVERSION= 0.18.9.1
+PORTREVISION= 0
CATEGORIES= net-mgmt
MASTER_SITES= http://www.observium.org/
DISTNAME= ${PORTNAME}-community-latest
@@ -22,7 +22,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USES= php:cli python${PY_MYSQL} shebangfix
SHEBANG_FILES= \
- mibs/process.pl \
poller-wrapper.py \
poller.php \
scripts/
@@ -65,11 +64,12 @@ WMIC_RUN_DEPENDS= wmic:net-mgmt/wmi-client
SUB_FILES+= pkg-message observium.conf.sample
SUB_LIST+= PHP="${PHPBASE}/bin/php" PYTHON=${PHPBASE}/bin/python
-ROOT_FILES= add_device.php adduser.php alerter.php alerts.php \
+ROOT_FILES= add_device.php adduser.php alerter.php \
check-errors.php check-services.php config_to_json.php \
config.php.default delete_device.php discovery.php housekeeping.php \
irc.php poller-wrapper.py poller.php rename_device.php \
- snmptrap.php snmptrap.php syslog.php test_alert.php
+ snmp.conf.example snmpd.conf.example \
+ snmptrap.php snmptrap.php syslog.php test_alert.php test_code.php VERSION
ROOT_DIRS= html includes libs logs mibs rrd scripts templates tests update
PORTDOCS= INSTALL README VERSION
diff --git a/net-mgmt/observium/distinfo b/net-mgmt/observium/distinfo
index fcb6863cec0c..a07d83f831a5 100644
--- a/net-mgmt/observium/distinfo
+++ b/net-mgmt/observium/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513523116
-SHA256 (observium-0.17.9.8859/observium-community-latest.tar.gz) = dcf2f72b1a1389d523f44bba31bccf72598bb5014c2850f8f3f70a30f0cc05ac
-SIZE (observium-0.17.9.8859/observium-community-latest.tar.gz) = 71030546
+TIMESTAMP = 1556045788
+SHA256 (observium-0.18.9.1/observium-community-latest.tar.gz) = b182abb41483389b2e18e8d336560733680f38d66b1dc2f291cbf113a7e1f4d7
+SIZE (observium-0.18.9.1/observium-community-latest.tar.gz) = 76524711
diff --git a/net-mgmt/observium/files/observium.conf.sample.in b/net-mgmt/observium/files/observium.conf.sample.in
index d72c5ea4d213..dbcb702254cc 100644
--- a/net-mgmt/observium/files/observium.conf.sample.in
+++ b/net-mgmt/observium/files/observium.conf.sample.in
@@ -5,9 +5,17 @@
#
# Replace the '*:8080' by the actual virtual host(name)
# you will be using; and consider enabling SSL. An example
-# can be fund at e /usr/local/etc/apache24/extra/httpd-ssl.conf
+# can be found at /usr/local/etc/apache24/extra/httpd-ssl.conf
#
+<IfModule !rewrite_module>
+LoadModule rewrite_module libexec/apache24/mod_rewrite.so
+</IfModule>
+
+<IfModule !php7_module>
+LoadModule php7_module libexec/apache24/libphp7.so
+</IfModule>
+
Listen *:8080
<VirtualHost *:8080>
Documentroot "%%WWWDIR%%/html"