aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/rat/Makefile4
-rw-r--r--devel/rhtvision/Makefile8
-rw-r--r--devel/root/Makefile4
-rw-r--r--mbone/rat/Makefile4
4 files changed, 19 insertions, 1 deletions
diff --git a/audio/rat/Makefile b/audio/rat/Makefile
index 8481e1c1916d..f26916805d42 100644
--- a/audio/rat/Makefile
+++ b/audio/rat/Makefile
@@ -31,6 +31,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} >= 400014
ENABLE_IPv6= --enable-ipv6
.endif
diff --git a/devel/rhtvision/Makefile b/devel/rhtvision/Makefile
index bcef94cbb3e5..3e879f5ad433 100644
--- a/devel/rhtvision/Makefile
+++ b/devel/rhtvision/Makefile
@@ -31,6 +31,12 @@ CFLAGS+= -I${X11BASE}/include
.else
PLIST_SUB+= X11_ONLY="@comment "
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-configure:
${ECHO} "HAVE_X11 => no" > ${WRKSRC}/configure.cache
.endif
@@ -46,4 +52,4 @@ post-patch:
${WRKSRC}/${f}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/root/Makefile b/devel/root/Makefile
index a87386ec4faf..548fd98f552b 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -139,6 +139,10 @@ CONFIGURE_ARGS+= --disable-srp
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
# The thread sub-system was not working for ROOT versions 3.x on FreeBSD 4.x
# systems. Meanwhile maybe it's working with some patches - but I have no
# FreeBSD 4.x system still running for testing ;-)
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 8481e1c1916d..f26916805d42 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -31,6 +31,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} >= 400014
ENABLE_IPv6= --enable-ipv6
.endif