aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/xlslib/Makefile30
-rw-r--r--devel/xlslib/distinfo3
-rw-r--r--devel/xlslib/files/patch-src_xlslib_label.cpp29
-rw-r--r--devel/xlslib/pkg-descr18
-rw-r--r--devel/xlslib/pkg-plist46
6 files changed, 127 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dcfc95159ed1..aa85e06a1eaf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1640,6 +1640,7 @@
SUBDIR += wininfo
SUBDIR += wxGlade
SUBDIR += xfc
+ SUBDIR += xlslib
SUBDIR += xmake
SUBDIR += xparam
SUBDIR += xtl
diff --git a/devel/xlslib/Makefile b/devel/xlslib/Makefile
new file mode 100644
index 000000000000..2f744b1f9b56
--- /dev/null
+++ b/devel/xlslib/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xlslib
+# Date created: 13 December 2005
+# Whom: Sergey Prikhodko<sergey@network-asp.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlslib
+PORTVERSION= 0.2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sergey@network-asp.biz
+COMMENT= A C++ library for generation of Excel(TM) files
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_GCC= 3.4+
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS.*src\).*|\1|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^\(CXXFLAGS\).*|\1 = @CXXFLAGS@|' \
+ ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|\(.*class\)\ xlslib_core::\(range\)|\1 \2|' \
+ ${WRKSRC}/src/xlslib/common.h
+
+.include <bsd.port.mk>
diff --git a/devel/xlslib/distinfo b/devel/xlslib/distinfo
new file mode 100644
index 000000000000..4f026e684eff
--- /dev/null
+++ b/devel/xlslib/distinfo
@@ -0,0 +1,3 @@
+MD5 (xlslib-0.2.1.tar.gz) = b18dc9082d7024285f7a510aefcb237a
+SHA256 (xlslib-0.2.1.tar.gz) = 9c4f02404a7812ad6a42035d83332295a7cf4af08779d99b3ff2d001832f8453
+SIZE (xlslib-0.2.1.tar.gz) = 270246
diff --git a/devel/xlslib/files/patch-src_xlslib_label.cpp b/devel/xlslib/files/patch-src_xlslib_label.cpp
new file mode 100644
index 000000000000..7f2782fcf021
--- /dev/null
+++ b/devel/xlslib/files/patch-src_xlslib_label.cpp
@@ -0,0 +1,29 @@
+--- src/xlslib/label.cpp.orig Mon Dec 12 16:45:55 2005
++++ src/xlslib/label.cpp Mon Dec 12 16:48:27 2005
+@@ -95,7 +95,7 @@
+ label_t class implementation
+ ******************************
+ */
+-label_t::label_t(unsigned16_t rowval, unsigned16_t colval,
++xlslib_core::label_t::label_t(unsigned16_t rowval, unsigned16_t colval,
+ string& labelstrval, xf_t* pxfval)
+ {
+ row = rowval;
+@@ -121,7 +121,7 @@
+ ******************************
+ */
+
+-unsigned16_t label_t::GetSize()
++unsigned16_t xlslib_core::label_t::GetSize()
+ {
+ unsigned16_t size = 0;
+
+@@ -136,7 +136,7 @@
+ ******************************
+ */
+
+-CUnit* label_t::GetData()
++CUnit* xlslib_core::label_t::GetData()
+ {
+ CUnit* datalabel =
+ (CUnit*)( new CLabel(row,col,strlabel,pxf));
diff --git a/devel/xlslib/pkg-descr b/devel/xlslib/pkg-descr
new file mode 100644
index 000000000000..038be55998ab
--- /dev/null
+++ b/devel/xlslib/pkg-descr
@@ -0,0 +1,18 @@
+xlsLib is a multiplatform, C++ developed, library for dynamically
+generating Excel(TM) files (*.xls). It allows the generation of Excel(TM)
+compatible files without the need of any other external software.
+
+ * Easy to use, fully object oriented, API.
+ * Excel 95 (TM) format spreadsheets.
+ * Multiple worksheets.
+ * All standard font's styles and colors.
+ * All standard cell's styles, colors and properties.
+ * All standard cell's border-styles and colors.
+ * Three basic type of cells:
+ o Blank.
+ o Label. The text in labels can be formated in all standard styles.
+ o Number. All standard number-formats are supported.
+ * Merged cells.
+ * Handling of cells using ranges.
+
+WWW: http://xlslib.sourceforge.net/
diff --git a/devel/xlslib/pkg-plist b/devel/xlslib/pkg-plist
new file mode 100644
index 000000000000..0772dd7bfd0a
--- /dev/null
+++ b/devel/xlslib/pkg-plist
@@ -0,0 +1,46 @@
+include/xlslib/biffsection.h
+include/xlslib/binfile.h
+include/xlslib/blank.h
+include/xlslib/cell.h
+include/xlslib/colinfo.h
+include/xlslib/colors.h
+include/xlslib/common.h
+include/xlslib/config.h
+include/xlslib/continue.h
+include/xlslib/crc.h
+include/xlslib/data3.h
+include/xlslib/data4.h
+include/xlslib/datast.h
+include/xlslib/docsumminfo.h
+include/xlslib/extformat.h
+include/xlslib/font.h
+include/xlslib/format.h
+include/xlslib/formtags.h
+include/xlslib/globalrec.h
+include/xlslib/index.h
+include/xlslib/label.h
+include/xlslib/merged.h
+include/xlslib/number.h
+include/xlslib/oledoc.h
+include/xlslib/olefs.h
+include/xlslib/oleprop.h
+include/xlslib/overnew.h
+include/xlslib/range.h
+include/xlslib/recdef.h
+include/xlslib/record.h
+include/xlslib/rectypes.h
+include/xlslib/row.h
+include/xlslib/sheetrec.h
+include/xlslib/stringtok.h
+include/xlslib/summinfo.h
+include/xlslib/systype.h
+include/xlslib/timespan.h
+include/xlslib/tostr.h
+include/xlslib/unit.h
+include/xlslib/workbook.h
+include/xlslib/xlconfig.h
+lib/libxls.a
+lib/libxls.la
+lib/libxls.so
+lib/libxls.so.0
+@dirrm include/xlslib