aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mp3ck/Makefile18
-rw-r--r--audio/mp3ck/distinfo1
-rw-r--r--audio/mp3ck/pkg-comment1
-rw-r--r--audio/mp3ck/pkg-descr10
-rw-r--r--audio/mp3ck/pkg-plist1
6 files changed, 32 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 68b69e69a942..d946759865ce 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -132,6 +132,7 @@
SUBDIR += mp3butler
SUBDIR += mp3check
SUBDIR += mp3chew
+ SUBDIR += mp3ck
SUBDIR += mp3encode
SUBDIR += mp3info
SUBDIR += mp3mover
diff --git a/audio/mp3ck/Makefile b/audio/mp3ck/Makefile
new file mode 100644
index 000000000000..9e4ac1959e0a
--- /dev/null
+++ b/audio/mp3ck/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: mp3ck
+# Date created: Feb 3 2002
+# Whom: Yar Tikhiy <yar@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3ck
+PORTVERSION= 0.02
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= yar@FreeBSD.org
+
+MAN1= mp3ck.1
+
+.include <bsd.port.mk>
diff --git a/audio/mp3ck/distinfo b/audio/mp3ck/distinfo
new file mode 100644
index 000000000000..6a061b5f2ad5
--- /dev/null
+++ b/audio/mp3ck/distinfo
@@ -0,0 +1 @@
+MD5 (mp3ck-0.02.tar.gz) = a9fd0c6d0a4872b865df8b7566ddc380
diff --git a/audio/mp3ck/pkg-comment b/audio/mp3ck/pkg-comment
new file mode 100644
index 000000000000..3545a3325afa
--- /dev/null
+++ b/audio/mp3ck/pkg-comment
@@ -0,0 +1 @@
+A consistency check utility for MPEG Layer 2 or 3 files or streams
diff --git a/audio/mp3ck/pkg-descr b/audio/mp3ck/pkg-descr
new file mode 100644
index 000000000000..6d58e0c40e77
--- /dev/null
+++ b/audio/mp3ck/pkg-descr
@@ -0,0 +1,10 @@
+Mp3ck is a portable utility for checking the consistency of MPEG
+Layer 2 or 3 streams or files. The primary accent of the check is
+on the seamless flow of frames and tags since most MPEG defects
+introduced by aborted network transfers manifest theirselves in its
+breakage.
+
+WWW: http://mp3ck.sourceforge.net/
+
+- Yar Tikhiy
+yar@FreeBSD.org
diff --git a/audio/mp3ck/pkg-plist b/audio/mp3ck/pkg-plist
new file mode 100644
index 000000000000..cfd0d9a15035
--- /dev/null
+++ b/audio/mp3ck/pkg-plist
@@ -0,0 +1 @@
+bin/mp3ck