aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/zms/Makefile48
-rw-r--r--mail/zms/distinfo3
-rw-r--r--mail/zms/pkg-descr11
-rw-r--r--mail/zms/pkg-message3
5 files changed, 66 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 47c10a4b661e..9377550242cb 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -702,6 +702,7 @@
SUBDIR += xpi-displayquota
SUBDIR += zabit
SUBDIR += zmailer
+ SUBDIR += zms
# SUBDIR += mailman-devel
.include <bsd.port.subdir.mk>
diff --git a/mail/zms/Makefile b/mail/zms/Makefile
new file mode 100644
index 000000000000..78308e3b238c
--- /dev/null
+++ b/mail/zms/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: zms
+# Date created: 12 February 2007
+# Whom: Zane C. Bowers
+#
+# $FreeBSD$
+#
+
+PORTNAME= zms
+PORTVERSION= 1.7.0
+CATEGORIES= mail
+MASTER_SITES= http://cpan.org/authors/id/V/VV/VVELOX/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.pl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A specialized mail gateway system for using user specified SMTP server
+
+RUN_DEPENDS= ${SITE_PERL}/Net/LDAP/Entry.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${SITE_PERL}/Net/Server/Mail/ESMTP.pm:${PORTSDIR}/mail/p5-Net-Server-Mail \
+ ${SITE_PERL}/Authen/Simple/PAM.pm:${PORTSDIR}/security/p5-Authen-Simple-PAM \
+ ${SITE_PERL}/Config/Tiny.pm:${PORTSDIR}/devel/p5-Config-Tiny \
+ ${SITE_PERL}/Net/SMTP/TLS.pm:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
+ ${SITE_PERL}/Net/SMTP_auth.pm:${PORTSDIR}/mail/p5-Net-SMTP_auth \
+ ${SITE_PERL}/Net/RBLClient.pm:${PORTSDIR}/dns/p5-Net-RBLClient \
+ ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ ${SITE_PERL}/IPC/Shareable.pm:${PORTSDIR}/devel/p5-IPC-Shareable
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+
+MAN1= ${PORTNAME}.1
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-extract:
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-build:
+ @${EXEC} pod2man --section=1 --release=${PORTVERSION} --name=${PORTNAME} --center=${PORTNAME}" user guide" ${WRKSRC}/${DISTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/zms
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/zms/distinfo b/mail/zms/distinfo
new file mode 100644
index 000000000000..9e6e8d3dc11a
--- /dev/null
+++ b/mail/zms/distinfo
@@ -0,0 +1,3 @@
+MD5 (zms-1.7.0.pl) = d9b5bde27d4d50f2b8398ea9fc3426e1
+SHA256 (zms-1.7.0.pl) = be53f4df4ea50fdb6b396fefe7a36d8a4592bdfe25eae4a54dfd5c5c15bcd275
+SIZE (zms-1.7.0.pl) = 57505
diff --git a/mail/zms/pkg-descr b/mail/zms/pkg-descr
new file mode 100644
index 000000000000..1237d9caac09
--- /dev/null
+++ b/mail/zms/pkg-descr
@@ -0,0 +1,11 @@
+A specialized mail gateway system for using user a specified SMTP
+server and proxying.
+
+Three proxy modes are supported.
+- Unathenticated proxying mode in which case it just sits between
+ the client and specified server.
+- Athenticated proxying mode, which is the same as above, but only
+ for authenticated connection.
+- Smart proxying mode in which it accepts will send the mail through
+ a server specified in the user's config by matching the the sender
+ using regexps to determine what server should be used.
diff --git a/mail/zms/pkg-message b/mail/zms/pkg-message
new file mode 100644
index 000000000000..45f00b3c1cf0
--- /dev/null
+++ b/mail/zms/pkg-message
@@ -0,0 +1,3 @@
+*****************************************************************
+The LDAP schema may be found at http://vvelox.net/src/ldap/zms.schema
+*****************************************************************