aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/wpa_supplicant/Makefile4
-rw-r--r--security/wpa_supplicant/files/patch-crypto.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/security/wpa_supplicant/Makefile b/security/wpa_supplicant/Makefile
index 2bb1217a4032..82f35955cb9a 100644
--- a/security/wpa_supplicant/Makefile
+++ b/security/wpa_supplicant/Makefile
@@ -65,8 +65,4 @@ post-install:
IGNORE=is not supported on FreeBSD < 6.0
.endif
-.if ${OSVERSION} >= 700019
-BROKEN= does not compile on FreeBSD >= 7.0
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/wpa_supplicant/files/patch-crypto.c b/security/wpa_supplicant/files/patch-crypto.c
new file mode 100644
index 000000000000..c27bc4c09f64
--- /dev/null
+++ b/security/wpa_supplicant/files/patch-crypto.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- crypto.c.orig
++++ crypto.c
+@@ -12,6 +12,7 @@
+ * See README and COPYING for more details.
+ */
+
++#include <sys/types.h>
+ #include <openssl/md4.h>
+ #include <openssl/des.h>
+