aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/endian/Makefile27
-rw-r--r--sysutils/endian/distinfo3
-rw-r--r--sysutils/endian/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2a1ee00f2f42..23bb8a329487 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -156,6 +156,7 @@
SUBDIR += eiciel
SUBDIR += eject
SUBDIR += empower
+ SUBDIR += endian
SUBDIR += enteruser
SUBDIR += env4801
SUBDIR += epylog
diff --git a/sysutils/endian/Makefile b/sysutils/endian/Makefile
new file mode 100644
index 000000000000..0100e548f0b1
--- /dev/null
+++ b/sysutils/endian/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: endian
+# Date created: 3 Jan 2006
+# Whom: bacon@smithers.neuro.mcw.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= endian
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/ \
+ http://bacon.is-a-geek.org/~bacon/Ports/distfiles/
+
+MAINTAINER= bacon@smithers.neuro.mcw.edu
+COMMENT= Report endianness of a system
+
+MAN1= endian.1
+
+PLIST_FILES= bin/endian
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/endian/distinfo b/sysutils/endian/distinfo
new file mode 100644
index 000000000000..83008a477942
--- /dev/null
+++ b/sysutils/endian/distinfo
@@ -0,0 +1,3 @@
+MD5 (endian-1.0.tar.gz) = 83407de0ce534c2be774caca4ae9230c
+SHA256 (endian-1.0.tar.gz) = ec0e3b8f7bb1920a0d4f24223d613acecdc4c1cb9d69e930b794d19b54135e41
+SIZE (endian-1.0.tar.gz) = 2942
diff --git a/sysutils/endian/pkg-descr b/sysutils/endian/pkg-descr
new file mode 100644
index 000000000000..181d9d8bc621
--- /dev/null
+++ b/sysutils/endian/pkg-descr
@@ -0,0 +1,5 @@
+Endian reports the endianness to the standard output as "little",
+"big", or "mixed". As there is no standard terminology for the various
+possible mixed modes, and very few such machines even exist, endian
+does not distinguish between various mixed modes. Report endianness
+of a system.