aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/pstoepsi/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/pstoepsi/Makefile b/graphics/pstoepsi/Makefile
index 889d81c015c8..f09367980c3c 100644
--- a/graphics/pstoepsi/Makefile
+++ b/graphics/pstoepsi/Makefile
@@ -16,13 +16,27 @@ EXTRACT_ONLY= #empty
MAINTAINER= mita@FreeBSD.org
COMMENT= Wiliam Chia-Wei Cheng's yet another PS to EPSI converter
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
NO_WRKSUBDIR= yes
.SILENT:
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
${CP} ${DISTDIR}/${DIST_SUBDIR}/pstoepsi ${WRKDIR}/pstoepsi.prefix
${CP} ${DISTDIR}/${DIST_SUBDIR}/README.this-site ${WRKDIR}