aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/eclair/Makefile33
-rw-r--r--multimedia/eclair/distinfo3
-rw-r--r--multimedia/eclair/pkg-descr4
-rw-r--r--multimedia/eclair/pkg-plist30
5 files changed, 71 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 339bf91c9e12..74fa3ec8590a 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -26,6 +26,7 @@
SUBDIR += dvdstyler
SUBDIR += dvdwizard
SUBDIR += dvts
+ SUBDIR += eclair
SUBDIR += emotion
SUBDIR += emovix
SUBDIR += enjoympeg
diff --git a/multimedia/eclair/Makefile b/multimedia/eclair/Makefile
new file mode 100644
index 000000000000..00faf3e32891
--- /dev/null
+++ b/multimedia/eclair/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: eclair
+# Date created: 2006-07-18
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= eclair
+PORTVERSION= 20060719
+CATEGORIES= multimedia
+MASTER_SITES= http://mbsd.msk.ru/dist/
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An EFL powered media player
+
+LIB_DEPENDS= ecore.1:${PORTSDIR}/x11/ecore \
+ edje.5:${PORTSDIR}/graphics/edje \
+ emotion.0:${PORTSDIR}/multimedia/emotion \
+ esmart_trans_x11.0:${PORTSDIR}/graphics/esmart \
+ evas.1:${PORTSDIR}/graphics/evas \
+ tag.5:${PORTSDIR}/audio/taglib
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= pkgconfig libxml2
+USE_SQLITE= 3
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/multimedia/eclair/distinfo b/multimedia/eclair/distinfo
new file mode 100644
index 000000000000..8c263cb5157c
--- /dev/null
+++ b/multimedia/eclair/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclair-20060719.tar.bz2) = bffffd12d303bcd87e6cb581962d2378
+SHA256 (eclair-20060719.tar.bz2) = 5cd78965239fff3f527d59a97c58ec35a6ca2d4f0cda4bb6f778c9a02eba4201
+SIZE (eclair-20060719.tar.bz2) = 630780
diff --git a/multimedia/eclair/pkg-descr b/multimedia/eclair/pkg-descr
new file mode 100644
index 000000000000..96fb374faf61
--- /dev/null
+++ b/multimedia/eclair/pkg-descr
@@ -0,0 +1,4 @@
+Mediaplayer for e17 window manager.
+
+Author: MoOm <simon.treny@free.fr>
+WWW: http://www.enlightenment.org/
diff --git a/multimedia/eclair/pkg-plist b/multimedia/eclair/pkg-plist
new file mode 100644
index 000000000000..0d8b4944c8d6
--- /dev/null
+++ b/multimedia/eclair/pkg-plist
@@ -0,0 +1,30 @@
+bin/eclair
+bin/eclair_wsz2edj
+%%DATADIR%%/fonts/Vera.COPYING
+%%DATADIR%%/fonts/VeraBd.ttf
+%%DATADIR%%/fonts/fonts.alias
+%%DATADIR%%/fonts/fonts.dir
+%%DATADIR%%/icons/add_files.png
+%%DATADIR%%/icons/invert_selection.png
+%%DATADIR%%/icons/load_playlist.png
+%%DATADIR%%/icons/open.png
+%%DATADIR%%/icons/playlist.png
+%%DATADIR%%/icons/remove_all.png
+%%DATADIR%%/icons/remove_selected.png
+%%DATADIR%%/icons/remove_unselected.png
+%%DATADIR%%/icons/save_playlist.png
+%%DATADIR%%/icons/search_window.png
+%%DATADIR%%/icons/select_all.png
+%%DATADIR%%/icons/select_none.png
+%%DATADIR%%/icons/windows.png
+%%DATADIR%%/themes/default.edj
+%%DATADIR%%/themes/gant.edj
+%%DATADIR%%/themes/swallow_me.edj
+%%DATADIR%%/widget_themes/default.edj
+%%DATADIR%%/wsz2edj/wsz2edj_edc.tar.gz
+@dirrmtry %%DATADIR%%/wsz2edj
+@dirrmtry %%DATADIR%%/widget_themes
+@dirrmtry %%DATADIR%%/themes
+@dirrmtry %%DATADIR%%/icons
+@dirrmtry %%DATADIR%%/fonts
+@dirrmtry %%DATADIR%%