aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/staroffice5/Makefile3
-rw-r--r--editors/wordperfect/Makefile3
-rw-r--r--games/rollemup/Makefile4
-rw-r--r--graphics/linux-bmrt/Makefile4
-rw-r--r--graphics/linux_glide/Makefile11
-rw-r--r--graphics/netshow/Makefile7
-rw-r--r--lang/ETHOberonV4/Makefile8
-rw-r--r--math/wingz/Makefile4
-rw-r--r--math/wingz3/Makefile4
-rw-r--r--multimedia/netshow/Makefile7
-rw-r--r--print/acroread/Makefile10
-rw-r--r--print/acroread4/Makefile2
-rw-r--r--print/acroread5/Makefile3
-rw-r--r--www/aswedit/Makefile7
14 files changed, 36 insertions, 41 deletions
diff --git a/editors/staroffice5/Makefile b/editors/staroffice5/Makefile
index 50435724976a..1f9ade41a406 100644
--- a/editors/staroffice5/Makefile
+++ b/editors/staroffice5/Makefile
@@ -17,10 +17,11 @@ DISTFILES= applicat.rdb.gz libofa517li.so libsdb517li.so
MAINTAINER= mb@imp.ch
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
ONLY_FOR_ARCHS= i386
NO_CDROM= 'Must be downloaded direct from Sun via www interface'
+
+USE_LINUX= yes
IS_INTERACTIVE= yes
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
EXTRACT_CMD= ${CAT}
diff --git a/editors/wordperfect/Makefile b/editors/wordperfect/Makefile
index 520256ea0f34..479d9c766503 100644
--- a/editors/wordperfect/Makefile
+++ b/editors/wordperfect/Makefile
@@ -15,13 +15,12 @@ EXTRACT_SUFX= .GZ
MAINTAINER= msmith@freebsd.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
NO_CDROM= "LIC: redistribution not allowed"
IS_INTERACTIVE= "requires user interaction for installation"
+USE_LINUX= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
diff --git a/games/rollemup/Makefile b/games/rollemup/Makefile
index 91d3c93da08a..f1c9f594fc64 100644
--- a/games/rollemup/Makefile
+++ b/games/rollemup/Makefile
@@ -14,8 +14,6 @@ DISTNAME= Rollemup
MAINTAINER= sanpei@FreeBSD.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
LICENSE= no-commercial-use
RESTRICTED= You are not allowed to distribute the software by any means. \
You are allowed to download a copy from this site for personal use. \
@@ -23,6 +21,8 @@ RESTRICTED= You are not allowed to distribute the software by any means. \
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+
EXTRACT_ONLY= # empty
NO_PACKAGE= ${RESTRICTED}
NO_CDROM= ${RESTRICTED}
diff --git a/graphics/linux-bmrt/Makefile b/graphics/linux-bmrt/Makefile
index ae9e4a3da4de..e6d15e2744fc 100644
--- a/graphics/linux-bmrt/Makefile
+++ b/graphics/linux-bmrt/Makefile
@@ -13,9 +13,9 @@ DISTNAME= BMRT${PORTVERSION}.linux-glibc2
MAINTAINER= rjoseph@mammalia.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base \
- /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
+RUN_DEPENDS= /compat/linux/usr/X11R6/lib/libGL.so:${PORTSDIR}/graphics/linux_mesa3
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/BMRT2.6
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
index cfb36d01f1eb..fd8439d75f7f 100644
--- a/graphics/linux_glide/Makefile
+++ b/graphics/linux_glide/Makefile
@@ -15,22 +15,17 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_2_4
MAINTAINER= cracauer@cons.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
-PREFIX= /compat/linux/usr
+USE_LINUX_PREFIX=yes
NO_MTREE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Glide2.4
-pre-install:
- @[ -d ${PREFIX} ] || ${MKDIR} ${PREFIX}
-
do-install:
@zcat ${WRKSRC}/dist.tar.gz | \
- (cd ${PREFIX}; tar fx - lib include bin/test00)
- ${MV} ${PREFIX}/bin/test00 ${PREFIX}/bin/test-glide
+ (cd ${PREFIX}/usr; tar fx - lib include bin/test00)
+ ${MV} ${PREFIX}/usr/bin/test00 ${PREFIX}/usr/bin/test-glide
post-install:
-/compat/linux/sbin/ldconfig
diff --git a/graphics/netshow/Makefile b/graphics/netshow/Makefile
index f363019013ca..a2676b19cbc5 100644
--- a/graphics/netshow/Makefile
+++ b/graphics/netshow/Makefile
@@ -14,15 +14,14 @@ EXTRACT_SUFX= .gz
MAINTAINER= dburr@FreeBSD.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
-ONLY_FOR_ARCHS= i386
RESTRICTED= "Commercial software"
NO_CDROM= ${RESTRICTED}
NO_PACKAGE= ${RESTRICTED}
-NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+NO_BUILD= yes
USE_X_PREFIX= yes
pre-extract:
diff --git a/lang/ETHOberonV4/Makefile b/lang/ETHOberonV4/Makefile
index d1bd746ef953..2af989d65a9d 100644
--- a/lang/ETHOberonV4/Makefile
+++ b/lang/ETHOberonV4/Makefile
@@ -14,12 +14,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= jhicks@glenatl.glenayre.com
-# XXX - how to fix the following?
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
-ONLY_FOR_ARCHS= i386
NO_CDROM= licensing
NO_PACKAGE= no version number on distfile
+
+ONLY_FOR_ARCHS= i386
+
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/${UNTAR_DIR}
UNTAR_DIR= usr/local/ETHOberon
diff --git a/math/wingz/Makefile b/math/wingz/Makefile
index 61823bee5a76..03c3326a1767 100644
--- a/math/wingz/Makefile
+++ b/math/wingz/Makefile
@@ -15,12 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
NO_WRKSUBDIR= yes
-
USE_X_PREFIX= yes
post-install:
diff --git a/math/wingz3/Makefile b/math/wingz3/Makefile
index 6f08bb6af38e..6ea08e660801 100644
--- a/math/wingz3/Makefile
+++ b/math/wingz3/Makefile
@@ -13,13 +13,13 @@ EXTRACT_ONLY=
MAINTAINER= mi@aldan.algebra.com
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+NO_PACKAGE= "nothing to build. commercial software"
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_X_PREFIX= yes
NO_BUILD= yes
-NO_PACKAGE= "nothing to build. commercial software"
do-fetch:
#
diff --git a/multimedia/netshow/Makefile b/multimedia/netshow/Makefile
index f363019013ca..a2676b19cbc5 100644
--- a/multimedia/netshow/Makefile
+++ b/multimedia/netshow/Makefile
@@ -14,15 +14,14 @@ EXTRACT_SUFX= .gz
MAINTAINER= dburr@FreeBSD.org
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
-ONLY_FOR_ARCHS= i386
RESTRICTED= "Commercial software"
NO_CDROM= ${RESTRICTED}
NO_PACKAGE= ${RESTRICTED}
-NO_BUILD= yes
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+NO_BUILD= yes
USE_X_PREFIX= yes
pre-extract:
diff --git a/print/acroread/Makefile b/print/acroread/Makefile
index a7ac7a9f4de9..dc399c479efe 100644
--- a/print/acroread/Makefile
+++ b/print/acroread/Makefile
@@ -17,11 +17,12 @@ DISTNAME= ar302lin
DISTNAME= ar302osf
.endif
EXTRACT_SUFX= .tar.Z
+LATEST_LINK= acroread3
MAINTAINER= tg@FreeBSD.org
.if ${ARCH} == "i386"
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+USE_LINUX= yes
.elif ${ARCH} == "alpha"
RUN_DEPENDS= /compat/osf1/usr/shlib/libc.so:${PORTSDIR}/emulators/osf1_base
.endif
@@ -61,9 +62,12 @@ post-install:
.endif
@cd ${PREFIX}/Acrobat3/bin && \
${PATCH} --quiet < ${FILESDIR}/acroread.diff && \
- ${INSTALL_SCRIPT} ${PREFIX}/Acrobat3/bin/acroread ${PREFIX}/bin && \
+ ${INSTALL_SCRIPT} ${PREFIX}/Acrobat3/bin/acroread \
+ ${PREFIX}/bin/acroread3 && \
${RM} acroread.orig
- @${CHMOD} +x ${PREFIX}/bin/acroread
+ @${CHMOD} +x ${PREFIX}/bin/acroread3
+ [ -e ${PREFIX}/bin/acroread ] \
+ || (cd ${PREFIX}/bin ; ${LN} -s acroread3 acroread)
@${ECHO_MSG} "Be sure to read the license agreement in"
@${ECHO_MSG} "${PREFIX}/Acrobat3/Reader/License.pdf"
diff --git a/print/acroread4/Makefile b/print/acroread4/Makefile
index 32e5c21f11ab..173579f00289 100644
--- a/print/acroread4/Makefile
+++ b/print/acroread4/Makefile
@@ -19,7 +19,7 @@ DISTNAME= fdec-rs-405
MAINTAINER= dima@FreeBSD.org
.if ${ARCH} == "i386"
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
+USE_LINUX= yes
.elif ${ARCH} == "alpha"
RUN_DEPENDS= /compat/osf1/usr/shlib/libc.so:${PORTSDIR}/emulators/osf1_base
.endif
diff --git a/print/acroread5/Makefile b/print/acroread5/Makefile
index b28cd55f2e7b..733bf700db07 100644
--- a/print/acroread5/Makefile
+++ b/print/acroread5/Makefile
@@ -15,10 +15,9 @@ DISTNAME= linux-505
.endif
MAINTAINER= osa@FreeBSD.org.ru
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
NO_FILTER_SHLIBS= yes
.if ${ARCH} == "i386"
diff --git a/www/aswedit/Makefile b/www/aswedit/Makefile
index 90abfdc5b4eb..42a78d1c3039 100644
--- a/www/aswedit/Makefile
+++ b/www/aswedit/Makefile
@@ -16,12 +16,13 @@ DISTNAME= asWedit-4.0-i386.linux
MAINTAINER= brett@peloton.runet.edu
-RUN_DEPENDS= /compat/linux/usr/i486-linux-libc5/lib/libc.so.5:${PORTSDIR}/emulators/linux_base
-
-ONLY_FOR_ARCHS= i386
RESTRICTED= "Commercial software"
NO_BUILD= yes
NO_PACKAGE= ${RESTRICTED}
+
+ONLY_FOR_ARCHS= i386
+
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/asWedit-4.0.1
do-install: