aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/kpsk/Makefile1
-rw-r--r--comms/kpsk/files/patch-ac2
2 files changed, 2 insertions, 1 deletions
diff --git a/comms/kpsk/Makefile b/comms/kpsk/Makefile
index f1145318bcc6..7a6c86e367cb 100644
--- a/comms/kpsk/Makefile
+++ b/comms/kpsk/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-D_POSIX_C_SOURCE -I${LOCALBASE}/include" \
USER_LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/kpsk/files/patch-ac b/comms/kpsk/files/patch-ac
index 90d4f573f06e..dc9f911b20fc 100644
--- a/comms/kpsk/files/patch-ac
+++ b/comms/kpsk/files/patch-ac
@@ -5,7 +5,7 @@
#include <stdio.h>
#include <stdlib.h>
+#ifdef __FreeBSD__
-+#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+#else
#include <linux/soundcard.h>
+#endif