aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--java/jdk13/Makefile4
-rw-r--r--java/jdk14/Makefile4
-rw-r--r--java/jdk15/Makefile4
-rw-r--r--java/jdk16/Makefile4
-rw-r--r--java/linux-sun-jdk13/Makefile2
5 files changed, 9 insertions, 9 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index f32224ec5a7d..034053061605 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -133,7 +133,7 @@ TAR= gtar # Necessary for proper extraction of sources
.endif
# Check for JDK sources
-.if !exists(${DISTDIR}/${SRCFILE})
+.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
Because of licensing restrictions, you must fetch the source distribution\n\
@@ -147,7 +147,7 @@ ${DISTDIR}.\n
.endif
# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE})
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
The source distribution exists on your system, but due to\n\
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index f32224ec5a7d..034053061605 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -133,7 +133,7 @@ TAR= gtar # Necessary for proper extraction of sources
.endif
# Check for JDK sources
-.if !exists(${DISTDIR}/${SRCFILE})
+.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
Because of licensing restrictions, you must fetch the source distribution\n\
@@ -147,7 +147,7 @@ ${DISTDIR}.\n
.endif
# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE})
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
The source distribution exists on your system, but due to\n\
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index f32224ec5a7d..034053061605 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -133,7 +133,7 @@ TAR= gtar # Necessary for proper extraction of sources
.endif
# Check for JDK sources
-.if !exists(${DISTDIR}/${SRCFILE})
+.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
Because of licensing restrictions, you must fetch the source distribution\n\
@@ -147,7 +147,7 @@ ${DISTDIR}.\n
.endif
# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE})
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
The source distribution exists on your system, but due to\n\
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index f32224ec5a7d..034053061605 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -133,7 +133,7 @@ TAR= gtar # Necessary for proper extraction of sources
.endif
# Check for JDK sources
-.if !exists(${DISTDIR}/${SRCFILE})
+.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
Because of licensing restrictions, you must fetch the source distribution\n\
@@ -147,7 +147,7 @@ ${DISTDIR}.\n
.endif
# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE})
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE= :\n\
The source distribution exists on your system, but due to\n\
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index db005a730ba2..a8aec5fc79e0 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -36,7 +36,7 @@ DOWNLOAD_URL?= http://java.sun.com/webapps/download/Display?BundleId=7479
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE= You must manually fetch the Java 2 Development Kit ${PORTVERSION}\
archive (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL},\
download the "Linux GNUZIP Tar shell script" into ${DISTDIR} and\