aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/i386-rtems-gdb/Makefile2
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::igen::lf.c51
-rw-r--r--devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c51
3 files changed, 103 insertions, 1 deletions
diff --git a/devel/i386-rtems-gdb/Makefile b/devel/i386-rtems-gdb/Makefile
index 71cc1116e9d5..4a52e955c67e 100644
--- a/devel/i386-rtems-gdb/Makefile
+++ b/devel/i386-rtems-gdb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdb
PORTVERSION= 5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gdb
diff --git a/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c b/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c
new file mode 100644
index 000000000000..5bc12da1da65
--- /dev/null
+++ b/devel/i386-rtems-gdb/files/patch-sim::igen::lf.c
@@ -0,0 +1,51 @@
+--- gdb-5.2/sim/igen/lf.c.orig Thu Apr 15 21:35:05 1999
++++ gdb-5.2/sim/igen/lf.c Mon Feb 16 08:13:36 2004
+@@ -259,27 +259,27 @@
+ case lf_is_c:
+ case lf_is_h:
+ nr += lf_printf(file, "\
+-/* This file is part of the program psim.
+-
+- Copyright (C) 1994-1997, Andrew Cagney <cagney@highland.com.au>
+-
+- This program is free software; you can redistribute it and/or modify
+- it under the terms of the GNU General Public License as published by
+- the Free Software Foundation; either version 2 of the License, or
+- (at your option) any later version.
+-
+- This program is distributed in the hope that it will be useful,
+- but WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+- GNU General Public License for more details.
+-
+- You should have received a copy of the GNU General Public License
+- along with this program; if not, write to the Free Software
+- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+-
+- --
+-
+- This file was generated by the program %s */
++/* This file is part of the program psim.\
++\
++ Copyright (C) 1994-1997, Andrew Cagney <cagney@highland.com.au>\
++\
++ This program is free software; you can redistribute it and/or modify\
++ it under the terms of the GNU General Public License as published by\
++ the Free Software Foundation; either version 2 of the License, or\
++ (at your option) any later version.\
++\
++ This program is distributed in the hope that it will be useful,\
++ but WITHOUT ANY WARRANTY; without even the implied warranty of\
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\
++ GNU General Public License for more details.\
++ \
++ You should have received a copy of the GNU General Public License\
++ along with this program; if not, write to the Free Software\
++ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.\
++ \
++ --\
++\
++ This file was generated by the program %s */\
+ ", filter_filename(file->program));
+ break;
+ default:
diff --git a/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c b/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c
new file mode 100644
index 000000000000..441508fc20a1
--- /dev/null
+++ b/devel/i386-rtems-gdb/files/patch-sim::ppc::lf.c
@@ -0,0 +1,51 @@
+--- gdb-5.2/sim/ppc/lf.c.orig Thu Apr 15 21:35:11 1999
++++ gdb-5.2/sim/ppc/lf.c Mon Feb 16 08:09:23 2004
+@@ -274,27 +274,27 @@
+ case lf_is_c:
+ case lf_is_h:
+ nr += lf_printf(file, "\
+-/* This file is part of the program psim.
+-
+- Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>
+-
+- This program is free software; you can redistribute it and/or modify
+- it under the terms of the GNU General Public License as published by
+- the Free Software Foundation; either version 2 of the License, or
+- (at your option) any later version.
+-
+- This program is distributed in the hope that it will be useful,
+- but WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+- GNU General Public License for more details.
+-
+- You should have received a copy of the GNU General Public License
+- along with this program; if not, write to the Free Software
+- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+-
+- --
+-
+- This file was generated by the program %s */
++/* This file is part of the program psim.\
++\
++ Copyright (C) 1994-1995, Andrew Cagney <cagney@highland.com.au>\
++\
++ This program is free software; you can redistribute it and/or modify\
++ it under the terms of the GNU General Public License as published by\
++ the Free Software Foundation; either version 2 of the License, or\
++ (at your option) any later version.\
++\
++ This program is distributed in the hope that it will be useful,\
++ but WITHOUT ANY WARRANTY; without even the implied warranty of\
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the\
++ GNU General Public License for more details.\
++ \
++ You should have received a copy of the GNU General Public License\
++ along with this program; if not, write to the Free Software\
++ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.\
++ \
++ --\
++\
++ This file was generated by the program %s */\
+ ", filter_filename(file->program));
+ break;
+ default: