aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/solfege/Makefile3
-rw-r--r--misc/solfege/Makefile3
2 files changed, 6 insertions, 0 deletions
diff --git a/audio/solfege/Makefile b/audio/solfege/Makefile
index 85c4bed944ba..cccb421741fb 100644
--- a/audio/solfege/Makefile
+++ b/audio/solfege/Makefile
@@ -39,5 +39,8 @@ post-patch:
@${REINPLACE_CMD} -e "s|[(]datadir[)]/locale|(prefix)/share/locale|g" ${WRKSRC}/po/Makefile
@${GREP} -lR "/usr/bin/python2.2" ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e "s,/usr/bin/python2.2,${SETENV} python,"
+ @${REINPLACE_CMD} -e "s|python2.2|${PYTHON_CMD}|" ${WRKSRC}/online-docs/Rules.make
+ @${REINPLACE_CMD} -e 's|\(python2.2 python2.1\)|${PYTHON_VERSION} \1|' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/misc/solfege/Makefile b/misc/solfege/Makefile
index 85c4bed944ba..cccb421741fb 100644
--- a/misc/solfege/Makefile
+++ b/misc/solfege/Makefile
@@ -39,5 +39,8 @@ post-patch:
@${REINPLACE_CMD} -e "s|[(]datadir[)]/locale|(prefix)/share/locale|g" ${WRKSRC}/po/Makefile
@${GREP} -lR "/usr/bin/python2.2" ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e "s,/usr/bin/python2.2,${SETENV} python,"
+ @${REINPLACE_CMD} -e "s|python2.2|${PYTHON_CMD}|" ${WRKSRC}/online-docs/Rules.make
+ @${REINPLACE_CMD} -e 's|\(python2.2 python2.1\)|${PYTHON_VERSION} \1|' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>