aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/linux-f10-fontconfig/Makefile13
-rw-r--r--x11-fonts/linux-f10-fontconfig/pkg-plist2
-rw-r--r--x11-fonts/linux-f8-fontconfig/Makefile13
-rw-r--r--x11-fonts/linux-f8-fontconfig/pkg-plist2
-rw-r--r--x11-fonts/linux-fontconfig/Makefile13
-rw-r--r--x11-fonts/linux-fontconfig/pkg-plist2
6 files changed, 27 insertions, 18 deletions
diff --git a/x11-fonts/linux-f10-fontconfig/Makefile b/x11-fonts/linux-f10-fontconfig/Makefile
index e8e5eb54bf25..fd8d8c954c47 100644
--- a/x11-fonts/linux-f10-fontconfig/Makefile
+++ b/x11-fonts/linux-f10-fontconfig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fontconfig
PORTVERSION= 2.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-fonts linux
DISTNAME= ${PORTNAME}-${PORTVERSION}-13
@@ -24,10 +24,15 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
BRANDELF_DIRS= usr/bin
+# We will use some other configuration file, so delete a linux one
+# Don't let the linux fc-cache mess up the native cache file
post-extract:
- ${RM} ${WRKSRC}/etc/fonts/fonts.conf
+ @${RM} ${WRKSRC}/etc/fonts/fonts.conf \
+ ${WRKSRC}/usr/bin/fc-cache \
+ ${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
-post-install:
- ${INSTALL_DATA} ${FILESDIR}/fonts.conf ${PREFIX}/etc/fonts/fonts.conf
+# Here is our configuration file
+post-patch:
+ @${CAT} ${FILESDIR}/fonts.conf | ${SED} 's:/usr/X11R6:${LOCALBASE}:g' > ${WRKSRC}/etc/fonts/fonts.conf
.include <bsd.port.mk>
diff --git a/x11-fonts/linux-f10-fontconfig/pkg-plist b/x11-fonts/linux-f10-fontconfig/pkg-plist
index cb1f841b2938..918babda115a 100644
--- a/x11-fonts/linux-f10-fontconfig/pkg-plist
+++ b/x11-fonts/linux-f10-fontconfig/pkg-plist
@@ -1,7 +1,6 @@
etc/fonts/fonts.conf
etc/fonts/fonts.dtd
etc/fonts/local.conf
-usr/bin/fc-cache
usr/bin/fc-list
usr/lib/libfontconfig.so.1
usr/lib/libfontconfig.so.1.0.4
@@ -10,7 +9,6 @@ usr/share/doc/fontconfig-%%PORTVERSION%%/COPYING
usr/share/doc/fontconfig-%%PORTVERSION%%/README
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.html
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.txt
-usr/share/man/man1/fc-cache.1.gz
usr/share/man/man1/fc-list.1.gz
usr/share/man/man5/fonts-conf.5.gz
@dirrm etc/fonts
diff --git a/x11-fonts/linux-f8-fontconfig/Makefile b/x11-fonts/linux-f8-fontconfig/Makefile
index e8e5eb54bf25..fd8d8c954c47 100644
--- a/x11-fonts/linux-f8-fontconfig/Makefile
+++ b/x11-fonts/linux-f8-fontconfig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fontconfig
PORTVERSION= 2.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-fonts linux
DISTNAME= ${PORTNAME}-${PORTVERSION}-13
@@ -24,10 +24,15 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
BRANDELF_DIRS= usr/bin
+# We will use some other configuration file, so delete a linux one
+# Don't let the linux fc-cache mess up the native cache file
post-extract:
- ${RM} ${WRKSRC}/etc/fonts/fonts.conf
+ @${RM} ${WRKSRC}/etc/fonts/fonts.conf \
+ ${WRKSRC}/usr/bin/fc-cache \
+ ${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
-post-install:
- ${INSTALL_DATA} ${FILESDIR}/fonts.conf ${PREFIX}/etc/fonts/fonts.conf
+# Here is our configuration file
+post-patch:
+ @${CAT} ${FILESDIR}/fonts.conf | ${SED} 's:/usr/X11R6:${LOCALBASE}:g' > ${WRKSRC}/etc/fonts/fonts.conf
.include <bsd.port.mk>
diff --git a/x11-fonts/linux-f8-fontconfig/pkg-plist b/x11-fonts/linux-f8-fontconfig/pkg-plist
index cb1f841b2938..918babda115a 100644
--- a/x11-fonts/linux-f8-fontconfig/pkg-plist
+++ b/x11-fonts/linux-f8-fontconfig/pkg-plist
@@ -1,7 +1,6 @@
etc/fonts/fonts.conf
etc/fonts/fonts.dtd
etc/fonts/local.conf
-usr/bin/fc-cache
usr/bin/fc-list
usr/lib/libfontconfig.so.1
usr/lib/libfontconfig.so.1.0.4
@@ -10,7 +9,6 @@ usr/share/doc/fontconfig-%%PORTVERSION%%/COPYING
usr/share/doc/fontconfig-%%PORTVERSION%%/README
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.html
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.txt
-usr/share/man/man1/fc-cache.1.gz
usr/share/man/man1/fc-list.1.gz
usr/share/man/man5/fonts-conf.5.gz
@dirrm etc/fonts
diff --git a/x11-fonts/linux-fontconfig/Makefile b/x11-fonts/linux-fontconfig/Makefile
index e8e5eb54bf25..fd8d8c954c47 100644
--- a/x11-fonts/linux-fontconfig/Makefile
+++ b/x11-fonts/linux-fontconfig/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fontconfig
PORTVERSION= 2.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-fonts linux
DISTNAME= ${PORTNAME}-${PORTVERSION}-13
@@ -24,10 +24,15 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
BRANDELF_DIRS= usr/bin
+# We will use some other configuration file, so delete a linux one
+# Don't let the linux fc-cache mess up the native cache file
post-extract:
- ${RM} ${WRKSRC}/etc/fonts/fonts.conf
+ @${RM} ${WRKSRC}/etc/fonts/fonts.conf \
+ ${WRKSRC}/usr/bin/fc-cache \
+ ${WRKSRC}/usr/share/man/man1/fc-cache.1.gz
-post-install:
- ${INSTALL_DATA} ${FILESDIR}/fonts.conf ${PREFIX}/etc/fonts/fonts.conf
+# Here is our configuration file
+post-patch:
+ @${CAT} ${FILESDIR}/fonts.conf | ${SED} 's:/usr/X11R6:${LOCALBASE}:g' > ${WRKSRC}/etc/fonts/fonts.conf
.include <bsd.port.mk>
diff --git a/x11-fonts/linux-fontconfig/pkg-plist b/x11-fonts/linux-fontconfig/pkg-plist
index cb1f841b2938..918babda115a 100644
--- a/x11-fonts/linux-fontconfig/pkg-plist
+++ b/x11-fonts/linux-fontconfig/pkg-plist
@@ -1,7 +1,6 @@
etc/fonts/fonts.conf
etc/fonts/fonts.dtd
etc/fonts/local.conf
-usr/bin/fc-cache
usr/bin/fc-list
usr/lib/libfontconfig.so.1
usr/lib/libfontconfig.so.1.0.4
@@ -10,7 +9,6 @@ usr/share/doc/fontconfig-%%PORTVERSION%%/COPYING
usr/share/doc/fontconfig-%%PORTVERSION%%/README
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.html
usr/share/doc/fontconfig-%%PORTVERSION%%/fontconfig-user.txt
-usr/share/man/man1/fc-cache.1.gz
usr/share/man/man1/fc-list.1.gz
usr/share/man/man5/fonts-conf.5.gz
@dirrm etc/fonts