aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/muine/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index c61b556ef7a3..05803f7f6595 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -3,12 +3,12 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.54 2007/01/26 03:17:25 tmclau02 Exp $
+# $Id: Makefile,v 1.56 2007/10/10 16:52:55 killfill Exp $
#
PORTNAME= muine
PORTVERSION= 0.8.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio gnome
MASTER_SITES= http://muine-player.org/releases/
@@ -23,6 +23,7 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
USE_GMAKE= yes
+USE_GETTEXT= yes
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui gnomesharp20
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
@@ -31,6 +32,8 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
GACUTIL_FLAGS="/package muine /gacdir $(libdir) /root $(libdir)"
+CONFIGURE_ARGS+= --enable-compile-warnings=maximum
+
GCONF_SCHEMAS= muine.schemas
OPTIONS= XINE "Enable Xine backend" off \