aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/cyrus-imapd/Makefile7
-rw-r--r--mail/cyrus-imapd2/Makefile7
-rw-r--r--mail/cyrus-imapd22/Makefile7
-rw-r--r--mail/cyrus-imapd23/Makefile7
-rw-r--r--mail/cyrus-imapd24/Makefile7
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile7
-rw-r--r--security/cyrus-sasl2/Makefile7
7 files changed, 14 insertions, 35 deletions
diff --git a/mail/cyrus-imapd/Makefile b/mail/cyrus-imapd/Makefile
index d3f423a66a26..50db0af6412a 100644
--- a/mail/cyrus-imapd/Makefile
+++ b/mail/cyrus-imapd/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS= sasl.8:${PORTSDIR}/security/cyrus-sasl \
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
+USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -35,6 +36,7 @@ CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-dbdir=${LOCALBASE} \
--with-auth=unix \
--with-com_err \
+ --with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
.if defined(WITH_SNMP)
@@ -66,11 +68,6 @@ HTDOCS= anoncvs bugs changes faq feedback index install-admin-mb \
.include <bsd.port.pre.mk>
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|/etc/|${PREFIX}/etc/|" \
${WRKSRC}/tools/mkimap
diff --git a/mail/cyrus-imapd2/Makefile b/mail/cyrus-imapd2/Makefile
index 3684af670f90..74e769205d43 100644
--- a/mail/cyrus-imapd2/Makefile
+++ b/mail/cyrus-imapd2/Makefile
@@ -26,6 +26,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
USE_RC_SUBR= YES
+USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -36,6 +37,7 @@ CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-bdb-libdir=${LOCALBASE}/lib \
--with-auth=unix \
--with-com_err \
+ --with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
.if defined(WITH_BDB_VER)
@@ -115,11 +117,6 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
-USE_OPENSSL= yes
-#.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-#.endif
-
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
RC_SUBR=${RC_SUBR}
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index 60ab2850cd12..3cdffcbe01ff 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -24,6 +24,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
USE_RC_SUBR= YES
+USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -34,6 +35,7 @@ CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-bdb-libdir=${LOCALBASE}/lib \
--with-auth=unix \
--with-com_err \
+ --with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
.if defined(WITH_BDB_VER)
@@ -137,11 +139,6 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
RC_SUBR=${RC_SUBR}
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 60ab2850cd12..3cdffcbe01ff 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -24,6 +24,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
USE_RC_SUBR= YES
+USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -34,6 +35,7 @@ CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-bdb-libdir=${LOCALBASE}/lib \
--with-auth=unix \
--with-com_err \
+ --with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
.if defined(WITH_BDB_VER)
@@ -137,11 +139,6 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
RC_SUBR=${RC_SUBR}
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 60ab2850cd12..3cdffcbe01ff 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -24,6 +24,7 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
USE_RC_SUBR= YES
+USE_OPENSSL= yes
USE_PERL5= yes
USE_REINPLACE= YES
GNU_CONFIGURE= YES
@@ -34,6 +35,7 @@ CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-bdb-libdir=${LOCALBASE}/lib \
--with-auth=unix \
--with-com_err \
+ --with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
.if defined(WITH_BDB_VER)
@@ -137,11 +139,6 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSD
RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
-.endif
-
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
RC_SUBR=${RC_SUBR}
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index eae84c6999f2..a43e8ee4f942 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -29,6 +29,7 @@ DOCSDIR= ${PREFIX}/share/doc/cyrus-sasl2
USE_RC_SUBR= YES
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -39,6 +40,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -101,11 +103,6 @@ CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
CONFIGURE_ARGS+=--disable-krb4
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index b1efaae1498c..ab76327eca44 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -38,6 +38,7 @@ MAN3= sasl.3 sasl_authorize_t.3 sasl_auxprop.3 \
sasl_user_exists.3 sasl_verifyfile_t.3
MAN8= sasldblistusers2.8 saslpasswd2.8
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -48,6 +49,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -142,11 +144,6 @@ CONFIGURE_ARGS+=--disable-krb4
EBONES= "@comment "
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \